locked
Site content type : Title column name change RRS feed

  • Question

  • Please Help!

    I've inadvertently changed the default column 'Title' to 'Summary' on the Item content type, and now all new lists/libraries are created with this new column name instead of Title.

    When I try to revert back to Title it says "The Column name that you entered is already in use or reserved. choose another name"

    This is MOSS 2007.

    All suggestions gratefully received!

    Regards

    Russ


    Cheers Russ
    Tuesday, December 20, 2011 3:27 PM

Answers

  • There is a solution to this -  http://sharepointpratik.wordpress.com/2011/07/28/the-column-name-you-have-entered-is-already-in-use-or-reserved-choose-another-name/ 

     

    Let us know if this helps


    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by RussHank Wednesday, December 21, 2011 7:13 AM
    Tuesday, December 20, 2011 4:03 PM
  • Hi RussHank,

     

    The JavaScript sentence worked in my computer. You can use it trustingly following these steps:

    1.       Open the site content type which you changed by directory site setting > site content type gallery > site content type;

    2.       Click the Summary in the Columns section.

    3.       In the Change Site Content Type Column page, click Edit site column in new window link.

    4.       In the Change Site Column page, change ‘Summary’ to ‘Title’, then type the JavaScript sentence (javascript:g_FieldName={};alert(‘Successfully cleared forbidden columns’);) into the browser address bar. Click OK in the change site column page.

     

    Please let we know whether it work when you feel free.

    Thanks!


    Wayne Fan

    TechNet Community Support

    • Marked as answer by RussHank Wednesday, December 21, 2011 7:13 AM
    Wednesday, December 21, 2011 3:55 AM

All replies

  • There is a solution to this -  http://sharepointpratik.wordpress.com/2011/07/28/the-column-name-you-have-entered-is-already-in-use-or-reserved-choose-another-name/ 

     

    Let us know if this helps


    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by RussHank Wednesday, December 21, 2011 7:13 AM
    Tuesday, December 20, 2011 4:03 PM
  • Is it really this simple?!

    Sorry I'm a bit nervious as we don't have a test server to trial this.

    Thanks.

    Russ.

    And this works for switching back to 'Title' ??!?

     


    Cheers Russ
    • Edited by RussHank Tuesday, December 20, 2011 4:18 PM
    Tuesday, December 20, 2011 4:11 PM
  • Hi RussHank,

     

    The JavaScript sentence worked in my computer. You can use it trustingly following these steps:

    1.       Open the site content type which you changed by directory site setting > site content type gallery > site content type;

    2.       Click the Summary in the Columns section.

    3.       In the Change Site Content Type Column page, click Edit site column in new window link.

    4.       In the Change Site Column page, change ‘Summary’ to ‘Title’, then type the JavaScript sentence (javascript:g_FieldName={};alert(‘Successfully cleared forbidden columns’);) into the browser address bar. Click OK in the change site column page.

     

    Please let we know whether it work when you feel free.

    Thanks!


    Wayne Fan

    TechNet Community Support

    • Marked as answer by RussHank Wednesday, December 21, 2011 7:13 AM
    Wednesday, December 21, 2011 3:55 AM
  • Hi Wayne,

    I get an 'Error on page' message and no dialog!? Any ideas?

    Cheers

    Russ

     

    Wednesday, December 21, 2011 6:49 AM
  • Got it, thanks both.

    The issue is caused by the speach marks in the alert dialog.

    Merry Xmas!

    Russ

    Wednesday, December 21, 2011 7:13 AM