locked
The SharePoint 2010 VSS Writer service has been stopped RRS feed

  • Question

  • I have tried looking at other posts about this but none are relevant.

    Every morning, in my network summary report, I get notice of this error, every single morning, and period checks throughout the day show that this service has stopped again.

    I open services.msc, change the service from "disabled" (for some reason when it stops it goes back to "disabled") to automatic and start the service. I wait for a few minutes and all seems fine, but if I check again in a couple hours, without fail, the SharePoint 2010 VSS Writer service is stopped again.

    What do i need to do to prevent this service from stopping?

    Thanks,

    Rob


    Robert Weiss
    Sunday, July 3, 2011 1:37 PM

Answers

  • Ok, this issue has FINALLY been resolved. Keith MacMartin of rbTechnologies in East Montpelier, Vermont, our IT consultants, came up with the following solution:

    =============from Keith==========

    Changing the password in Active Directory and for the Sharepoint services themselves didn't seem to be sufficient, so I used the Sharepoint Central Administration Console to set the password for the spfarm user to the same password I had already set for Active Directory. This seems to be the most important piece.

    Adding the Sharepoint Foundation to Windows Server Backup required running the command "stsadm -o registerwsswriter" from the command line (does not require Powershell). This was actually how I figured out that I needed to change the spfarm password in Sharepoint Central Administration - the first time I ran this command it complained that the passwords were not the same (the AD password and the Sharepoint password).

    ============end==============

    So, the end result is that the SharePoint 2010 VSS writer service STAYS RUNNING, and the SharePoint foundation is now listed in the apllications of our SBS backup.

    -Rob


    Robert Weiss
    • Marked as answer by Net-dude Monday, August 1, 2011 2:35 PM
    Monday, August 1, 2011 2:35 PM

All replies

  • Did you apply the Sharepoint Service Pack 1 update?  And if so, did you run the post installation psconfig?

    http://msmvps.com/blogs/bradley/archive/2011/06/30/remember-you-must-run-psconfig-after-sharepoint-sp1-is-installed.aspx

     


    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, July 3, 2011 3:12 PM
  • Yes I have already updated to SP1 and have already run the post-install psconfig from the command window.

    Robert Weiss
    Sunday, July 3, 2011 11:21 PM
  • Hi Rob,

    Thank you for your post.

    Please try to download and run SBS 2011 BPA on your server to fix your issue.
    Are there any events log for the VSS writer service stopped?

    If there are more inquiries on this issue, please feel free to let us know.


    Regards,
    Rick Tan
    • Edited by Rick Tan Friday, July 8, 2011 3:46 AM
    Tuesday, July 5, 2011 5:19 AM
  • I alreaqdy ran the Best Practices Analyzer last week and it revealed nothing 9I mean literally..it came back with hardly any info, basically giving the impression that the server was running perfectly, which it isn't.

    So, I uninstalled, then reinstalled BPA, and got the same result.

    ???


    Robert Weiss
    Thursday, July 7, 2011 1:31 PM
  • Hi Rob,

    Thank you for your update.

    Please verify the VSS Writer service running on domain\spfarm account and Restart the Service setting in Recovery Tab in services.msc console.

    If there are more inquiries on this issue, please feel free to let us know.


    Regards,
    Rick Tan

    Friday, July 8, 2011 3:42 AM
  • Hi,

    Do you notice service failure/crash kind of events in event log? If so, please share.

    Can you also post the alert in monitoring report?

     

     

     


    Ketan Thakkar | Microsoft Online Community Support
    Tuesday, July 12, 2011 10:28 AM
    Answerer
  • Hi Rob!

    I had the same issue a couple of day ago on a SBS2011 new installation after change of language on sharepoint. I had to go in under services and try to start the service but I got logon problems. I started active directory users and computers search for spfarm, then reset the password. Then i changed the log on password under all services running as spfarm and started them up. Now it works like a charm.

    Please give a vote or mark as "answer" if this was helpful.


    Best regards Jimmy Svensson MCTS SBS Server Configuration MCTS Windows 7 Configuration Please remember to click “Mark as Answer” on the post that helps you.
    • Marked as answer by Rick Tan Friday, July 15, 2011 1:10 AM
    • Unmarked as answer by Rick Tan Friday, July 15, 2011 1:11 AM
    • Proposed as answer by Rick Tan Friday, July 15, 2011 1:11 AM
    • Marked as answer by Rick Tan Friday, July 22, 2011 1:44 AM
    • Unmarked as answer by Net-dude Monday, August 1, 2011 2:31 PM
    Tuesday, July 12, 2011 11:10 AM
  • Been on vacation, just got back, so sorry for slowness of response.

    I will look into this deeper today and read/try your suggestions. I will then post some comments on this by tomorrow.

    Thanks for all the input.

    -Rob


    Robert Weiss
    Tuesday, July 12, 2011 12:54 PM
  • Ok, this issue has FINALLY been resolved. Keith MacMartin of rbTechnologies in East Montpelier, Vermont, our IT consultants, came up with the following solution:

    =============from Keith==========

    Changing the password in Active Directory and for the Sharepoint services themselves didn't seem to be sufficient, so I used the Sharepoint Central Administration Console to set the password for the spfarm user to the same password I had already set for Active Directory. This seems to be the most important piece.

    Adding the Sharepoint Foundation to Windows Server Backup required running the command "stsadm -o registerwsswriter" from the command line (does not require Powershell). This was actually how I figured out that I needed to change the spfarm password in Sharepoint Central Administration - the first time I ran this command it complained that the passwords were not the same (the AD password and the Sharepoint password).

    ============end==============

    So, the end result is that the SharePoint 2010 VSS writer service STAYS RUNNING, and the SharePoint foundation is now listed in the apllications of our SBS backup.

    -Rob


    Robert Weiss
    • Marked as answer by Net-dude Monday, August 1, 2011 2:35 PM
    Monday, August 1, 2011 2:35 PM
  • Hi all

    Although this issue is resolved, I would like to ask a question to the solution, as I need it for a current installation:

    How do you successfully change the password of DOMAIN\spfarm in SP Central Administration? I always get the error that the new password doesn't match the password requirement. I have chosen a complex password with 20 digits.

    As Information: I am trying to fix this error on a Small Business Server 2011.

     

    Many thanks,
    Marianne

    Tuesday, November 22, 2011 4:27 PM
  • Same problem same system as MarianneK.  Any updates?  I cannot change the SPFARM password in SP Central Administration.

    David Boucher




    Tuesday, March 6, 2012 3:32 AM
  • What you have to do is reset in AD your SPFarm password. So find your your SPFarm user right click and reset password. (this expires sometimes)
    Tuesday, April 3, 2012 3:21 PM
  • and if that did not work. What also can be the problem is that some service is running as local. you have to change this to network.

    I am not exactly anymore but there are some good reviews where you can change this from local to run as network. After you change that you can get in the SP Central administration again. ( strange but thue)

    Tuesday, April 3, 2012 3:28 PM
  • You don't change the SPFARM password in CA, you change it in AD UC, then you go into CA and check Change Password Now but don't use generate or new value, use existing and enter the same password you set in AD UC.

    Hope that resolves it.

    You may also have to adjust the password for any services that the user is running (ie. Sharepoint VSS Writer)

    If you don't do it this way, you will most likely be told that your password doesn't meet the requirements because since you just changed it in AD UC, trying to change it again via CA fails because the default minimum time for PW changes is 24 hours.

    You do this by going to services.msc, right click the service and set the new password in the log on tab.


    • Edited by IntrebuloN Thursday, April 5, 2012 5:12 PM Added "if you don't do it this way..."
    Thursday, April 5, 2012 5:10 PM