none
FIM 2010 Sync service is not accepting french characters? RRS feed

  • Question

  • Hello,

    I have an issue that I've been unable to find an answer for. 

    In the event that someone is only using FIM 2010 Sync Service, How does one get language pack support? I get the sense that I need to install the full product just to get to end result which I am suspecting is French accent support for the Sync service. Is that true?

    The issue that I am receiving is invalid-dn errors (Multiple values were specified for an attribute that can have only one value)for those with French accents such as é in their name and I am receiving dn-attributes-failure (The name reference is invalid) for those who's manager name contains the accent such as é.

    For the users with the accent it also wants to place their English translated names in brackets. for example IF I had someone with the name Andrée.Smith the import in my Ad will look like Andrée.Smith(Andree.Smith). I really don't care about the accent, but it's in an AD I don't manage and would like to find away to correct this translation.

    Any advice out there? I can provide more details if required.

    Thank you in advance!


    John


    • Edited by Incubeus Tuesday, December 15, 2015 8:19 PM grammar
    Tuesday, December 15, 2015 8:06 PM

All replies

  • Haven't tried French characters, but I'd expect that AD and Sync handles them just fine. What I think, you need to make sure, is that you're are indeed using the EscapeDNComponent function to construct your DN's for the AD MA - otherwise you will have errors like the ones you mention.

    If you are using Sync Rules from the FIM Portal, there is a option to use EscapeDN in there, otherwise you need to escape in the source where you're getting the DN from or in your provisioning code.

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Wednesday, December 16, 2015 8:54 PM
  • Thanks Soren,

    Sorry for the delay getting back..

    I am looking into your suggestion to see how I can do the EscapeDN from the MA/sync service without portal.

    Unfortunately I didn't use the portal function as it required sharepoint to access the mentioned sync rules. I only have the sync service installed using MA agents.  I recently installed the "service and language packs" as I originally only installed the sync service for licencing reasons, but no change. I also tried changing the SQL collation (Latin1_General_CI_AS) to the recommended sharepoint collation of Latin1_General_CI_AS_KS_WS and no dice.

    I will contacting MS support today to see what other suggestions they have hiding in their private SOX DB.

    I will be sure to come back and share if a solution is found.

    Thanks again :)


    John

    Tuesday, January 5, 2016 6:51 PM
  • If you're not using the portal, you could have a look at my provisioning framework which have support for escaping DN's

    Have a look here - http://fimmre.codeplex.com/


    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Tuesday, January 5, 2016 8:07 PM
  • Hi Soren,

    Not that this is forgotten or resolved. I just wanted to provide you an update that so far MS escalation support has not been able to find a solution. They were able to repro the issue and they are working on it in a lab environment, And being that they requested more time it should be interesting on what the outcome will be. :)

    I will post again when I hear back from them.

    Thank you

    John


    John

    Tuesday, January 26, 2016 9:45 PM