locked
Command Execution failed: Cannot find any suitable disks for database files. RRS feed

  • Question

  • I am deploying Lync Server Standard Edition on Windows Server 2008 R2.  

    The Server exists on a Virtual Machine.  

    I have MS SQL Server 2008 R2 running on the same machine.  

    The topology Publisher succeeded without error and the SQL store is located at lync01.contoso.com\rtc with the following information:

    FQDN:  lync01.contoso.com

    SQl Instance:  rtc

    Dependent pools:  lync01.contoso.com

    This SQL store cannot be modified because it hosts the user store for a standard edition server.

    This SQL store cannot be modified because it hosts the CMS.

     

    However When i attempt to complete step two of the Deployment Wizard it fails with the following error:

    Command execution failed:  Cannot find any suitable disks for database files.  Database paths must be specified manually.

     

    How do I resolve this error?

     

     

     

    Friday, January 28, 2011 6:22 PM

Answers

  • The point to note is that Lync Server 2010 Standard Edition comes with SQL 2008 SP1 Express Edition. This must be used for the CMS and Lync database for this edition of Lync Server. Otherwise, SQL Server 2005 SP3 or SQL Server 2008 SP1 must be setup as a backend database for a Lync Server 2010 Enterprise Edition Front-End Pool. Fyi, SQL Server 2008 R2 is still not a supported version for use with Lync. Hope this helps. Please share with us if this helps. Thanks.
    TechNet Forum Moderator (Unified Communications) - http://www.leedesmond.com
    • Marked as answer by bakesale Friday, January 28, 2011 8:11 PM
    Friday, January 28, 2011 7:43 PM

All replies

  • The point to note is that Lync Server 2010 Standard Edition comes with SQL 2008 SP1 Express Edition. This must be used for the CMS and Lync database for this edition of Lync Server. Otherwise, SQL Server 2005 SP3 or SQL Server 2008 SP1 must be setup as a backend database for a Lync Server 2010 Enterprise Edition Front-End Pool. Fyi, SQL Server 2008 R2 is still not a supported version for use with Lync. Hope this helps. Please share with us if this helps. Thanks.
    TechNet Forum Moderator (Unified Communications) - http://www.leedesmond.com
    • Marked as answer by bakesale Friday, January 28, 2011 8:11 PM
    Friday, January 28, 2011 7:43 PM
  • The point to note is that Lync Server 2010 Standard Edition comes with SQL 2008 SP1 Express Edition. This must be used for the CMS and Lync database for this edition of Lync Server. Otherwise, SQL Server 2005 SP3 or SQL Server 2008 SP1 must be setup as a backend database for a Lync Server 2010 Enterprise Edition Front-End Pool. Fyi, SQL Server 2008 R2 is still not a supported version for use with Lync. Hope this helps. Please share with us if this helps. Thanks.
    TechNet Forum Moderator (Unified Communications) - http://www.leedesmond.com

    Thank you, this was successful.  However I am unable to enable users.  I recieve the error insufficient access rights.  However I am logged into the Domain administrator account who is a member of the group CSUserAdministrator and CSAdministrator.  

    In addition to this under the Control Panel>Topology The following Services refuse to start:  ConferencingServer, Registrar, UserServer

     

    Should I open a new thread?

    Friday, January 28, 2011 8:14 PM
  • I don't have SQL 2008 R2 installed, but still have the same problem. I set topolgy for SE front end. I went through all the steps, including Prepare first Standard Edition server and publishing my topology, then on Install or Update Lync Server System step 2 got Cannot find suitable disks for database files error. The C:\Program Files\Microsoft SQL Server\MSSQL10.RTCLOCAL\MSSQL\DATA is created with the files, but Install-CSDatabase -LocalDatabase fails on invalid path. As far as I am reading Install-CSDatabse has an option to specify path explicitly, but how do I set environment variables, so the installation script will work with the default. Or at least what's the lync power shell command to show me what the path is set to.

    Thanks, Jack

    Friday, April 15, 2011 10:16 PM
  • Yeah I have the same problem and I just cant find the solution to the problem. Anyone can help? Thanks
    Thursday, June 23, 2011 3:25 PM
  • I have the same problem.Any idea?
    Friday, July 15, 2011 11:58 AM
  • I'm still have this same problem. The difference is that I did not install SQL Server 2008 R2. I did a stand-alone installation on a single computer and allowed Lync Setup to install SQL Server Express 2008 on the machine. I have made some changes since the intial deployment and when I try to re-run the setup after re-deploying the topology I get:

    Command execution failed: Cannot find any suitable disks for database files. Database paths must be specified manually.

    I have found very little information about the issue online. Any ideas?

    Thanks!


    Sunday, July 31, 2011 5:12 AM
  • Gents, after a lot of debugging (and some MSDN article reading...) I have finally found the source of my issue. Make sure that your hard drive has enough space! The Install-CSDatabase command will by default use an internal algorithm to find a default path to place the data files. If there isn't enough space on your hard drive then it will not choose a path and it will fail with the said error message. I previously had only 1gb of HDD space left. When I increased that to 100GB I no longer had issues!
    • Proposed as answer by Juan Villa Sunday, July 31, 2011 5:42 AM
    Sunday, July 31, 2011 5:42 AM
  • It was the solution in my case.
    Tuesday, November 6, 2012 6:28 PM
  • Worked for me also.

    This was with Lync2013 standard I was running up in a Lab. Free space was 8gb in this case. increasing free space to 80Gb install completed


    Alistair

    Friday, November 9, 2012 4:11 PM
  • Had similar issue installing Lync Server 2013 RTM Standard Edition.

    Server C: drive had 16GB out of 40GB free. Extending disk by another 5GB solved the problem and I can see why, 21GB of free space (after extending) shrunk to 6.3GB of free space after installation was finished.

    Looks like you need at least 20GB of free space to execute Install-CSDatabase command.

    Cheers!



    • Edited by Peter-LV Saturday, November 10, 2012 1:32 AM
    Saturday, November 10, 2012 1:19 AM
    1. Right-click My Computer and select Properties.

    2. Select Advanced.

    3. Click Environment Variables.

    4. In the User variables for <account name> area, select TEMP and click Edit.

    5. In the Variable value field, enter the new path for the TEMP environment variable and click OK.

    6. In the User variables for <account name> area, select TMP and click Edit.

    7. In the Variable value field, enter the new path for the TMP environment variable and click OK.

    8. Click OK to close the Environment Variables dialog box and OK once more to close the System Propertiesdialog box.

    9. Restart the node to apply the change.


    • Proposed as answer by starzkv Tuesday, November 13, 2012 8:34 AM
    Tuesday, November 13, 2012 7:02 AM
  • I too got the following error in Lync Server 2013 (RTM):

    Executing PowerShell command: Install-CSDatabase -Confirm:$false -Verbose -LocalDatabases -Report "C:\Users\Administrator\AppData\Local\Temp\2\Install-CSDatabase-[2012_11_17][12_32_05].html"
    Command execution failed: Cannot find any suitable disks for database files. You must manually specify database paths.

    Peter Nuksa's observation regarding disk space proved to be correct. I had 17GB out of 50GB free. Expanding with extra 10GB solved the problem and the setup now completes without errors.

    Saturday, November 17, 2012 12:00 PM
  • Juan Villa

    You are great. i inceased the space now the issue fixed

    Sunday, December 30, 2012 10:11 PM
  • Worked for me also. Thanks for the information.

    Jimmy Mathew, Parackattu

    Monday, January 28, 2013 6:50 PM
  • This fixed me as well
    Thursday, March 28, 2013 10:24 AM
  • Hi to all,

    I`am expiriencing the same issue:

    Directory lookup for the file "\\vw-lync-2013.7o.local\C$\CsData\RtcDatabaseStore\rtclocal\DbPath\rtc.mdf" failed with the operating system error 5(Access is denied.).

    What permissions are required on rtc.mdf ?

    Wednesday, July 10, 2013 2:55 PM
  • That's a typically intuitive Microsoft "show stopper" error message.  With a message like "Command execution failed: Cannot find any suitable disks for database files. You must manually specify database paths." you really mean that there is insufficient space on the Shared volume.  I squeaked by with 27 GB. 
    Monday, May 5, 2014 7:01 AM