locked
Time for request too short RRS feed

  • Question

  • hi,

     we use AX Enterprise portal on WSS 3.0 which has very poor performance. Some task can't execute because "time for request" is too short.

    I set below parms but nothing changed.

    <httpRuntime executionTimeout="360" maxRequestLength="102400" />

    Monday, May 27, 2013 6:52 PM

Answers

  • hi Grzegorz,

    thank you for the reply,

    sharepoint/iis timeout should be at the web.config, the tag that you put is the tag of the time out,

    <httpRuntime executionTimeout="360" maxRequestLength="102400" />

    then perhaps you can also check this timeout settings:

    1. go to your IIS -> sites-> select sites, right click

    2. advance settings -> connection limits

    3. connection timeouts-> set to 300 (default 120)

    4. reset IIS, try to reproduce

    if the issue persist, please try to get more clue from ULS log and fiddler log.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Emir Liu Friday, May 31, 2013 10:25 AM
    Tuesday, May 28, 2013 7:45 AM
  • Hi Grzegorz,

    I checked your logs, the fiddler didn't catch any time out issue.

    but from the ULS logs, there are 2 points that may cause the issue,

    1. there is 3rd party custom application/coding that is not correctly coded, from the logs there are some access to the database, so it require locking to resource/worker, then the lock was not free/release after use, so when another request came in, the resource was locked and no more spare to share with, so the latest request will be piled up at a queue, when the queue hits the time limit of waiting for request, then the process was failed.

    2. the AAM is not configured well, A request was made for a URL, https://www.artim.com.pl, which has not been configured in Alternate Access Mappings.  Some links may point to the Alternate Access URL for the default zone, http://ax3ep.  Review the Alternate Access mappings for this Web application at http://ax3ep:25925/_admin/AlternateUrlCollections.aspx and consider adding https://www.artim.com.pl as a Public Alternate Access URL if it will be used frequently.

    for the 2nd point is clear what you need to check, but for the 1st point is more troublesome, because you need to check all your 3rd party application on that portal.

    to easily know what process that causing the resource that exhaust, you can capture the memory dump and TTT trace, while you reproduce the issue, and the issue is a must to be happened, so the logs will capture the process. we can remote to your environment to check and help you to capture this, but a professional case need to be open for the requirement.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Grzegorz Friday, June 7, 2013 6:06 AM
    Friday, June 7, 2013 2:44 AM

All replies

  • Hi,

    Thank you for your post.

    I'm trying to involve someone familiar with this topic to further look at this issue.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please click here.


    Emir Liu
    TechNet Community Support

    Tuesday, May 28, 2013 2:12 AM
  • Hi Grzegorz,

    for time out should be there have multiple time out settings that you may need to check,

    1. IE timeout

    2. IIS/sharepoint timeout

    3. network timeout

    to check which part of the the issue that got time out issue, I suggest you check using fiddler and check at which part the time out appears, and by checking the sharepoint ULS log, you may also help, to get more clue.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, May 28, 2013 3:58 AM
  • Thanks for yours replies.

    I think that isn't problem with IE timeout and network. I use the same browser and network to execute php script which time is set to 3 minutes. There isn't any timeout error.

    The webpart with .net control execute only 1 min and I get error message.

    Where is in sharepoint parametr for execute time?

    Regards,

    Grzegorz

    Tuesday, May 28, 2013 6:50 AM
  • hi Grzegorz,

    thank you for the reply,

    sharepoint/iis timeout should be at the web.config, the tag that you put is the tag of the time out,

    <httpRuntime executionTimeout="360" maxRequestLength="102400" />

    then perhaps you can also check this timeout settings:

    1. go to your IIS -> sites-> select sites, right click

    2. advance settings -> connection limits

    3. connection timeouts-> set to 300 (default 120)

    4. reset IIS, try to reproduce

    if the issue persist, please try to get more clue from ULS log and fiddler log.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Emir Liu Friday, May 31, 2013 10:25 AM
    Tuesday, May 28, 2013 7:45 AM
  • hi,

     I set connection time - setup to 600(sec)  in IIS site advanced settings. I still have 90 sec to execute request. Where can I find ULS and fiddler log?

    Monday, June 3, 2013 12:35 PM
  • Hi Grzegorz,

    before the capture process, please restart your server to make sure there is no temporary data left in memory.

    you can find the ULS log:

    1. open central admin -> operation ->diagnostic logging

    2. check and open the path at Trace Log, you will find the ULS log,

    3. open ULS log with excel, then try to find the time when the issue occurs, it may be simpler if you reproduce the issue when you aware of the time.

    4. download fiddler trace tool from http://fiddler2.com/

    5. run fiddler tool from the client machine that you use to reproduce the issue, then it will be start capturing the issue.

    it will be very best if you capture the issue within the same time using ULS log and fiddler log.

    if you already have the logs, please reply your findings, or you may help us by opening a professional case so we can help you to check and give you a very detail solution for your issue.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, June 4, 2013 3:23 AM
  • hi,

      I did what you wrote. I uploaded data here http://www.speedyshare.com/v6qqy/logs.zip There are files from sharepoint and fiddler.

    I hope that wille help to resolve my issue.

    Regards

    Thursday, June 6, 2013 9:16 AM
  • Hi Grzegorz,

    terribly sorry, my company firewall block your link,

    I suggest to open a professional case, then we can have the workspace to upload and download the logs/result.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 6, 2013 9:22 AM
  • hi,

    thank you for fast reply.

    try this link https://artim.com.pl/_layouts/ep/logs.zip

    it is my company website server. It should work :)

    Thursday, June 6, 2013 10:47 AM
  • Hi Grzegorz,

    I checked your logs, the fiddler didn't catch any time out issue.

    but from the ULS logs, there are 2 points that may cause the issue,

    1. there is 3rd party custom application/coding that is not correctly coded, from the logs there are some access to the database, so it require locking to resource/worker, then the lock was not free/release after use, so when another request came in, the resource was locked and no more spare to share with, so the latest request will be piled up at a queue, when the queue hits the time limit of waiting for request, then the process was failed.

    2. the AAM is not configured well, A request was made for a URL, https://www.artim.com.pl, which has not been configured in Alternate Access Mappings.  Some links may point to the Alternate Access URL for the default zone, http://ax3ep.  Review the Alternate Access mappings for this Web application at http://ax3ep:25925/_admin/AlternateUrlCollections.aspx and consider adding https://www.artim.com.pl as a Public Alternate Access URL if it will be used frequently.

    for the 2nd point is clear what you need to check, but for the 1st point is more troublesome, because you need to check all your 3rd party application on that portal.

    to easily know what process that causing the resource that exhaust, you can capture the memory dump and TTT trace, while you reproduce the issue, and the issue is a must to be happened, so the logs will capture the process. we can remote to your environment to check and help you to capture this, but a professional case need to be open for the requirement.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Grzegorz Friday, June 7, 2013 6:06 AM
    Friday, June 7, 2013 2:44 AM