locked
Programs installed after Vista continously entering setup RRS feed

  • Question

  • On my installation of vista there seems to be a problem. Office 2007, Itunes, skype or almost any other program when intialized enter into setup mode. Once the new setup has run the application loads. When started again the same setup screen returns. 

    I was unsure of what could be causing this error.  
    Wednesday, February 18, 2009 2:23 PM

All replies

  • the programs were installed with global settings. those settings are stored partly in some setup folders (that are only writable by administrators and not by standard users), partly in some registry hives (again, these are only writable by administrators). after installation is complete, and the user start up these applications for the first time, the programs try to write per-user settings in the registry, which is not allowed for standard users. therefore, the programs can't write these settings, and when you re-start them, they still think they are ran for the frist time, since the per-user settings are still missing.
    to solve this, right click on the program's icon (either on the desktop or in the start menu), and select "run as administrator". now the programs have the permissions to write their settings in the registry. once complete and the program starts up, close it again, and re-run it as normal (ie. not "as administrator"). this should solve your issue.
    Thursday, February 19, 2009 2:59 PM
  • When I right click, I dont have run as administrator as an option. I went under securities and added all the rights for my user but it sill wont work.
    Thursday, February 19, 2009 4:02 PM