locked
MS10-072 SharePoint Server 2007 SP2 32-bit Patch RRS feed

  • Question

  • MS10-072 SharePoint Server 2007 SP2 32-bit patch (KB2345212) does not install on Windows Server 2008 SP2 x86 where SharePoint 2007 32-bit was installed with SP2 slipstreamed into the package.  Error message states "The expected version of the product was not found on your system".  After manually installing SP2 for SharePoint Server 2007 on top of the slipstreamed install, I was able to install the patch.  The slipstreamed package is the ISO package downloaded from TechNet Subscriptions. The issue did not occur in the following scenarios:

    • SP2 slipstreamed package installed on Windows Server 2008 SP1 x86
    • SP2 slipstreamed package installed on Windows Server 2008 SP2 x64
    • SP2 for SharePoint Server 2007 not slipstreamed, but installed manually

    Any reason why this is happening.  Thanks.

    • Moved by Mike Walsh FIN Friday, April 15, 2011 2:00 PM admin q not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, April 15, 2011 1:40 PM

All replies

Friday, April 15, 2011 4:11 PM
  • I saw that. My understanding was that the patch would install if SP1 was installed or not. Am I misreading those two bullets? Why would you need SP1 if SP2 is already installed? Thanks js
    Friday, April 15, 2011 5:07 PM
  • JS, 

    The security patch your installing is probably looking for SP1 and not SP2. Since you have SP2 already installed, it might be the reason for the error. 

     

    Thanks

    V

     


    V
    Friday, April 15, 2011 5:15 PM