none
Increase TTL for DNS delegation RRS feed

  • Question

  • Hello,

    I have set up a DNS delegation for EMC SmartConnect. Sometimes when I ping the delegation name, it does not resolve for a few tries and then works fine. I suspect that there is a timeout problem for the delegation. I noted that the TTL seems to be zero, based on the results below which I got when using nslookup with the D2 debug mode. When I try to enabled advanced mode in the DNS MMC snap in and change the TTL, the changes do not stick. I think this is know issue, as outlined in the link below, but I can not seem to get the modified value to stay. Does anyone have a way to increase the TTL for a delegation, so I can see if that is causing the SmartConnect name to not resolve consistently? Thanks!

    https://support.microsoft.com/en-us/help/3037081/dns-manager-snap-in-sets-ttl-to-0-value-unexpectedly-on-ns-records-in

    ------------

    ------------
    Got answer (57 bytes):
        HEADER:
            opcode = QUERY, id = 4, rcode = NOERROR
            header flags:  response, want recursion, recursion avail.
            questions = 1,  answers = 1,  authority records = 0,  additional = 0

        QUESTIONS:
            Delegation1.mydomain.com, type = A, class = IN
        ANSWERS:
        ->  Delegation1.mydomain.com
            type = A, class = IN, dlen = 4
            internet address = 192.168.19.12
            ttl = 0 (0 secs)

    ------------

    Tuesday, August 14, 2018 5:41 PM

Answers

  • Hi,

    Thanks for your reply.

    Try to create a new NS record and add the TTL when you create it.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by wedqwdqwedwd Friday, August 17, 2018 11:40 PM
    Thursday, August 16, 2018 8:59 AM
    Moderator

All replies

  • Hi,

    Thanks for your question.

    Enable advanced mode in the DNS MMC.

    Edit name servers of NS record properties.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, August 15, 2018 9:19 AM
    Moderator
  • Thank you Travis, but the settings do not seem to stuck when using that method. 
    Wednesday, August 15, 2018 1:58 PM
  • Hi,

    Thanks for your reply.

    Try to create a new NS record and add the TTL when you create it.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by wedqwdqwedwd Friday, August 17, 2018 11:40 PM
    Thursday, August 16, 2018 8:59 AM
    Moderator