none
Mapi over HTTP in 2016 CU2 RRS feed

  • Question

  • Hello!

    I've been testing CU1 for a couple of weeks - the result: both OWA and Outlook access work correctly.

    I format my physical boxes and install a bran-new CU2 Exchange organization on the exact same test servers as CU1 -the result: OWA works great, Outlook says ~"Exchange is not online":

    My steps:

    1)

    Test-OutlookConnectivity -RunFromServerId Exch1 -ProbeIdentity OutlookMapiHttpSelfTestProbe


    2) I check all EventViewer's logs - there was only one log which contained errors:


    2) I open this log: %ExchangeInstallPath%Logging\HttpProxy\Mapi\... and find my Outlook's connection attempt:


    3) The above screenshots lead me to this window:

    I don't remember what setting were for CU1 since Outlook could connect without issues but given that I was getting 401 errors I checked Windows Authentication - Negotiate and tried to connect via Outlook once again:


    4)

    5) Successfull connection attempt in the log:


    Q1: I failed to find any information about correct mapi virtual directory authentication settings (step 3)
    (https://technet.microsoft.com/en-us/library/dn635177(v=exchg.160).aspx
    https://technet.microsoft.com/en-us/library/mt634322(v=exchg.160).aspx?f=255&MSPPError=-2147217396)

     - what should they be?

    Q2:  ManagedAvailability\Monitoring log started generating 401 errors for all (including monitoring) mailboxes as soon as the Exchange  was installed - how in this case Test-OutlookConnectivity cmdlet could have succeeded?

    Q3: Is this behaviour by design or it's another CU2 bug?

    Thank you in advance,

    Michael



    • Edited by MF47 Tuesday, July 12, 2016 11:07 AM
    Tuesday, July 12, 2016 11:04 AM

Answers

  • Hi,

    Based on my test, I install a brand new exchange 2016 CU2 environment. And I don't meet your issue.

    Did you do some changes on MAPI virtual directory?

    The default authentications on MAPI virtual directory are Ntlm, OAuth, Negotiate, you can use this command to configure them.

    Get-MapiVirtualDirectory | Set-MapiVirtualDirectory -IISAuthenticationMethods Ntlm,OAuth,Negotiate

    For Q2, if I uncheck the authentication in EAC, execute the same command, the result is same for me. In my research, OutlookMapiHttpSelfTestProbe is to validate that the MAPI/HTTP endpoint is able to receive traffic on the Mailbox server. So it should be no problem between MAPI/HTTP endpoint and mailbox server. And the command is successful even I disable MAPI/HTTP in my organization. So I suggest to use this web site tool to check outlook connection.

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    • Marked as answer by MF47 Wednesday, July 13, 2016 9:14 AM
    Wednesday, July 13, 2016 8:52 AM
    Moderator

All replies

  • Hi,

    I will do some research/test and let you know the results.

    Thanks for understanding.

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    Wednesday, July 13, 2016 8:16 AM
    Moderator
  • Thank you Lynn-Li!
    Wednesday, July 13, 2016 8:35 AM
  • Hi,

    Based on my test, I install a brand new exchange 2016 CU2 environment. And I don't meet your issue.

    Did you do some changes on MAPI virtual directory?

    The default authentications on MAPI virtual directory are Ntlm, OAuth, Negotiate, you can use this command to configure them.

    Get-MapiVirtualDirectory | Set-MapiVirtualDirectory -IISAuthenticationMethods Ntlm,OAuth,Negotiate

    For Q2, if I uncheck the authentication in EAC, execute the same command, the result is same for me. In my research, OutlookMapiHttpSelfTestProbe is to validate that the MAPI/HTTP endpoint is able to receive traffic on the Mailbox server. So it should be no problem between MAPI/HTTP endpoint and mailbox server. And the command is successful even I disable MAPI/HTTP in my organization. So I suggest to use this web site tool to check outlook connection.

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    • Marked as answer by MF47 Wednesday, July 13, 2016 9:14 AM
    Wednesday, July 13, 2016 8:52 AM
    Moderator
  • Hi,

    "Did you do some changes on MAPI virtual directory?" - no, I didn't - it is a newly-installed Exchange environment.

    "In my research, OutlookMapiHttpSelfTestProbe is to validate that the MAPI/HTTP endpoint is able to receive traffic on the Mailbox server" - I think it is true, but it sounds strange to me: prior to receiving any traffic the authentication must succeed...

    "The default authentications on MAPI virtual directory are Ntlm, OAuth, Negotiate, you can use this command to configure them." - my default was the empty checkboxes. If on your Exchange the default authentication was "Ntlm, OAuth, Negotiate" it may be intermittent bug... I'll try to deploy another CU2 and take one more look at it.

    Thank you very much for your help!

    Regards,

    Michael

    Wednesday, July 13, 2016 9:13 AM
  • Just wanted to point out that I had this exact same issue with a clean Exchange 2016 CU installation as well!
    Tuesday, September 13, 2016 9:56 PM
  • "with a clean Exchange 2016 CU installation as well!" - CU2?
    Wednesday, September 14, 2016 9:12 AM
  • The same issue exists in green fresh CU3 as well.
    Sunday, October 23, 2016 7:32 AM
  • :(
    Sunday, October 23, 2016 2:06 PM