none
GPO to enable system restore on all drives.

    Question

  • Hi experts,

    Is it possible to enable system restore on all the drives alongside 'C:' drive by GPO, or is their any script that enables system restore on all the drives that can be used with GPOs.

    Any Suggestions....????

    Thank You.


    TechSpec90

    Tuesday, January 27, 2015 7:58 AM

Answers

  • HI,

    Here are the steps to enable system restore using group policy:

    Step 1:

    (1) Click Start, click Run, type gpedit.msc, and then clickOK.

    (2) Expand Computer Configuration, expand Administrative Templates, expandSystem, and then click System Restore.

    (3) Double-click Turn off System Restore, and then on the Setting tab, set it to Not Configured.

    (4) Double-click Turn off Configuration, and then on the Setting tab, set it to Not Configured.

    Note: If the above setting is already set to Not configured, set it toEnabled and click Apply. Then revert back the setting toNot configured, and click Apply, OK.

    Step 2:

    If using the group policy editor do not fix the problem, then try the registry fix given below.

    Note: Some serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up, click the following link:

    How to back up the registry in Windows 7
    http://support.microsoft.com/kb/322756

    1. Click Start, type regedit.exe and press ENTER
    2. Navigate to the following key:
    HKEY_LOCAL_MACHINE \ Software \ Policies \ Microsoft \ Windows NT \ SystemRestore
    3. In the right-pane, delete the value named DisableConfig
    4. Exit the Registry Editor.

    Hope this helps.



    Regards, Prabhu

    Tuesday, January 27, 2015 12:54 PM

All replies

  • HI,

    Here are the steps to enable system restore using group policy:

    Step 1:

    (1) Click Start, click Run, type gpedit.msc, and then clickOK.

    (2) Expand Computer Configuration, expand Administrative Templates, expandSystem, and then click System Restore.

    (3) Double-click Turn off System Restore, and then on the Setting tab, set it to Not Configured.

    (4) Double-click Turn off Configuration, and then on the Setting tab, set it to Not Configured.

    Note: If the above setting is already set to Not configured, set it toEnabled and click Apply. Then revert back the setting toNot configured, and click Apply, OK.

    Step 2:

    If using the group policy editor do not fix the problem, then try the registry fix given below.

    Note: Some serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up, click the following link:

    How to back up the registry in Windows 7
    http://support.microsoft.com/kb/322756

    1. Click Start, type regedit.exe and press ENTER
    2. Navigate to the following key:
    HKEY_LOCAL_MACHINE \ Software \ Policies \ Microsoft \ Windows NT \ SystemRestore
    3. In the right-pane, delete the value named DisableConfig
    4. Exit the Registry Editor.

    Hope this helps.



    Regards, Prabhu

    Tuesday, January 27, 2015 12:54 PM
  • Thanks for the Reply.....Prabhu

    I 'll try your steps and let you know.....

    Thank You....


    TechSpec90

    Wednesday, January 28, 2015 12:48 PM