Can't create a new SQL Azure Standard Tier db


  • I'm having an issue creating a new sql azure standard tier db. Here's the basic steps I've done to migrate a web tier db.

    Register for the sql preview programme

    Perform a db export to blob storage

    use the + (new) button to create a new SQL db

    select the import option

    browser to your saved export

    hopefully see the new tiers as options in dialog. 

    The new tiers require a separate server to web. Can create this from the import dialog

    I have 2 independent azure accounts, the above process worked for my test account but for the live account where I was also experimenting after success on the test account I hit an issue. I request to create a new server whilst importing. This step seems to work but then the actual import fails with this msg


    "Error encountered during the service operation. 
     Could not import package.
     Error SQL72014: .Net SqlClient Data Provider: Msg 40823, Level 16, State 1, Line 1 Invalid value provided for parameter EDITION. Please provide a value that is valid on server version 1.0.
     Error SQL72045: Script execution error. The executed script:
     CREATE DATABASE [$(DatabaseName)] COLLATE SQL_Latin1_General_CP1_CI_AS
     (EDITION = 'Standard', MAXSIZE = 1 GB)"

    Tried a couple of times but no joy. Using the portal I can browse to the new sql server and it looks okay other than the list of ENABLED RESERVATION SIZES ONLY HAS P1, P2, P3 I'm requesting a standard (s1) db not premium (P1, P2, P3). On my test server I see in this list also S1, S2. As you can see in the error message I'm requesting Edition = Standard. I get the feeling the newly created server is not accepting standard tier dbs?

    Now the server is created if I try an import I see the server in the list of available servers but when I select a tier of Basic or Standard the new server is grayed out, not so if I select Premium or the older Web or Business? Interestingly my current live sql server shows up as supporting the new premium?



    Friday, April 25, 2014 12:34 PM


All replies

  • Work around found:

    Pretty simple really, create a new sql server from the portal db servers page. This seemed to create the server as requested, eg supporting "standard" tier. 

    Friday, April 25, 2014 12:54 PM
  • Hello,

    Glad to hear that the issue resolved and thanks for your sharing.

    Fanny Liu

    If you have any feedback on our support, please click here. 

    Fanny Liu
    TechNet Community Support

    Monday, April 28, 2014 8:59 AM