locked
Mac client unable to communicate with management point (SP1) RRS feed

  • Question

  • Having followed the steps on both TechNet and James Bannan's blog to install the CM2012 SP1 client on Mac computers, I am running into a few problems on my OS X 10.7 MacBook Pro.

    The first problem is that when I go to System Preferences > Configuration Manager and click the 'Connect Now' button at the bottom, the message 'Connection failed, retry in progress...' is displayed after a few seconds. When that happens, the error "SSL Connection failed. HTTP Response code is 500 and reason is Internal Server Error" is logged in the CCMClient.log file located in /Library/Application Support/Microsoft/CCM/Logs. 


    I've verified that I can browse directly to https://<FQDN of primary site server> from the Mac. When I do, I see the IIS7 landing page, and do have a trusted connection to the web server. Back in System Preferences > Configuration Manager, I noticed that 'Management point' has a value of 'https://<FQDN of primary site server>:443/omadm/cimhandler.ashx'. When I open this URL in a web browser, I am first prompted to select a certificate. I select the client certificate that I installed earlier, and then I'm prompted for OS admin credentials. I enter those, and then receive a '500 - Internal server error' page. All that being said, I'm not sure that one is supposed to be able to actually view https://<FQDN of primary site server>:443/omadm/cimhandler.ashx in a browser, but I'm including it in case it's relevant here.

    The other, less critical problem is that in System Preferences > Configuration Manager, the value of 'Certificate subject name' is the actual name of the Active Directory user account that I used to enroll the Mac certificate. According to James Bannan's documentation, the certificate name is supposed to be that of the computer it's installed on. Thanks in advance for any assistance.

    EDIT: I repeated the steps to install the client and enroll the certificate on a different Mac running 10.8 just to see what would happen, and am getting the same error message on this computer.

    Anyone else experiencing this?

    • Edited by J1745 Friday, April 5, 2013 6:18 PM
    Thursday, March 28, 2013 2:59 PM

Answers

  • In case anyone stumbles onto this post experiencing the 'SSL Connection failed' message, what fixed this problem for me was to run C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis -i on my site server, which apparently refreshes the ASP.NET settings in IIS. I found this solution on Fei Xia's MSDN blog.
    • Marked as answer by J1745 Friday, April 19, 2013 9:14 PM
    Friday, April 19, 2013 9:14 PM