none
Windows forgets Regional options setting after restart, needs to be reset to default every time. RRS feed

  • Question

  • In Windows 8.1, I need comma as a decimal symbol. However, after restart it changes to dot and I need to reset it and restart all the programs. It is annoying. In Region settings, input method, Welcome, User setting etc. are the same language/region (Slovak). Is there registry key that would prevent OS changing the settings after restart? The default settings are correct, so I do not understand where does the change come from. After OS installation I used different system language (English) for a time, because it is easier for me to do setup in English, so maybe that is the reason. Thank you.
    Tuesday, September 26, 2017 4:11 PM

All replies

  • Hi,

    You could add a new keyboard input language (Slovak) to achieve comma as a decimal symbol quickly.

    Here are steps.

    1. Open PC Setting -> Time and language -> Region and language

    2. Under Languages, click Add a language, find and add the language that you want to use, and you could set as primary.

    I did a test, if I set it as primary, then restart PC, it will be Slovak keyboard.

    Here are screenshots for reference.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 27, 2017 7:48 AM
  • Thanks. I have done all that before, as I wrote in my question. The only languages and keyboards installed are Slovak. OS display language and Welcome screen is also changed to Slovak. I have uninstalled all English options where possible. The problem is that in Region Setting - Formats - Advanced settings the decimal symbol and digit grouping symbol are changed every time the computer is turned off or hybernated. After reset the correct values (comma as a deccimal symbol) are again displayed. Is there a script I could set to run after startup, because something is changing the decimal symbol. I work as accountant and it is very annoying. I have to restart all the programs after hybernation several times a day. 
    Thursday, September 28, 2017 7:34 AM
  • This is great help from Microsoft! If I could, I would go back to Linux, unfortunatelly the programs I used for work are not available in Linux. I am stuck with using this malware called Windows. I reinstalled it 2 months before, have no time to do it again. Is there a way to fix this? PLEASE!!!!!!!!!!!!
    Wednesday, October 4, 2017 7:30 AM
  • If you add a keyboard input language, please check the key in registry as following screenshot.

    And I did a test. If I add the keyboard input language, it can be used in application without restart PC.

    And if I change the region but not set the Slovak keyboard input language as primary, after restart PC, it still is US keyboard.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 5, 2017 6:22 AM
  • Thank you for your help. But I do not have problem with a primary, or any other keyboard language. My values in registry are the same as yours. 

    I have a problem with following setting: 

    Region Setting - Formats - Advanced settings the decimal symbol and digit grouping symbol are changed every time the computer is turned off or hybernated. 

    The decimal symbol is changed inepedently of a keyboard. If I open Excel or my accounting software, it copies the decimal symbol settings from OS, so I have to change the decimal symbol after restart or hybernation and then restart the programs. If I do not change the settings to comma, I have to use dot as a decimal symbol. And here is my problem: I use Slovak keyboard as primary (with comma as decimal symbol). When I press comma key on numeric keypad, it will display as a comma, but the software expects DOT.  Dot is further away on a keyboard, it slows me down in my work. Can I somehow remove any other decimal symbol options in registry, or set them permanently as comma? The right values display always after I press reset button /in advanced settings, but after hybernation or restart of OS the wrong values are back (dot, not comma as a decimal symbol).  I hope I explained my problem. It would help If I could add screenshots to this frum, but I cannot because I am not verified user. 

    Thursday, October 5, 2017 1:41 PM
  • In Excel, you could take following steps to set dot as comma.

    File -> Options -> Advanced -> Unmark Use system separators -> set Decimal separator to “,”

    Here are screenshots.

    Please check if your accounting software has the similar setting.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 6, 2017 9:17 AM
  • Hi, 

    Hows everything going? Please feel free to give me any update.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 13, 2017 1:28 AM
  • Hi, I do not use Excel, but other similar processor. Accounting programs do not have an option to exchange dot for comma. I downloaded freeware called Keyboard layout manager and created special keyboard with modified dot key in numeric keyboard. I am very dissapointed in the Microsoft Windows OS I must use. If any accounting programs were available in different OS, I would immediately quit using Windows.
    Thursday, October 26, 2017 10:31 AM
  • I have the opposite issue. I use English most of the time, used french once to import semicolon separated values.csv file into Excel once, changed back to English but the list separator keeps reverting to semicolon. 

    In a post about losing hotkeys ( for changing input methods) on relogging into a windows computer, (https://www.neowin.net/forum/topic/1261058-windows-81-is-forgetting-ctrl12345-shortcuts-designated-for-keyboard-layout-switching-after-wa/)  they explained it might have to do with the default settings. However, I checked the registry, but both the .DEFAULT/Control Panel/International/sList  and HKEY_CURRENT_USER/Control Panel/International/sList  have comma as value. So this is not a solution for us. There must be another default place where a setting is kept. 

    Wednesday, August 22, 2018 8:29 AM