locked
Stsadm restore question RRS feed

  • Question

  • I am trying to take a backup of an existing site collection in my production environment and to restore it in my staging environment.   The name of my production site is http://myteam.toro.com, and my staging site is http://qa-myteam.toro.com.  Both of them have an /is site collection.  I just want to blow away the one in staging with it's production counterpart.

    I did the backup using stsadm -o backup -url http://myteam.toro.com/is -filename isbackup.bak, and then tried to do a restore using stsadm -o restore -url http://qa-myteam.toro.com/is -filename isbackup.bak -
    overwrite.

    However when I do that I get the following error message:
    The incoming tabular data stream (TDS) remote procedure call (RPC) protocol stream is incorrect. Parameter 1 (""): Data type 0xE7 has an invalid data length or metadata length.

    I tried searching for this and am coming up blank.  Any ideas on what I am doing wrong?

    Thanks for you help.
    Ted

    P.S Of course another question is can I even do this?

    Monday, September 29, 2008 6:55 PM

All replies

  • Hey Ted,

    First off, yes you can restore a site collection using ststadm backup/restore, you are good there. 

    I am not clear what you mean by "both of them have an /is site collection".  I would assume that you mean you are backing up and restoring to a top level site collection?

    Two things I would try; first, put quotes around the URL in for the restore site.  I am not sure but that - (dash) may cause issues in the command.  I have seen that before.  If the quotes don't work try to first delete and recreate the site collection on your stage environment.  Then run the restore command again. 

    Let me know this helps.

    Tony


    For more information check out my blog; http://blogs.pointbridge.com/Blogs/pagnusat_tony
    Monday, September 29, 2008 7:23 PM
  • Hi Tony
    I am adding some words which are hidden in your post,.... with your permission.
    Delete and recreate the site collection using STSADM without template  on your stage environment.
    Then run the restore command again.
    Regards
    Xavier Ravi
    Monday, September 29, 2008 7:46 PM
  • Hi Tony,

    check this link for instructions on how to move/migrate:

    http://www.sharepointforum.com/en-US/Wiki/Forms/DispForm.aspx?ID=7

    Daniel Bugday Web: http://www.sharepointforum.com/ Blog: http://www.sharepointforum.com/en-US/Blog/
    Monday, September 29, 2008 8:02 PM
  • Hehe, I think I really screwed something up.  I figured I would start at the top of the suggestions and work my way down the list.  So I started with the quotation marks around the URL and that seemed at first like it was working.  It ran for a LONG time (it's a pretty cheesy staging environment), until I got tired of watching it and walked away. 

    When I came back there was an error message:
    "The site collection could not be restored. If this problem persists, please make  sure the content databases are available and have sufficient free space."

    So I went out the staging sql box and looked at the IS content db.  It said it was 900mb in size, with 800mb free, but that the autogrow option was on.  I also checked the diskspace and it had plenty to restore my 2.5gb backup file.  I thought with autogrow on it should autoexpand to take the 2.5gb.

    So then I started wondering if any of the data got restored.  I went back to the URL and got a 404 error message.  So at that point I decided to delete the SC.  Low and behold when I went in to delete it through the Central Admin it wasn't there.  I looked at the content DB and it said that there were Zero sites in that DB.

    So I tried to create it again through the Admin tool and got the following error:
    Exception from HRESULT: 0x80040E14

    I figure I have really screwed this thing up now.  I am kind of stuck between deleted and created, and can't go either way.

    By the way, I wasn't sure how you create the new SC with no template, so that's the reason why I was trying to do it through Central Admin.

    Thanks for all of your help guys.

    Ted




    Tuesday, September 30, 2008 10:36 PM
  •  Hi,
    Create SC without template , use STSADM command line tool.

    stsadm -o createsite -url <url> -owneremail <someone@example.com> [-ownerlogin <DOMAIN\name>] [-title <site title>]

    For this testing purpose create a new web application and create Site collection using STSADM.
    Now restore the backup.

    Let me know the outcome

    Regards
    Xavier Ravi
    Tuesday, September 30, 2008 10:49 PM
  • Ok, I deleted the SC using stsadmn, then when I went to create the new one this is what I got:
    D:\>stsadm -o createsite -url "http://qa-myteam.toro.com/is" -owneremail myemail -ownerlogin mydomain\mylogin -title IS

    The system cannot find the path specified. (Exception from HRESULT: 0x80070003)

    So I thought that now maybe the quotation marks were hurting me.  So I tried this:
    D:\>stsadm -o createsite -url http://qa-myteam.toro.com/is -owneremail myemail -ownerlogin mydomain\mylogin -title IS

    Exception from HRESULT: 0x80040E14


    I was starting to think about your comment about creating a new webapp and that made me start wondering about this.  The whole point of this is to try to duplicate my production environment into my staging environment.  Is this the best way to go about doing this? 

    Is there someway to back up the entire production environment and restore the whole thing into stage?  Rather than doing it one SC at a time?

    Thanks again.

    Ted

    Wednesday, October 1, 2008 6:38 PM
  • Hi Ted,

    STSADM.exe is not under D:\>

    the file is under sharepoint installed drive , if it is C drive
    then it will be under C:\program files\common files\microsoft Shared\web server extention\12\bin\>
    From here you can run the STSADM tool.

    C:\program files\common files\microsoft Shared\web server extention\12\bin\>stsadm -o createsite -url http://qa-myteam.toro.com/is -owneremail myemail -ownerlogin mydomain\mylogin -title IS


    Here your production environment is A
    and the Stage environment is B
    you are creating a Web application (new) using Central Admin in Environment B.
    Come back to command prompt and run the STSADM in Environment B to restore the site collection

    Restore problem is the one in Base Q in this thread.
    If you are looking for other methods let us know for details.

    Regards
    Xavier Ravi
    Wednesday, October 1, 2008 7:00 PM
  • On every one of my WFE's I always add a path variable mapped to the stsadm folder so I don't have to manually change dir's to it every time I open a new dos window.  I've never seen a problem before that was related to the path, so I don't think that's my problem.

    I feel even dumber now in that I am trying desperately to create a new web app.  Every time I do it I get the following error message:
    Name cannot begin with the ''' character, hexadecimal value 0x27. Line 1, position 380.

    I have tried different names, made sure all names had absolutely no leading spaces, tried pointing it to an existing app pool, all with no luck.  In googling the error message it comes back with nothing helpful, so I am at my wits end trying to get this thing going.

    Ted

    Wednesday, October 1, 2008 9:31 PM
  •  "Exception from HRESULT: 0x80040E14" is a classic that means a database operation failed.  We see it mainly when the database logs have filled up (or filled up the disk) on databases where we do not automatically truncate the logs after database backup  (our bad).
    Thursday, October 2, 2008 4:02 PM