locked
Office files will not save %20 file name issue RRS feed

  • Question

  • Hello, I have spent a few weeks looking for the answer to this issue and have yet to find a fix or resolution to this problem, There are two issues really, I hope you can help, Apoligises for the long post before I start as I have spent alot of time on this and dont want to waste anyones time.

    When you open a document from sharepoint it only opens in read only, no matter what type of document it is or where its located, this also happens on any logon on that machine, even if the user is admin, have tried uninstalling office, internet explorer 7 and 8, reinstalling office and internet explorer, doing all the windows updates, deleting temp files and recent files, removing all profiles and logging on locally as admin then signing in to sharepoint, but all documents still open in read only, the only way to resolve the readonly issue is to run - webfldrs.msi (in windows system32, reinstall mode force all files to be reinstalled) - after running this all files open correctly..... But

    Now when you open a document (lets call it "test document.xlsx)" it asks do you wish to open in read only or edit mode, you chose edit mode, the document opens sucessfully(word,excel or powerpoint), now when you try to change the file name to say "test document1.xlsx" and press save it will try to save then say document not saved.  I have noticed though if you change the name to anything then press save as - excel workbook - then click on tools at the bottom left of the save window, the name will change to "test%20document.xlsx" - so its filling the space with %20 which I know is the html version of space, but on any other machine this doesnt happen at this stage, and I suspect this is why its not saving or is linked to the issue.

    We have had 6 machines so far which have had this issue all have had to be formatted, one of the machines got this problem back - so this proves its not old sp or updates, or bad windows build etc.. but it also proves that it can come back at any time on any machine for an unknown reason.

    Have tryed -

    Resetting local group policy - secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    tired to reinstall MDAC - sucess but made no difference to machine

    This person seem to have a good idea but couldnt get this to work - http://dotnetninja.wordpress.com/2009/01/12/how-to-open-sharepoint-documents-in-edit-mode-with-internet-explorer-6-and-windows-xp-without-regfix/

    Tired the microsoft solution - http://support.microsoft.com/kb/870853 this doesnt work either. (both at the readonly stage and at the %20 stage of the problem)

    So webfldrs fixes the read only issue but causes the other %20 (document not saved) issue, I understand that this might well all go away if none of our documents have a space but this is not an option, and the other 190 machines work fine... for now... but it seems every week we have 1 to 2 machines develop this problem... has anyone come across this or have either a fix,solution or idea where to go next... seem to be searching everyday for this solution or a reason why its happening but keep hitting dead ends.

    Again sorry for the long post

    Sharepoint 2007 sp2

    Office 2007

    Xp Pro sp3

    Will

     

    • Edited by willydee Wednesday, November 24, 2010 4:53 PM more infomation
    • Edited by Mike Walsh FIN Wednesday, November 24, 2010 5:59 PM Prefix not needed a) not exact b) The SharePoint 2007 products are default here.
    • Moved by Mike Walsh FIN Monday, January 10, 2011 3:07 PM Nothing to do with Excel Services (From:SharePoint - Excel Services (pre-SharePoint 2010))
    Wednesday, November 24, 2010 4:48 PM

Answers

  • Willy,

    When we made sure the machine was up-to-date with all the latest updates and service packs the "%20" issue went away (not sure exactly which one fixed it - but it went away). 

    We had the same issues you're seeing with documents opening read only, and messages such as "Folder no longer exists" (or some such thing) from SharePoint.  We found that running webfldrs.msi with the default settings (only 1st checkbox checked) and then running the web folders update solved those issues.

    We found that the Office-replacing-spaces-with-"%20" issue was caused by running webfldrs.msi with the last 4 check boxes checked (as is recommended by some web posts).

    Phil


    Phil Shisbey
    • Marked as answer by Mike Walsh FIN Tuesday, January 11, 2011 2:19 PM
    Monday, January 10, 2011 3:05 PM

All replies

  • Hi Will,

    Did the Client Integration enable? http://blogs.technet.com/b/sbs/archive/2009/05/07/files-in-companyweb-are-opening-read-only-after-sbs-2008-ur2.aspx

    After click save button and save back to the library, did the name save with %20?

    Have you do the backup on the computer before you run webfldrs.msi? Because we can also find clues when it can’t open with edit mode, but this save issue seems can’t.

    I think you can check the problem computer to find what they did (maybe they had gone to same site, triggered the same workflow) before it is going wrong.


    Best regards. Emir
    • Marked as answer by Lily Wu Thursday, December 2, 2010 8:50 AM
    • Unmarked as answer by Emir Liu Wednesday, December 29, 2010 1:57 AM
    Friday, November 26, 2010 9:42 AM
  • Thank you for your reply

    "Did the Client Integration enable? http://blogs.technet.com/b/sbs/archive/2009/05/07/files-in-companyweb-are-opening-read-only-after-sbs-2008-ur2.aspx"  - we do not have sbs 2008

    "After click save button and save back to the library, did the name save with %20?" - if you change the location to say your desktop the %20 will not happen and you can save, its only when you try and save to sharepoint (as its a html).  if %20 appears in the name you cannot save it to sharepoint

    Have you do the backup on the computer before you run webfldrs.msi? Because we can also find clues when it can’t open with edit mode, but this save issue seems can’t. - backed up reg and made a system restore point, tryed restoring reg, chuck at a time to try and narrow down the problem, thought i was getting somewhere but didnt seem to get same results, best I could do was narrow it down to HKEY_LOCAL_MACHINE.     I was able to swap between the readonly error and the documents not saved %"0 error.           The webfldrs.msi re-registers some file types but cant find a list of what it actually does other wise I could go through that.

    "I think you can check the problem computer to find what they did (maybe they had gone to same site, triggered the same workflow) before it is going wrong. "  -   Users dont work in the same deparment and dont seem to have related documents, unless its to do with there mysites or some other universal action on sharepoint.

    I think it must be related to file names/file types, whats the process of changing a space to a %20, is this javascript in the back ground? at what process should this happen, I believe its happening to early, excel or the operating system is seeing that it is pointing to a html location and changing the space to a %20 before its actually saved, you can see this is you press save as and then tools, the space in the name will change to %20 when you press tools, this doesnt happen on none affected machines.


    Monday, December 6, 2010 9:57 AM
  • We have the same issue.  Documents were opening read-only, so ran webfldrs.msi (and the web folders update) and now when trying to save an existing Excel document with a new name (Save As) we get "Document Not Saved"  error.   So I replaced spaces with underlines in the file name and it worked.  

    Emir, 

    • Client Integration is enabled.
    • When the Save button is clicked spaces are converted to %20 but then Excel hangs and errors out with "Document not saved". Back in the library there is no new document because the save operation failed.

     

    This is Excel 2007, MOSS 2007 + SP2, Windows Server 2003 + SP2.

    Tuesday, December 28, 2010 6:44 PM
  • Lily,

    Why was Emir's post marked as the answer?  It didn't appear to solve the issue for Willydee and now I have the same issue and a solution has yet to appear.  Please unmark Emir's post as the answer. 

    Thank you,

    Phil

    Tuesday, December 28, 2010 9:43 PM
  • Thanks Phil, 

                  Yes I still have the issue, I actually have a machine which has this problem, which I have backed up, Client Integration enable is enabled on the server so its not that. I havent found anything yet which resolves this issue.

    Monday, January 10, 2011 10:09 AM
  • Willy,

    When we made sure the machine was up-to-date with all the latest updates and service packs the "%20" issue went away (not sure exactly which one fixed it - but it went away). 

    We had the same issues you're seeing with documents opening read only, and messages such as "Folder no longer exists" (or some such thing) from SharePoint.  We found that running webfldrs.msi with the default settings (only 1st checkbox checked) and then running the web folders update solved those issues.

    We found that the Office-replacing-spaces-with-"%20" issue was caused by running webfldrs.msi with the last 4 check boxes checked (as is recommended by some web posts).

    Phil


    Phil Shisbey
    • Marked as answer by Mike Walsh FIN Tuesday, January 11, 2011 2:19 PM
    Monday, January 10, 2011 3:05 PM
  • If willyde could test Phil's suggestion and report back here, I could then (if it works) mark Phil's post and lock the thread as answered to the OP's satisfaction,

     

    Moderator


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Monday, January 10, 2011 3:25 PM
  • Thanks Phil for you information, I will test the laptop as soon as it arrives, its curently traveling fom Scotland at the moment, will post back as soon as I have the results.

     

    (Also agree with the webfldrs infomation, if you get the read only issue then run the last 4 boxes of webfldrs it will cause this %20 issue)

    Tuesday, January 11, 2011 11:43 AM
  • Update: We just found out that running webfldrs.msi with default settings fixes the "Folder no longer available" issue but does not resolve the read-only issue.  The only fix I've seen for the read-only issue is to run webfldrs.msi with last 4 check boxes checked, unfortunately however, that causes the spaces-%20 issue, but as I said, updating the box should make that go away as well.
    Phil Shisbey
    Tuesday, January 11, 2011 2:13 PM