none
Can't view downloaded files put in certain folders RRS feed

  • Question

  • Hello,

    I've found what I think is a problem with IE9.  I have a .snippet (Visual Studio code snippet file) that I'm trying to download off a Share Point site with IE9 and Win7 x64.  The file is supposed to go in the C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C# location.  The file name is something like _MyFile.snippet (it starts with an underscore character).  On the file on the Share Point site, I do a Send To, Download a copy.  Then I do a Save As an put in the path to C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C#.  

    In the Save As Dialog that opens up, I've quadruple-checked and the path in the Save As dialog is "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C#" (I copied and pasted the preceding path).  The file name is _MyFile.snippet.  I then get prompted that _MyFile.snippet already exists, do I want to replace it.  I say yes.  

    If I then open explorer and go to C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C#, I do not see the file (Show hidden files is checked).  I navigate to this folder in cmd.exe and do a dir /a, I do not see the file.  I navigate to the folder in Windows PowerShell and do a Get-ChildItem -force, and I do not see the file.  The only thing that seems to "see" the file is the "Save As" dialog in IE9.  What's up with that?  

    I just download it to the myuserprofile/downloads directory and copy it to the C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C# location, but something is very odd here.

    -Eric

    Thursday, March 7, 2013 3:13 PM

Answers

  • Hi Eric,


    Have you tried another folder path to check the result?


    Also,
    try the following steps:


    1. You can run Internet Explorer (No Add-ons) to troubleshoot the issue.

       

        1. Open Start Menu, then click all programs, select Accessories, open the  system tools;

        2. Right-click Internet Explorer(No Add-ons), run as Administrator.


    2. Reset Internet Explorer settings and see how it works.

    3. Test issue in Clean Boot mode and Safe Mode with networking


    Hope this helps.


    Vincent Wang
    TechNet Community Support

    Friday, March 8, 2013 6:31 AM
    Moderator

All replies

  • Hello,

    I just ran SysInternals Procmon while saving the file and found that the file is actually being saved in: C:\Users\CharlieFoxtrot\AppData\Local\VirtualStore\Program Files (x86)\Microsoft Visual Studio 10.0\VC#\Snippets\1033\Visual C#

    How confusing is that?

    -Eric

    Thursday, March 7, 2013 3:21 PM
  • Hi Eric,


    Have you tried another folder path to check the result?


    Also,
    try the following steps:


    1. You can run Internet Explorer (No Add-ons) to troubleshoot the issue.

       

        1. Open Start Menu, then click all programs, select Accessories, open the  system tools;

        2. Right-click Internet Explorer(No Add-ons), run as Administrator.


    2. Reset Internet Explorer settings and see how it works.

    3. Test issue in Clean Boot mode and Safe Mode with networking


    Hope this helps.


    Vincent Wang
    TechNet Community Support

    Friday, March 8, 2013 6:31 AM
    Moderator