locked
Connecting from a remote computer / name resolution issues RRS feed

  • Question

  • My work has two SQL Server 2005 databases, one installed on a Windows XP machine (running some equipment) and one installed on a Windows 7 machine (backing up the files from the XP instance).  Both computers run only the default instance.  I had replication set up and functioning (data being created on the XP maching was being replicated to the Win 7 machine) for the last three weeks in July.  I recently noticed that the replication is no longer working (the files were no longer being copied), and when I tried to check the status I got an error about named pipes, or, if I disabled named pipes "tcp provider error 0 no such host is known".

    At the time I found the replication problem, I could connect to both databases through SSMS on the Windows 7 machine.  On the XP machine, I could use SSMS to browse to the Win 7 instance but SSMS would not connect to the Win 7 instance by name (same errors about no such host known); the connection does go through by IP address.  I can ping from the Win 7 machine to the XP machine both by IP address and by name.  I could ping from the XP machine to the Win 7 machine by IP address but NOT by name.  

    I tried running the workgroup wizard on the XP machine, thinking this might help with the name resolution problem.  In the wizard, I changed the workgroup name to a new name.  I changed the workgroup name on the Win 7 machine to match.

    This change did not affect the ping status - I can still ping by both name and IP address from the Win 7 machine, and still only the IP address works from the XP machine.  However, now SSMS on the Win 7 machine no longer sees the XP machine!  Trying to log in with either the machine name and the IP address, I now get a "timeout expired" message, and the SSMS login browser does not show the XP machine on the network.

    Any pointers on where to look for the cause of this problem would be very welcome.


    • Edited by MTPht Monday, September 8, 2014 6:19 PM
    Monday, September 8, 2014 6:04 PM

Answers

  • Hello,

    You can add an entry in "Hosts" file for naming solution; this file is located in Folder "C:\Windows\System32\drivers\etc\"

    Or create a SQL Alias with the name pointing to IP addresse by using the tool "CliConfg.exe"


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Marked as answer by MTPht Friday, September 12, 2014 1:48 PM
    Tuesday, September 9, 2014 1:19 PM

All replies

  • I suggest you check out for firewall settings
    Monday, September 8, 2014 6:49 PM
  • The firewall on the XP computer is off.

    On the Win 7 computer's firewall, I opened the 1433 TCP port when I set up the replication.  As part of troubleshooting the broken replication, I checked that the port was still open (it is), and also opened the 1434 UDP port just for something to try (even though both computers use only the default SQL Server instance).  Are there any other settings I should check?

    Tuesday, September 9, 2014 1:06 PM
  • Hello,

    You can add an entry in "Hosts" file for naming solution; this file is located in Folder "C:\Windows\System32\drivers\etc\"

    Or create a SQL Alias with the name pointing to IP addresse by using the tool "CliConfg.exe"


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Marked as answer by MTPht Friday, September 12, 2014 1:48 PM
    Tuesday, September 9, 2014 1:19 PM
  • There was some problem (bug?) with the remote connections flag on the Win 7 server.  Someone had posted in the comments to a technet article that unchecking the remote connections box, restarting the server, then re-checking it helped them.  I tried it, and that fixed the problem with the Win 7 machine being unable to see the XP machine.

    Olaf's suggestion about the Hosts file fixed the problem with the XP machine having to use the IP address - now it can connect by name as well.

    Now I just have left the problem of a broken subscription to my replication, but that's a separate issue so I'll consider this thread closed.  Thanks to everyone who offered suggestions.

    Friday, September 12, 2014 1:52 PM