locked
Can't send mail from Exchange 2003 to Exchange 2007 RRS feed

  • Question

  • Here is my problem:  I have an Exchange 2003 server, recently installed an Exchange 2007 w/ SP1 to prepare for migration.  The 2007 server is the CAS, Hub, and Mailbox server. 

    I can send mail from a mailbox on Exchange 2007 to a mailbox on the 2003 server, but cannot send from the 2003 to the 2007.  I am even able to send mail out to the internet from the 2007 mailbox.  I have looked on the 2003 server and notice that the messages go into the queue under "Messages with an unreachable destination" when sending from 2003 to 2007.  Messages from internet email addresses also end up in the same queue.  The connector between 2003 -> 2007 was setup during the install, and even re-created to troubleshoot this problem. 

    Any help would be appreciated!

    Thanks,
    Patrick
    Wednesday, September 23, 2009 5:47 PM

Answers

  • Interesting enough, mail just started to flow.  Is it possible that there is just a significant delay when making changes? 
    • Proposed as answer by Amit Tank Friday, September 25, 2009 5:43 AM
    • Marked as answer by Mike Shen Friday, September 25, 2009 10:33 AM
    Wednesday, September 23, 2009 6:55 PM
  • Yes, usually you can restart the transport services to flush the cache and make changes effective immediately...

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    • Proposed as answer by Amit Tank Friday, September 25, 2009 5:43 AM
    • Marked as answer by Mike Shen Friday, September 25, 2009 10:33 AM
    Thursday, September 24, 2009 7:06 AM

All replies

  • Check the default receive connector settings and make sure that Permissions groups has "anonymous users" checked (I have exchange 2010 and ran into this yesterday) 
    Wednesday, September 23, 2009 5:56 PM
  • Do you have smarthost configured in smtp virtual server of Exchange 2003?

    ESM -> Exchange 2003 -> Protocols -> SMTP -> Default SMTP Virtual Servers -> Properties -> Delivery -> Advance -> SmartHost option, make sure nothing is here...

    If smarthost is there, you need to create a send connector selecting "Forward all mail through this connector to the following smart hosts" in Exchange 2003 instead of putting smart host into SMTP virtual server...

    Configuring an SMTP Connector

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    Wednesday, September 23, 2009 5:59 PM
  • Loren,

    I do in fact have the "anoymous users" checked for both the "Client" and "Default" receive connectors (actually all boxes on the Permissions tab are checked at the moment).

    Amit,

    I checked and I do not have any smarthosts defined in the field you referenced above.

    Thanks for the suggestions, any other thoughts?
    Wednesday, September 23, 2009 6:06 PM
  • What happens when you telnet %exch2003hostname% 25 from your exchange 2007 server and send a test email that way?

    Wednesday, September 23, 2009 6:13 PM
  • I get the same results when I do a telnet from the 2007 server to the 2003 and send mail.  The messages that are sent from a 2007 to the 2003 mailboxes send find, but sending from a 2003 mailbox to 2007 mailbox ends up in the mail queue on the 2003 server.
    Wednesday, September 23, 2009 6:24 PM
  • my bad.. I ment what error do you get when trying to telnet %exch2007% 25 from your exchange 2003 server and trying to send email that way.

    it should give you some status code.

    Loren
    Wednesday, September 23, 2009 6:26 PM
  • It says:  250 2.6.0 <messageid> Queued mail for delivery  

    I get the same message in the telnet session when a successful delivery happens from 2007 to 2003 mailbox. 
    Wednesday, September 23, 2009 6:31 PM
  • Interesting enough, mail just started to flow.  Is it possible that there is just a significant delay when making changes? 
    • Proposed as answer by Amit Tank Friday, September 25, 2009 5:43 AM
    • Marked as answer by Mike Shen Friday, September 25, 2009 10:33 AM
    Wednesday, September 23, 2009 6:55 PM
  • Yes, usually you can restart the transport services to flush the cache and make changes effective immediately...

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com

    • Proposed as answer by Amit Tank Friday, September 25, 2009 5:43 AM
    • Marked as answer by Mike Shen Friday, September 25, 2009 10:33 AM
    Thursday, September 24, 2009 7:06 AM