none
default theme for terminal server 2012 users

    Question

  • HI,

    I want to set defualt theme for all Terminal users logon on to server2012 terminal server.I applied the following GPO setting but didn't get any success

    1.    Log on an domain controller as an administrator,  open Group Policy management.

    2.    Create a GPO named “Desktop Theme” and link it to the OU that the Windows Server 2012 R2 TS resides.

    3.    Right-Click the “Desktop Theme” GPO and click Edit.

    4.    Navigate to [User Configuration\policies\Administrative Templates\Control Panel\Personalization]

    5.    Double click the “load a specific theme” on the right panel.

    6.    Select “Enabled” and type in the path “%windir%\Resources\Themes\vditheme.deskthemepack” without quotes.

    7.    Click Apply and OK.

    8.    Enable User Group Policy Loopback Processing mode for the Terminal Server.

    9.    Navigate to [Computer Configuration\Policies\Administrative Templates\System\Group Policy]

    10. Double click the “User Group Policy Loopback Processing mode” on the right panel.

    11. Select “Enabled” and choose “merge” mode.

    12. Click Apply and OK.

    13. Log on the Windows Server 2012 R2 Terminal server as an domain admin.

    14. Run “gpupdate /force” and reboot the machine.

    After that i check the registry setting on terminal server HKCU\Software\Policies\Microsoft\Windows\Personalization

     theme entry is changed but not applying that specific theme.


    • Edited by wert111 Tuesday, May 19, 2015 7:02 AM
    Tuesday, May 19, 2015 7:02 AM

All replies

  • Hi,

    >>Double click the “load a specific theme” on the right panel.

    As far as I know, this setting should apply when a user logs onto a computer for the first time. As a workaround, we can try to configure the setting User Configuration\policies\Administrative Templates\Control Panel\Personalization\Load a specific visual style file or force Windows Classic to force a special visual style for all users.

    Regarding the setting Load a specific visual style file or force Windows Classic, the following article can be referred to for more information.

    Configuring User Group Policy Settings

    https://technet.microsoft.com/en-us/library/cc782067%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    In addition, regarding configuring themes for users, the following article can be referred to for more information.
    Windows 7 Theme Group Policy

    http://windows7themes.net/en-us/windows-7-theme-group-policy/

    Please Note: Since the website above is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 20, 2015 8:38 AM
    Moderator
  • HI

    issue not resolved and you have mark answer by yourself 


    • Edited by wert111 Thursday, May 28, 2015 10:30 AM
    Thursday, May 28, 2015 10:09 AM
  • Hi,

    Before going further, thank you for coming back to us. The reason I marked my reply as answer is I thought it might be helpful for answering the question. You did the right thing to unmark it as it hasn't been helpful to you.

    >>User Configuration\policies\Administrative Templates\Control Panel\Personalization\load a specific theme

    Here, I am not sure if you have realized it but as explained in the Help section of the setting: If you enable this setting, the theme that you specify will be applied when a new user logs on for the first time. As a workaround, we can try the setting Load a specific visual style file or force Windows Classic which I mentioned in above post to force a visual style for users.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 01, 2015 1:45 AM
    Moderator