none
Invalid Duration error in MS Project 2010 RRS feed

  • Question

  • Hi,

    I have a user who has brought an issue to me.  He is a regular user of MS Project.  When he opens up his .mpp file he instantly gets an error of "Invalid Duration.  This is not a valid duration or it is outside the range for this field".  He has tried out every validation resolution option there is, he has looked at unpublished work items, he has also checked it through Excel.  He has re-entered the data, checking the format of every single piece of data.  Nothing was wrong and none of these checks have made any difference.   If he clicks on the Ok button on the error message, the file does then appear to operate normally with no issues, but he can't be 100% sure this is the case due to this message re-occurring every time he opens it again.  Is there anyone that has any ideas why this might be happening.  Please could someone throw some light on this ...?

    Thank you,  Lisa

    Thursday, June 27, 2013 11:28 AM

Answers

  • Check if using Macro on the plan. Similar issue has been fixed in June 2013 for project 2010, not sure which version you have seen the reported problem.

    Project 2010 hotfix package (Project-x-none.msp): June 11, 2013

    'http://support.microsoft.com/kb/2817385'

    You run a macro that sets the duration of a custom duration field for a task in a project in Project 2010. When you save and then reopen the project, you receive the following error message:
    Invalid Duration
    This is not a valid duration, or is outside the range for this field.

    Type a duration in the correct format: for example, 4 hours (or 4h), 12 days (or 12d), or 2ed for elapsed days.

    If its 2010, test with the above cu as its latest one.

    If this isn't case, please try using XML and check if that helps.

    If above doesn't help, provide information on project version and past history of plan, like was it created in past version and now opened in other version, etc.

    Wednesday, July 3, 2013 5:42 PM
    Moderator

All replies

  • tinsel1501,

    First question, is SP1 installed? If not, install it. I recall reading another post with this same issue several months ago and indeed I found a reference to it.

    http://social.technet.microsoft.com/Forums/projectserver/en-US/26b91269-b8f4-4e82-bf42-fca16e9d02a6/invalid-duration

    If the service pack is already installed, it could be a case of file corruption. Try saving as XML and then re-opening in Project. Note: you will lose any custom formatting using this process.

    John

    Thursday, June 27, 2013 2:50 PM
  • Try to delete the duration of that task and re-enter it. If this doesn't resolve the issue, recreate that task and delete the previous one. Let us know if this resolves. Other option is save file in XML  and re-open in MSP, it would also eliminate if there are any corruption.

    Sapna Shukla

    Thursday, June 27, 2013 2:54 PM
    Moderator
  • Lisa, this problem can be caused by a Deadline set on a Summary task.

    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can help other community members reading the thread.

    Wednesday, July 3, 2013 4:35 PM
  • Check if using Macro on the plan. Similar issue has been fixed in June 2013 for project 2010, not sure which version you have seen the reported problem.

    Project 2010 hotfix package (Project-x-none.msp): June 11, 2013

    'http://support.microsoft.com/kb/2817385'

    You run a macro that sets the duration of a custom duration field for a task in a project in Project 2010. When you save and then reopen the project, you receive the following error message:
    Invalid Duration
    This is not a valid duration, or is outside the range for this field.

    Type a duration in the correct format: for example, 4 hours (or 4h), 12 days (or 12d), or 2ed for elapsed days.

    If its 2010, test with the above cu as its latest one.

    If this isn't case, please try using XML and check if that helps.

    If above doesn't help, provide information on project version and past history of plan, like was it created in past version and now opened in other version, etc.

    Wednesday, July 3, 2013 5:42 PM
    Moderator
  • I avoid using the custom duration fields; they cause this irritating "Invalid Duration" error box.
    Tuesday, February 18, 2014 9:56 AM