none
Delivery delayed possibly because of Exchange Online issue with DNS check RRS feed

  • Question

  • http://social.technet.microsoft.com/Forums/exchange/en-US/newthread?category=microsoftonlineservices&forum=onlineservicesexchange

    I'm troubleshooting extremely late (3+ days) delivery emails FROM a domain hosted by Microsoft TO systemid.com.  Microsoft Remote connectivity analyzer https://testconnectivity.microsoft.com/ shows that it cannot get MX record for systemid.com.  HOWEVER, other tools like Mxtoolbox (http://mxtoolbox.com/) shows the MX lookup is successful.

    When sending FROM Google / Yahoo to the same email address at systemid.com, the emails go through right away.


    I was able to reproduce the issue by sending an email FROM my personal Hotmail email to systemid.com.  The next morning I got a delayed Delivery Status Notifcation:


    Reporting-MTA: dns;BAY004-OMC1S14.hotmail.com
    Received-From-MTA: dns;BAY169-W65
    Arrival-Date: Tue, 30 Sep 2014 11:38:10 -0700

    Final-Recipient: rfc822;xxxxxxxxx@systemid.com
    Action: delayed
    Status: 4.4.7
    Will-Retry-Until: Thu, 2 Oct 2014 11:38:17 -0700


    I think the root issue is that Exchange Online does not like something about MX record for systemid.com, although other tools say the MX records are fine.


    Can you see why emails from Hotmail or one of your Exchange Online customers cannot reach systemid.com although emails from Google / Yahoo go in just fine?  Please PM me if you need the name of the domain hosted by Microsoft or an email address at systemid.com for testing.

    Wednesday, October 1, 2014 6:22 PM

All replies

  • If you open a service request via your O365 tenant, and explain the issue, they'll respond quite quickly.

    I've created some tickets at O365 support for about the same problems in the past, and you usually get a call from an EOP/EO engineer the day after.
    Thursday, October 2, 2014 12:41 PM