locked
Cannot Deploy Windows 7 Enterprise into VMware Workstation VM RRS feed

  • Question

  • Hi,

    I am trying to make a reference image of Windows 7 Enterprise x64. I have the ISO copied over in MDT 2013 and a deployment task ready to go. Each time I try the deployment, I get a Windows Boot Manager error indicating:

    \Windows\System32\drivers\msisadrv.sys

    Status:0xc0000428

    Info: Windows cannot identify the digital signature for this file.

    If I press F8 and boot without checking driver signatures, I get a similar error with pci.sys. There are no VMware-specific drivers in my repository, just drivers for various Dell and Lenovo models. During the injection phase, I noticed that all of the driver names started with "Microsoft." If these are Microsoft drivers, why can't they verify their own signatures? Is there any way around this? Would it be possible to disable all of these Microsoft drivers? I'd really like to use the build and capture approach instead of doing everything manually. I certainly do not want to build a reference image on physical hardware.

    Thanks


    Jason

    Tuesday, August 4, 2015 3:14 PM

All replies

  • Some articles to get you started on driver management - http://deploymentresearch.com/Research/Post/325/MDT-2013-Lite-Touch-Driver-Management

    You shouldn't have any of those drivers on boot of your VMware machine.  If they're injecting they should be disabled or only the VMware specific drivers should be injected.  Not your entire pool of Dell and Lenovo model drivers.

    Tuesday, August 4, 2015 5:15 PM
  • I agree and I can't recommend enough using the "total control" method and it will be cleaner and far superior to injecting everything and "seeing what sticks". The whole point to building in a VM is so that you don't add hardware specific drivers to the reference image. You shouldn't see any drivers injected by MDT when building in a VM.

    If this post is helpful please vote it as Helpful or click Mark for answer.


    • Edited by Dan_Vega Tuesday, August 4, 2015 5:23 PM
    Tuesday, August 4, 2015 5:19 PM
  • Currently, I have my drivers grouped by hardware model.

    Out-of-box drivers\Windows 7\x64\%model%

    I looked through each driver in each hardware model category and wasn't able to find any drivers by Microsoft. They're all from Intel, Broadcom, etc. No Microsoft. Looking at the BDD.log file, I can see where the drivers are being loaded, but it is very non-descript. There is this one GUID (or what looks like a GUID) that seems to be the source of the drivers. I can't find that on the filesystem. I tried the same thing with a different deployment share, one similarly configured, but not exact, and it worked. Windows 7 installed without any boot errors. So, I guess, it has to be a driver. I just can't find it to disable it.

    Thanks


    Jason

    Tuesday, August 4, 2015 6:46 PM
  • Did you configure a Drivergroup001=Windows 7\x64\%MODEL% ? Simply creating those folders under Out-Of-Box drivers does not give your TS the logic to know which driver folder to use. Make sure you're reading the details from the article above on configuring your drivergroup to inject the proper drivers.  The only reason you're getting extra drivers is most likely the standard ts step of inject all drivers in the preinstall phase.  Make sure you're reading that entire article. 

    Tuesday, August 4, 2015 7:47 PM
  • You can also look here - https://social.technet.microsoft.com/Forums/en-US/612cb7cd-720c-42e1-83e2-04bbd83439d5/driver-selection-profiles?forum=mdt

    I just covered this for someone else today.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, August 4, 2015 7:50 PM
  • My CustomSettings.ini has a model section, "OptiPlex 990" for example, and under that is configured "Drivergroup001=Windows 7\x64\%model%" That's why I am not exactly sure where these Microsoft drivers are coming from. I don't recall importing anything from Microsoft specifically. I'll certainly go through the entire article. Is it best to set the driver group at the deployment share level or the task level?

    Thanks


    Jason

    Tuesday, August 4, 2015 8:33 PM
  • Personally I find it easier to set the driver group in the task sequence using make and model. But the way you organize it matters to you, use what makes the most sense to you.

    Adding a model variable to a specific model section in customsettings is somewhat pointless. I mean if you're going to use drivergroup in THAT way, it may as well be "Drivergroup001=Windows 7\x64\OptiPlex 990" as there would be no sense in using a variable.

    By setting the variable in your task sequence or in [Default] of customsettings if you so choose, it will dynamically set the right driver group for all models.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, August 4, 2015 8:59 PM
  • Here's my CustomSettings.ini. I pieced it together from various online tutorials until I got something that worked.

    [Settings]
    Priority=Model,Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y
    SkipCapture=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipUserData=YES
    SkipBitLocker=YES
    BitsPerPel=32
    VRefresh=60
    XResolution=1
    YResolution=1
    SkipFinalSummary=YES
    FinishAction=LOGOFF

    SkipLocaleSelection=YES
    UILanguage=en-US
    UserLocale=0409:00000409
    InputLocale= 0409:00000409
    KeyboardLocale= 0409:00000409

    SkipDomainMembership=NO
    MachineObjectOU=OU=corp,DC=domain,DC=com
    DomainOUs1=OU=sales,OU=corp,DC=domain,DC=com
    DomainOUs2=OU=marketing,OU=corp,DC=domain,DC=com

    SkipTimeZone=YES
    TimeZoneName=Eastern Standard Time

    SLShare=%DeployRoot%\Captures\Logs
    SLShareDynamicLogging=%DeployRoot%\Logs\%COMPUTERNAME%

    _SMSTSORGNAME=My Company
    _SMSTSpackageName=Microsoft Deployment Toolkit

    WSUSServer=http://wsus.domain.com

    [OptiPlex 990]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [OptiPlex 9010]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [OptiPlex 9020]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [OptiPlex 9030 AIO]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [10AAA0MRUS]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [10AAS41Y00]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [OptiPlex 980]
    DriverGroup001=Windows 7\x64\%model%
    DriverSelectionProfile=nothing

    [OptiPlex 780]
    DriverGroup001=Windows 7\x86\%model%
    DriverSelectionProfile=nothing

    [Inspiron 3050]
    DriverGroup001=Windows 8.1\x64\%model%
    DriverSelectionProfile=nothing


    Jason

    Wednesday, August 5, 2015 9:29 PM
  • That'll work or you could just add a DriverGroup variable to your task sequences instead of all those sections in customsettings.

    I mean you need to select which OS you're going to deploy, so you may as well just define drivergroup variable in the task sequence. You have to have a different task sequence for each OS and architecture. Once you set it in the TS you'll never have to make any changes to the TS or to customsettings just because you now support a new model. You would just create a folder with the new model name in the OoBD and import the new drivers.



    If this post is helpful please vote it as Helpful or click Mark for answer.

    Wednesday, August 5, 2015 9:49 PM
  • Could you have both settings? The driver map in the CS.ini and the task sequence variable, or would that break MDT?

    Jason

    Wednesday, August 5, 2015 9:54 PM
  • Is this an apply of a custom wim? 

    And to answer your question what is in your TS should win.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 5, 2015 11:02 PM