locked
Cannot set up outbound SMTP smart host RRS feed

  • Question

  • Hi --

    I have a SBS 2011 box that, since it was set up some time ago, has been properly relaying outbound email to a smart host at the client's old hosting provider.

    The client has moved its hosting to GoDaddy, and I'm trying to get outbound SMTP working to this new smart host.

    The outbound SMTP server I was given was smtpout.secureserver.net.

    When I set up a test account on a domain PC using Outlook 2013, Outlook sends email to this new SMTP server without a problem.

    When I modify the Exchange send connector to use the identical settings that Outlook successfully used, all Exchange outgoing mail gets stuck in the outbound queue. One by one, Exchange tries to connect, and after a relatively long interval, fails the send with a "4.1.5 440 DNS Query Failed" error.

    From the SBS box, a nslookup smtpout.secureserver.net returns

       Non-authoritative answer:
       Name:    smtpout.where.secureserver.net
       Address:  173.201.192.229
       Aliases:  smtpout.secureserver.net

    If I modify the Exchange send connector to send to smtpout.where.secureserver.net, I get the same results -- a "4.1.5 440 DNS Query Failed" error for every outbound message.

    However, if I modify the Exchange send connector to send to that IP address (173.201.192.229), mail flies out unimpeded.

    So, technically, I got this to work. But I'm not too comfortable leaving this with the IP address. And I don't understand from where this "DNS Query Failed" is coming.

    Can anyone help me get to the bottom of this?

    BTW -- Enabling the "Use the External DNS Lookup settings on the transport server" option on the send connector had no effect.

    Thanks
    CL







    Sunday, June 28, 2015 3:42 AM

All replies

  • Hi,

    According to your description, my understanding is that Exchange send connector failed to send to smtpout.secureserver.net/smtpout.where.secureserver.net with error "4.1.5 440 DNS Query Failed", but if successfully to send to IP address (173.201.192.229).

    If this error occurs when you send email to specific remote domains, this problem may occur because the remote DNS servers ignore the AAAA query or return an unexpected response. If this error occurs when you send email to all remote domains, this problem may occur because the DNS server that Microsoft Exchange Server uses is not working. By default, Exchange Server uses network adapter DNS settings for outgoing remote mail routing.

    More information you may reference link below:
    https://support.microsoft.com/en-us/kb/3038746

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, June 29, 2015 3:22 AM
  • Hi --

    We're not having problems sending to some domains. Since we switched smart hosts, Exchange cannot send outbound email AT ALL unless I use that smart host's IP address instead of its host name(s).

    This server sent out email, using the old smart host, for two and some years without a hitch. All I did was change the smart host.

    As I mentioned in my original post, I enabled external DNS lookup on the outbound connector to try to resolve this problem, and that did not help. The outbound connector directly references not only the ISP's DNS servers but also those from OpenDNS. This has not helped solve the problem.

    Thanks
    CL

    Monday, June 29, 2015 3:30 AM
  • Hi,

    In general, we can configure either IP address, or FQDN of smart host on Connector. If the FQDN doesn’t work, it seems that your server failed to resolve the name. 

    If there were any previous Smart Host names please remove those from the configuration. Besides, confirm that if corresponding A resource record has been added in your DNS server.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, July 6, 2015 6:18 AM