none
Add new page does not default to Site Pages library

    Question

  • Hi all,

    I am in the process of setting up Sharepoint online to move our on premise. I've used Sharepoint online with other companies and never seen this before. When you go to add a new page, the location defaults to www.mycompany.sharepoint.com, instead of www.mycompany.sharepoint.com/SitePages. We have a site pages library, and pages library set up. How can we change it so it puts new pages in the Site Pages library like it is supposed to?

    

    Monday, November 28, 2016 10:10 PM

All replies

  • Hi KatieB92,

    Please check if the “SharePoint Server Publishing” site feature is enabled.

    If this feature is enabled, the default location when adding a page will be the location of the Pages library (https://<site>/pages). But if we click on “Add a page” in a page that is stored in the Site Page library (such as home.aspx), the default location will be the location of the Site Pages library (https://<site>/SitePages).

    If this feature is disabled, the default location will be the location of the Site Pages library when adding the page.

    In SharePoint online, it is difficult to change the default location for the OOB “Add a page” action. As a workaround, you could add a custom action using JavaScript.

    A demo about adding a custom action. Though the article is for SharePoint 2010, it still has some good information.

    https://msdn.microsoft.com/en-us/library/office/hh185004%28v=office.14%29.aspx

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, November 29, 2016 11:37 AM
  • Thank you Lisa. The Sharepoint Server Publishing feature was already enabled. I had to create a new Home.aspx page in the Site Pages library, and then make that my default home homepage before I could add a new page in that library. Didn't solve my problem, but a temporary work around. I will look into that article.
    Wednesday, November 30, 2016 6:08 PM
  • Hi KatieB92,

    Thank you for your feedback.

     If you think the reply provided is helpful, please mark it as answer. It will help other users who meet the same issue in this forum.

    You can also share your own solution here and mark it as answer, and we can learn from each other.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 1, 2016 10:29 AM