locked
Exchange 2010 Public folder replicating warnings RRS feed

  • Question

  • After I migrated to Exchange 2010 I am getting all these warnings - 

    "Error 1129 occurred while processing a replication event.

    Folder: (6-106818) IPM_SUBTREE\MIS\Calendar"

    Its like every 5 mins and its only this calendar in the public folders.  I no longer have the Exchange 2003 around anymore. Very Annoying....


    MSB

    Thursday, September 13, 2012 5:07 PM

All replies

  • You could always create a new folder, copy all the items from the original to the new, then remove the old one.

    Thursday, September 13, 2012 6:57 PM
  • Isn't there a exchange shell command I could run against the public folder calendar? 

    MSB

    Thursday, September 13, 2012 7:14 PM
  • also the calendar is in that MIS public folder so what would that accomplish?

    MSB

    Thursday, September 13, 2012 7:19 PM
  • ANYONE????????

    MSB

    Friday, September 14, 2012 2:47 PM
  • SOMEONE????

    MSB

    Friday, September 14, 2012 6:44 PM
  • Hi

    Sorry for the delay dut to the weekend.

    After research the Error 1129, it is caused by Replication table error.

    You can try to remove and add replicas to affected folders which is listed in event.

    Then run the command below and check msexchPreferredBackfillSource

    isinteg -s server_name -test replstate –fix

    Cheers


    Zi Feng

    TechNet Community Support

    Monday, September 17, 2012 7:20 AM
  • Ok but this folder isnt replicating anymore the ex2003 server is gone... so what exactly does this do

    isinteg -s server_name -test replstate –fix (-test replistate does that test the replication? and -fix then fixes and problems, also this wouldnt cause an outadge or should I do this after hours, Thansk.)


    MSB

    Wednesday, September 19, 2012 2:06 PM
  • Hi

    If there is no more ex03, forget ISInteg

    Try New-PublicFolderDatabaseRepairRequest

    Find the public folder database and then run the command

    New-PublicFolderDatabaseRepairRequest -Database PFDB01 -CorruptionType ReplState

    Cheers


    Zi Feng

    TechNet Community Support


    • Edited by Zi Feng Thursday, September 20, 2012 7:29 AM
    Thursday, September 20, 2012 7:25 AM
  • when is this safe to run

    MSB

    Thursday, September 20, 2012 3:17 PM
  • I ran that and it didnt work -

     A positional parameter cannot be found that accepts argument 'Folder'.
        + CategoryInfo          : InvalidArgument: (:) [New-PublicFolderDatabaseRepairRequest], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,New-PublicFolderDatabaseRepairRequest


    MSB

    Thursday, September 20, 2012 8:53 PM
  • Do I need to assign permission or something like that?

    MSB

    Thursday, September 20, 2012 8:56 PM
  • Hi

    For Public folder database repair request

    You need the permission

    • Organization Management
    • Recipient Management
    • Server Management

    You can refer to Mailbox Permissions

    http://technet.microsoft.com/en-us/library/dd638132.aspx

    Cheers


    Zi Feng

    TechNet Community Support

    Friday, September 21, 2012 3:20 AM
  • Hi

    And the error seems you miss a Required parameter

    You can have a check on

    New-PublicFolderDatabaseRepairRequest

    http://technet.microsoft.com/en-us/library/ff718234.aspx

    Cheers


    Zi Feng

    TechNet Community Support

    Friday, September 21, 2012 3:22 AM
  • New-PublicFolderDatabaseRepairRequest -Database PFDB01 -CorruptionType ReplState

    It's pertty stright foward - ok 1 question for the exchange admin account what is the command to give that

    account ALL RIGHTS FOR EVERYTHING that I would need, Thanks


    MSB

    Friday, September 21, 2012 2:32 PM
  • How do I find the GUID of the database for that public folder....

    MSB

    Friday, September 21, 2012 3:01 PM
  • Ok I found out how to get the GUID for the public folder "Get-PublicFolderdatabase | fl Identity, Guid"

    I tried the GUID and still the same problem...


    MSB

    Friday, September 21, 2012 3:16 PM
  • any qlues????

    MSB

    Friday, September 21, 2012 5:04 PM
  • Hi

    What problem you got?

    Cheers


    Zi Feng

    TechNet Community Support

    Monday, September 24, 2012 6:36 AM
  • [PS] C:\Windows\system32>New-PublicFolderDatabaseRepairRequest -Database 0f286d48-98bc-40d8-a5a2-9e889782905f -Corruptio
    nType ReplState -DectectOnly
    A positional parameter cannot be found that accepts argument '-DectectOnly'.
        + CategoryInfo          : InvalidArgument: (:) [New-PublicFolderDatabaseRepairRequest], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,New-PublicFolderDatabaseRepairRequest

    MSB

    Monday, September 24, 2012 2:56 PM
  • Is it a permission problem?

    MSB

    Tuesday, September 25, 2012 2:50 PM
  • Hi

    What is DectectOnly?

    This is not a parameter in New-PublicFolderDatabaseRepairRequest

    Cheers


    Zi Feng

    TechNet Community Support

    Wednesday, September 26, 2012 1:51 AM
  • http://technet.microsoft.com/en-us/library/ff718234.aspx

    It states that in this doc ...

    DetectOnly

    Optional

    System.Management.Automation.SwitchParameter

    The DetectOnly parameter specifies that you want this command to report errors, but not fix them. You don't have to specify a value with this parameter.


    MSB

    Wednesday, September 26, 2012 1:37 PM
  • Hi

    It is "DetectOnly", not "DectectOnly", you have a spelling mistake

    Cheers


    Zi Feng

    TechNet Community Support

    Thursday, September 27, 2012 1:56 AM
  • Well I figured it out I did like _Det then <tab> and it worked, even for the ReplState , it ran however it didn't fix my problem : (   ...found soem other stuff and fixed that but....

    MSB

    Thursday, September 27, 2012 5:23 PM