Local Area Connection doesn't have a valid IP configuration (W7) RRS feed

  • Question

  • Hello all. 

    I need some help with my computer.  I don't know what exactly is wrong, only that the thread title is what it says when I try to diagnose the problem.  I'm experienced with computers, but just need to know what steps to take to fix this.

    Tried restarting, tried turning on/off modem.  Everything is plugged in.

    BTW using WIRED connection to DSL modem/router.  It is a wireless modem too.  I'm connected to the modem right now through a laptop and Vista.
    Friday, July 24, 2009 9:37 PM


  • i got the answer to my problem... found it here

    Saturday, July 25, 2009 3:58 PM

All replies

  • Hi Walter,

    Thanks for posting,

    Based on other issues i've seen with Windows 7 I would suggest going to your device manager and try a rollback of your driver.

    If the problem didn't occur previously, I would try to do a system restore to a point where it was still working...

    Hopefully this sorts your problem out!

    Filip Wilms
    Saturday, July 25, 2009 6:28 AM
  • I recently installed windows 7 RC and everything worked perfectly for the first day. On returning home from work i lost internet connectivity. My other machines connect fine however if i put my dsl line directly into my network port or through my router i get no internet. the networking aspects through my router is good, i can copy files from my laptop and ping it.

    when i run inconfig on it (connected to the router) i get the following

    IPv4 Address...........:
    Subnet Mask............:
    Default Gateway.......:

    I assume the address is what is causing the problem. I have it set to auto IP configuration but even if i manually put in values i get address coming up.

    I did a fresh install with formatting the drive so the drivers loaded for the mother board came from the win 7 dvd. My PC is as follows

    ECS Elitegrouo Motherboard - Geforce 6100PM-M2
    AMD Athlon 64 X2 Dual Core 5000+ 2.60 GHz
    4GB RAM
    Windows 7 Ultimate 32Bit OS

    Thanks for the future help...
    PS: I've tried resetting bout my router and dsl modem

    here is a screen shot of my ipconfig...
    • Edited by sm27 Saturday, July 25, 2009 3:36 PM
    • Proposed as answer by sue emm Monday, November 2, 2009 3:26 AM
    Saturday, July 25, 2009 3:08 PM
  • i got the answer to my problem... found it here

    Saturday, July 25, 2009 3:58 PM
  • My search for the answer to this took me everywhere.  I got mine fixed and nobody else seems to have done it this way, so I wanted to pass on this cure in hopes it might save someone a lot of time. 

    First of all I live in a Best Western Hotel (not a motel) and they have EXCELLENT tech support. The BW tech support guy unblocked me from wherever he lives at the other end of the phone. He spent a total of about a minute doing this.  Here's what happened and what he did.

    The Problem
    My computer's wireless and Ethernet adapters were physically blocked from the router. I had an Unknown network and got the dreaded 651 error and the message, “Local area connection doesn't have a valid IP configuration .”

    How'd that happen?
    I was using an add-on to Firefox to check my bookmarks for dead links. I can't remember which add-on it was because I reverted to an earlier version of my OS in an attempt to fix it. When it reverted it deleted the add-on. Today when I went to find it again, it is not available. Wonder why??? The kicker to all this is that I was watching my computer when the problem happened. It was like someone flipped a switch turning off my Ethernet adapter. I was on the wired connection (Ethernet) and switched to the wireless with no problems...until I tried to check my dead links again. Again the switch flipped off but for my Wireless adapter. RIGHT IN FRONT OF ME! Then I was really dead in the water. The problem was that the Best Western firewall saw my computer checking my bookmarks. The computer checked more than 300 websites within 1 minute and the firewall thought my computer had a virus. Thinking it had a virus the firewall blocked the physical address of my Ethernet adapter (first) and my wireless adapter (second) from further connections.

    The Fix
    1. Start by running cmd from the start menu
    2. Type “ipconfig /all” without the quotes
    3. Write down the physical address of which ever connection is/are not working. If you are hard wired to your router, then use the Ethernet adapter physical address. If you are running wireless, then use the Wireless LAN adapter. I had to do this for both.
    4. Go to your router's firewall and find the physical addresses of the connections.
    5. Find the physical address(s) of your blocked adapter(s) and unblock it.
    Sorry I can't be more specific for everyone's router but that is the general idea. I'm using Win 7 but I don't think it makes any difference.

    YOUR problem
    If you did not do anything unnatural that a firewall might have picked up as a virus, then you might have an actual virus that your outbound firewall blocked.
    Friday, November 13, 2009 10:10 PM
  •    i was having trouble with the same issue, but nothing worked. then, after two days, i found out, that ESET Smart Security was the problem.
       two days ago i re-installed win 7 and after the installation the program (ESET Smart Security 4) noted, that there was a problem with the firewall. ofcourse i didn't mind the notice, and thought that Windows' own firewall can do the job while i get this internet connection problem solved. after two frustrating days i was so annoyed of the Smart Security's notice to repair that i did it, and when the computer booted, all my previous connection settings were restored and the computer found my router instantly (even the name), and problem was solved.
       thought that i should mention it, if someone is as stupid as i can be. :)

    good luck!
    Saturday, December 26, 2009 1:56 AM
  • I've had the same problem, and solved it by increasing the number of ip-adresses on the routers DHCP-server (from 1 to 5).
    That made 7 connect right away :)
    Sunday, January 24, 2010 12:23 PM
  • Heyy... Walter,
    I also got the same IP conflict in windows 7 when I switched LAN. I went through the same steps-restarting, turn on/off modem, IP config renew.. and nothing resolved the issue.
    I have restarted the DHCP client from Services and rebooted the machine and now the issue resolved.
    Monday, February 8, 2010 3:41 PM

  • I had networking problems as well. 3 computers running Windows 7. 2 had Adobe CS3 installed which brings with is a piece of software called Bonjour. These two computers had no end of networking problems. 1 was a desktop connected to the router and the other was a laptop connecting via WiFi. Third computer didn't have CS3 and didn't have any trouble at all.

    In trying to find a solution (nothing seemed to work), I came across the solution shown below in a different thread and thought I would share it. I installed the upgrade for Bonjour (it's listed as Windows Vista 64 software) and all of my network problems cleared up. My thanks to "PDX Prod Mgr". Brilliant!

    PDX Prod Mgr Users Medals Users Medals Users Medals Users Medals Users Medals
     Proposed Answer
    I had the same problem when I rebuilt my Windows 7 system.  I had CS3 installed on my system, it installs an old version of bonjour.  If you inspect your program files\bonjour directory, see if you have an EXE and DLL file dated 2006.   Jump over to apple's website and search for windows bonjour.   I found the newer download here:    

    Download and install this (you don't have to uninstall the old Bonjour)  and reboot.  This fixed my install and I no longer have the network error you describe.  If you look at that folder now,  you will have the newer DLLs (and some other gunk.)   
    Sunday, February 14, 2010 5:40 PM
  • This may seem simple but having had the exact same problem with the no ip addy error msg ( OS W7 )   and after reading everything on this page I just went into the main settings/control page for my wireless router and added my pc's ip then applied and saved. Fixed it straight away.
    Saturday, May 15, 2010 1:10 PM
  • how do you get into the main settings of the router without being able to establish any sort of internet connection? i have the exact same problem as is mentioned as the thread title tried everything above, downloaded bonjour to usb, tried that and nothing? please help!!!
    Monday, May 24, 2010 5:25 PM
  • it depends on the brand of router you are using, typically you can type into your web address bar to access your router, I know this works for linksys and netgear routers. Some routers are typically these are belkin routers

    Wednesday, May 26, 2010 6:47 AM
  • Hey everyone,  I've had this problem for days with my home router on windows7.  Try these two commands and restart.  it worked for me.

    Link of Website is below also.

    2. Reset WinSock and TCP/IP Stack
    Open a Command Prompt as administrator:

    Reset WINSOCK entries: netsh winsock reset catalog
    Reset TCP/IP stack: netsh int ip reset reset.log
    Reboot the machine (you can run both commands first, I tend to put multiple commands in notepad and then copy and paste into the command window).

    • Proposed as answer by Amarnra Tuesday, March 19, 2013 12:37 PM
    Saturday, September 11, 2010 9:19 PM
  • The only way to solve this is to connect a computer with XP on the lan, share the connection from windows 7 to xp, and its fixed, reconnect the both windows 7 computer the home network comes on, then remove the Xp and reconnect the both windows 7 computers and it works ......


    Tuesday, November 9, 2010 8:51 AM
  • I had the same problem and what i did was i checked my DHCP server and saw what MAC address was assigned to that IP address and then double checked the other computer that was having the ip conflict because of the pc that had issues and I replaced the MAC address old the problem pc from my dhcp server and entered in the new mac address of the other computer
    Friday, December 10, 2010 8:20 PM
  • i got the answer to my problem... found it here

    hi , i have Disable Bonjour , STOP and reboot. but it still found Unidentified network... please help ~~~
    Wednesday, December 29, 2010 9:30 PM
  • Hi guys!

    I have had the same problem for a few days now, and have searched numerous forums and gone through hell and high water to fix it. nothing helped until I found the ultimate solution that will help everyone:


    During this time you must keep your router/modem turned off, and after the ISP has fixed the problem (in my case it took half an hour) you must restart your machine with the router/modem on and connected. From then on it should be like nothing ever happened.

    Just for the fun of it, here's a list of things I have tried without results:

    release/renew ipconfig
    restarting modem/router and computer about a zillion times
    changing LAN card
    creating a static IP
    resetting winsock in command prompt
    reinstalling Windows 7
    reinstalling XP (I had a dual boot and I did both, losing all installations)
    manually entering IP address
    disabling/enabling local area connection
    plugging and unplugging LAN cable
    uninstalling and reinstalling LAN card driver
    resetting modem/router using the reset button

    And after all this, all it took was just a phone call.
    This is because your ISP is THE ONLY authority when it comes to configuring your IP address. In this case, it can only be done from the outside. this is also the reason why Microsoft didn't announce any patches or fixes for this problem, because it is not their problem and responsibility.

    Only one question remains, WHY is this happening? Noone has been able to answer this, and I have read tons of forum posts about it. Maybe even the guys that made Windows 7 don't know it.

    I am going to copy this post on several other forums because I have seen the trouble that people are having with this problem.

    If you find out why this is happening, please post it here.
    • Proposed as answer by Insidiousmindz Tuesday, October 17, 2017 2:30 AM
    • Unproposed as answer by Insidiousmindz Tuesday, October 17, 2017 2:30 AM
    Monday, March 7, 2011 4:07 PM
  • I don't have de telephone number, wich number did you call.?
    Saturday, April 16, 2011 1:54 AM
  • I spent AGES looking for a solution to your problem as I was having the same difficulty. I have now fixed it at last!! This website has the solution that I used: 

    It worked perfectly for me. Hope it helps.

    Thursday, June 16, 2011 10:35 PM
  • You may get error Local Area Connection Does not Have A Valid IP Configuration due to damaged network cards. You need to check the network adapter card of the system to get the issue fixed. The network card needs proper drivers to be installed. If you have not installed the driver, then you need to click the ‘Update’ option for the network card and get proper drivers installed. You also need to check the status of the card. If it says “not working successfully”, you need to click the ‘Troubleshoot’ button and get the issue fixed.

    Hopefully, it may help you.

    Thursday, July 21, 2011 5:00 AM
  • Just for all the people who are still looking for an anwser. I had this error for two days after a big storm hit and our power went out. I did it all including buying a new network card, installing drivers, new windows. I even called our ISP and he told me he could not help me! The weird part was that our wireless still worked but the main computer could not establish a wired connection.

    It may be your router, this is how I found out:


    I plugged my modem directly into my computer and still got the error. I then disconnected the coaxial cable (the thick screw on cable) from the modem and let the lights go off and screwed it back in. This gave my computer an internet connection but upon reconnecting to my linksys router I got the 169 ip adress again. Then I tested it again by connecting my sisters labtop to my router via ethernet cable and she could not get a connection. I went out that night and bought a new router and finally after 2 days of headaches it worked. 


    If it seems like nothing else is working you can try this option. Good luck.



    Wednesday, August 31, 2011 6:18 PM
  • This worked for me! Thank You!
    • Proposed as answer by Skier7667 Thursday, March 22, 2012 2:07 PM
    • Unproposed as answer by Skier7667 Thursday, March 22, 2012 2:08 PM
    Thursday, October 13, 2011 6:52 PM
  • I started getting this issue in Window 7 64 bit Professional - Local Area Connection doesn't have a valid IP configuration - the error message you receive after running the Network Troubleshooter which has you turn your router off, then back on, etc.

    Problem was I could access my DSL modem in order to enter my user name/password and set it up correctly for internet access. The invalid IP config address of course
    prevented me from doing any of this.

    I read through the posts on this forum and on others and there seemed to be many suggestions on a resolution to the problem. I didn't have a faulty NIC or virus
    or modem. My problem started when I switched my Westell dual DSL modem/router gateway for a D-Link DSL modem using it in bridge mode to connect my D-Link
    DIR-825 router. Both had worked perfectly before, but once I made this switch, the program started and I was getting assigned an IP address starting with and no matter how many times I unplugged, restarted, reset the modem completely, rebooted, go to Safe Mode, ipconfig /release, ipconfig /
    renew - nothing seemed to work.

    In reading multiple posts it appeared that DHCP is supposed to assign an IP address of 192.168.x.x ( So I went to Servicesand looked for the DHCP Service and it was Startedand on Automatic. I left it on Automatic, but Stopped it and closed all windows. Then I powered off the PC completely. I reset the modem one more time and then powered on the PC. DHCP started again (since it was set on Automatic) assigned the correct IP address and now I was able to get into the modem and enter my Password, User name and set it back on bridge mode, so I could connect my router to it.

    Hope this helps others and I'm grateful for all those that took the time to submit their suggestions, as the culmination of them turned out to inspire me to try
    what I did.

    • Proposed as answer by Skier7667 Thursday, March 22, 2012 2:29 PM
    Thursday, March 22, 2012 2:29 PM
  • am stuck as well, been on this same problem for hours.

    i went to cmd and the message i got when i did ipconfig all is

    Microsoft Windows [Version 6.1.7601]

    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Uche>ipconfig/ all

    Error: unrecognized or incomplete command line.


        ipconfig [/allcompartments] [/? | /all |

                                     /renew [adapter] | /release [adapter] |

                                     /renew6 [adapter] | /release6 [adapter] |

                                     /flushdns | /displaydns | /registerdns |

                                     /showclassid adapter |

                                     /setclassid adapter [classid] |

                                     /showclassid6 adapter |

                                     /setclassid6 adapter [classid] ]


        adapter             Connection name

                           (wildcard characters * and ? allowed, see examples)


           /?               Display this help message

           /all             Display full configuration information.

           /release         Release the IPv4 address for the specified adapter.

           /release6        Release the IPv6 address for the specified adapter.

           /renew           Renew the IPv4 address for the specified adapter.

           /renew6          Renew the IPv6 address for the specified adapter.

           /flushdns        Purges the DNS Resolver cache.

           /registerdns     Refreshes all DHCP leases and re-registers DNS names

           /displaydns      Display the contents of the DNS Resolver Cache.

           /showclassid     Displays all the dhcp class IDs allowed for adapter.

           /setclassid      Modifies the dhcp class id.

           /showclassid6    Displays all the IPv6 DHCP class IDs allowed for adapter


           /setclassid6     Modifies the IPv6 DHCP class id.

    The default is to display only the IP address, subnet mask and

    default gateway for each adapter bound to TCP/IP.

    For Release and Renew, if no adapter name is specified, then the IP address

    leases for all adapters bound to TCP/IP will be released or renewed.

    For Setclassid and Setclassid6, if no ClassId is specified, then the ClassId is



        > ipconfig                       ... Show information

        > ipconfig /all                  ... Show detailed information

        > ipconfig /renew                ... renew all adapters

        > ipconfig /renew EL*            ... renew any connection that has its

                                             name starting with EL

        > ipconfig /release *Con*        ... release all matching connections,

                                             eg. "Local Area Connection 1" or

                                                 "Local Area Connection 2"

        > ipconfig /allcompartments      ... Show information about all


        > ipconfig /allcompartments /all ... Show detailed information about all




    Friday, May 18, 2012 10:46 AM
  • Solved my problem...thanks Skier7667!!!
    Saturday, May 19, 2012 4:19 AM
  • This is very bad advise. Do not restore your system just because of this minor issue
    Tuesday, July 31, 2012 4:14 AM
  • Just Change The RJ Connector. U have done.
    Monday, September 17, 2012 12:07 PM
  • Hey everyone,  I've had this problem for days with my home router on windows7.  Try these two commands and restart.  it worked for me.

    Link of Website is below also.

    2. Reset WinSock and TCP/IP Stack
    Open a Command Prompt as administrator:

    Reset WINSOCK entries: netsh winsock reset catalog
    Reset TCP/IP stack: netsh int ip reset reset.log
    Reboot the machine (you can run both commands first, I tend to put multiple commands in notepad and then copy and paste into the command window).

    This worked for me when nothing else did. Thanks!
    Friday, September 28, 2012 3:14 PM
  • Hey everyone,  I've had this problem for days with my home router on windows7.  Try these two commands and restart.  it worked for me.

    Link of Website is below also.

    2. Reset WinSock and TCP/IP Stack
    Open a Command Prompt as administrator:

    Reset WINSOCK entries: netsh winsock reset catalog
    Reset TCP/IP stack: netsh int ip reset reset.log
    Reboot the machine (you can run both commands first, I tend to put multiple commands in notepad and then copy and paste into the command window).

    I can also confirm that this is the only solution that worked for me. I entered the second command and rebooted computer. Upon restart my internet functionality was returned.

    You can find the original article on the microsoft website at:

    Tuesday, March 19, 2013 12:38 PM
  • I simply had 2 network adaptors on board. One as part of the system board the other just happened "to be there" - so I disabled the 2nd one and now my network is running fine.

    I have also noticed that on other older machines running XP that sometimes the newer RJ45 network cables (bright colours etc. rather than the grey colour of older cables) don't allow connection for some strange reason although "new" and "old" should not make any difference but they seemingly do. 

    Friday, July 12, 2013 3:21 AM
  • I've had the same problem, and solved it by increasing the number of ip-adresses on the routers DHCP-server (from 1 to 5).
    That made 7 connect right away :)

    Dude you rock! Been putting together a computer for my older brother's birthday and got stuck on updating my mobo drivers including the network driver (putting Win 7 on an old nVidia2 Ultra AMD mobo).  Found some drivers that would work (anyone who's needing, they were found here:

    Installed the drivers then hit the invalid IP message so at first I thought the driver install didn't work.  After reading your comment, I remembered that I had set up my ATT Uverse Motorola NVG510 to allocated only 1 IP address.  This was done b/c the NVG510's wireless well, isn't and I needed to set up my own wireless router on the local network.  Anyone needing that solution, see here:

    Allocating another IP address fixed it.  Word and thank you!!!!


    ps Sorry about the naked links, Technet won't let me post links until they "verify" my account.

    • Edited by amseek Sunday, April 6, 2014 7:58 AM
    Sunday, April 6, 2014 7:56 AM
  • So how do you "Update" without internet connection
    Friday, May 1, 2015 6:18 PM
  • Thank you so much! I was having trouble with IP Config and did your steps thru the DHCP after doing a few steps to enable my IP then restarted the computer and it worked. Thank you!
    Wednesday, December 14, 2016 2:30 AM