locked
using sce variables (monitor properties->warning pane) RRS feed

  • Question

  • hi i have a question,

    we currently implementing windows service monitoring using sce 2010 for our servers, works well...but i have a problem using sce variables in the warning name...

    in the Service-Running-State-Properties under the pane Warning there is the "name of the warning" and the "description of the warning"...

     

    name of warning is: windows service stopped

    and in the description field :

    The '$Target/Property[Type="MicrosoftSystemCenterNTServiceLibrary!Microsoft.SystemCenter.NTService"]/DisplayName$' service on computer $Target/Host/Property[Type="Windows!Microsoft.Windows.Computer"]/NetworkName$ has stopped running

    i want to use a variable like the computer name in the name of the warning but when i try to enter for example:

    Windows Service Stopped on $Target/Host/Property[Type="Windows!Microsoft.Windows.Computer"]/NetworkName$ sce interprets it as normal text (in the warning name line)

    are variables only supported in the description because when i setup email notification for the warning it would be nice to see the server name in the subject and not only Windows Service stopped...

     

    thanks for ur help

    regards

    Harald

    Monday, September 5, 2011 12:45 PM

Answers

  • Hello Haraid,

    This behaviour is by design. The "name of warning" does not support any variable.

    Thanks,


    Yog Li -- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Yog Li Tuesday, September 13, 2011 9:39 AM
    Wednesday, September 7, 2011 11:24 AM