locked
Mapi Over Http and outlook 2010 RRS feed

  • Question

  • Hello.

    I've tested a outlook connectivity to Exchange online and got unable to configure new profile with Outlook 2010 when mapi is disabled (set-casMailbox -mapienabled $false), but succeeded with Outlook 2016. However Outlook 2010 works fine with existing profile and only unable to configure new one.

    As described here Outlook 2010 have complete support of Mapi over Http (ofc with req updates).

    https://support.microsoft.com/en-us/help/3201590/rpc-over-http-deprecated-in-office-365-on-october-31,-2017

    What i'm doing wrong? Or maybe there is another way to configure profiles with Outlook 2010?

    I'm using x86 version 14.0.7172.500

    Thanks


    Wednesday, March 1, 2017 11:33 AM

Answers

  • Sorry it was my own mistake. I should use MapiBlockOutlookRpcHttp instead of MapiEnabled parameter
    • Marked as answer by GrayscaleRu Monday, March 13, 2017 2:52 PM
    Monday, March 13, 2017 2:52 PM

All replies

  • Hello,

    Does this issue happen with all clients that have Outlook 2010 installed?

    Do you have the MapiHttp feature is disabled on the Outlook client using the following registry value:

    Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
    DWORD: MapiHttpDisabled
    Value: 1

    In addition,

    Since this issue is more related to the Exchange server side, if above doesn't apply, I'd recommend you post a new question to Exchange Online forum to get further assistance:

    https://social.technet.microsoft.com/Forums/msonline/en-US/home?forum=onlineservicesexchange

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steve Fan Friday, March 10, 2017 9:38 AM
    Thursday, March 2, 2017 9:52 AM
  • Sorry it was my own mistake. I should use MapiBlockOutlookRpcHttp instead of MapiEnabled parameter
    • Marked as answer by GrayscaleRu Monday, March 13, 2017 2:52 PM
    Monday, March 13, 2017 2:52 PM