none
prior install, now a windows installer error code on a new install RRS feed

  • General discussion

  • Vista SP1
    Steady State 2.5

    I installed Steady State last week just to check it out and wanted to uninstall it but it wouldn't uninstall. I ended up deleting all instances of "steadystate" in the registry, deleting the Cache.wdp file, and Steady State in Program Files.

    Now, upon a new install of the msi I get "The configuration data for this product is corrupt. Contact your support personnel"

    I installed Windows install cleanup to try and clear out any leftover config files but the program wasn't listed.

    I researched the registry and found these values related to Steady State that were undeletable:

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\Root\LEGACY_WINDOWS_STEADYSTATE\0000]
    "Service"="Windows SteadyState"
    "Legacy"=dword:00000001
    "ConfigFlags"=dword:00000000
    "Class"="LegacyDriver"
    "ClassGUID"="{8ECC055D-047F-11D1-A537-0000F8753ED1}"
    "DeviceDesc"="Windows SteadyState Service"

    Both:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\Root\LEGACY_WINDOWS_STEADYSTATE
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\Root\LEGACY_WINDOWS_STEADYSTATE\0000

    are undeletable using regedit (also the values under [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\Root\LEGACY_WINDOWS_STEADYSTATE\0000 )

    What would be a good way to correct this?


    Friday, February 6, 2009 4:34 PM

All replies

  •  

    Hi mdsharp24, have you tried taking ownership of the registry entries and then delete them?


    Sean Zhu - MSFT
    Monday, February 9, 2009 7:23 AM
    Moderator