none
GPP Run Once and do not reapply doesn´t work in Windows 10 v1607

    Question

  • My observation is, that when I create GPP for user, create update or replace registry settings and set it to apply only once, it will not inherit. Right after I disable this Run Once - option, I get it working.

    I´ve tested this in multiple machines with multiple accounts in my lab. Can anyone else confirm?


    In Windows 10 1511 Run once works fine!
    • Edited by yannara Friday, August 12, 2016 11:44 AM
    Friday, August 12, 2016 11:43 AM

All replies

  • Hi,

    Thanks for your post.

    Group Policy preferences provide the means to simplify deployment and standardize configurations. They add to Group Policy a centralized system for deploying preferences (that is, settings that users can change later).

    The GPP will reapply until group policy refresh (user configuration will refer in 90 minutes by default) or run gpupdate /force mannually.

    For more information about GPP, please refer to the article below.

    Using Group Policy Preferences

    https://technet.microsoft.com/en-us/library/gg699429.aspx

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 15, 2016 9:13 AM
    Moderator
  • Jay, like I wrote above, this works in 1511, but not in 1607.
    Monday, August 15, 2016 11:52 AM
  • Hi,

    The GPP still do not apply after running GPUpdate /force on 1607?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 16, 2016 4:33 AM
    Moderator
  • Hi,

    The GPP still do not apply after running GPUpdate /force on 1607?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    That´s right! Now you got it :) ..but they will if I tick off that "run once and do not reapply" - setting.
    Tuesday, August 16, 2016 7:13 AM
  • I was wrong before - the problem occures also in previous versions of Windows 10. The root cause is bad handling of run once in user logon prosessing. There is similar older thread about this: https://social.microsoft.com/Forums/en-US/4684e43c-a53d-4e4b-87a4-42480a40d4c5/preferences-registry-dont-apply-if-set-to-quotapply-oncequot?forum=winserverGP

    I also witness random behavior in this, but latest mass test shows me, that the chance to get this working is less than 50-50.

    • Proposed as answer by Jay GuModerator Wednesday, August 24, 2016 9:53 AM
    • Unproposed as answer by yannara Wednesday, August 24, 2016 1:14 PM
    Tuesday, August 23, 2016 3:58 PM