locked
Cannot create Public folders - The process failed to get the correct properties RRS feed

  • Question

  • Hi All,

    we have an Exchange 2013 DAG and a few PF databases. If users want to create a new Folder or subfolder they receive following mesage in Outlook. "Cannot create the folder". If I create the folder in the ECP the folder will be created with the message "The process failed to get the correct properties". The folder is visible in Outlook but not accessible.

    Users has owner permissions and just a few folders are concerned, it´s not a general problem. I have already done an integrety check, defrag and a soft repair on all PF databases, and all databases are healthy. No errors and warnings in the logfiles.

    Does anyone has an idea?

    Thanks

    Best regards,
    Dirk


    • Edited by DServ Wednesday, April 1, 2015 8:31 AM
    Wednesday, April 1, 2015 8:30 AM

Answers

  • Solution: Move the Primary Public Folder mailbox to an own database. This will solve replication and performance issues with the PF structure.

    Regards,

    • Marked as answer by DServ Wednesday, April 29, 2015 7:05 AM
    Wednesday, April 29, 2015 7:05 AM

All replies

  • Is this a new problem or has this never worked? Are those folders replicating to the other databases? Can you re-create the folders that are having issues and test on the 'new' folders?
    Wednesday, April 1, 2015 11:38 AM
  • Hi Josh,

    this is a new Problem, the PF worked smoothly before. The PF databases replicating to other members in the DAG and I already suspend and deleted the replication with no success.
    What do you mean with re-create the folders and test on the new ones? I´m able to create a folder in the first PF Mailbox (Primary) but not in the second hierarchy.

    I´ve also been inheriting all permissions from the root folder to be sure it´s not a permission issue but it´s still not working.

    Dirk

    Wednesday, April 1, 2015 12:06 PM
  • When you said, "just a few folders are concerned", that made me think you could delete those folders and re-create them. MY apologies if I was mistaken.

    can you verify permission in ADSI? And to be clear, no one can create sub's within these specific folders but other folders are ok? I'm leaning towards something wonky with permissions, hence, my inclination to re-create those folders if possible. Can you run { Get-PublicFolderClientPermission -Identity "path to folder" -Server "servername" }and verify the permissions here? also run the Get-PublicFolderAdministrativePermission to verify admins have this access.

    I've had a problem in the past where I've had to push permission down via ADSI edit because no other method would work for me.


    • Edited by Josh Lavely Wednesday, April 1, 2015 12:27 PM Left out a param
    Wednesday, April 1, 2015 12:26 PM
  • You´re right, it could be a permission issue because the trouble began when I ran AddUsersToPFRecursive.ps1 -TopPublicFolder.

    Get-PublicFolderClientPermission -Identity has the same permissions like in the ECP and Get-PublicFolderAdministrativePermission is not more available in Exchange 2013.

    Did you inherited the permissions with ADSI on the "CN= Folder Hierarchies" Folder?

    Wednesday, April 1, 2015 12:43 PM
  • I had to set these permissions to the Databases themselves in ADSI Edit so,

    Configuration Partition ::

    Services > Microsoft Exchange > Organization > Administrative Groups > Exchange Administrative group () > Databases > Right-Click your database and set permissions here. Hope this helps!

    Wednesday, April 1, 2015 1:19 PM
  • The permissions in ADSI Edit are ok. 

    I´ve tried to inherit the permissions on the root public folder and ran the "AddUsersToPFRecursive.ps1" script, it works only at the Primary Hierarchy and not at the secondary. On folders at the secondary hierarchy I received "RPC call failed to sync public folder".

    Has anyone an idea? It seems that something is broken from the primary to the secondary hierarchy.






    • Edited by DServ Thursday, April 2, 2015 9:20 AM typo
    Wednesday, April 1, 2015 1:31 PM
  • Update: The Public Folder primary hierarchy isn´t synchronizing with the secondary hierarchy. The log files show timeouts. The issue isn´t fixed in CU8. Microsoft Premier Support is working on it.

    https://support.microsoft.com/en-us/kb/3040681

    Dirk

    Tuesday, April 21, 2015 1:45 PM
  • Solution: Move the Primary Public Folder mailbox to an own database. This will solve replication and performance issues with the PF structure.

    Regards,

    • Marked as answer by DServ Wednesday, April 29, 2015 7:05 AM
    Wednesday, April 29, 2015 7:05 AM
  • Hi, I have the same error on Exchange 2013. Exact same symptoms from Outlook and ECP. 

    We have several public folder mailboxes split into a Primary and Secondary Hierarchy.

    Can you confirm what you mean by "Move the the Primary Public Folder mailbox?" Currently both our Public and Secondary Herirachy are located in a single Public Folder Database. Do you mean you split these into two?

    Any assistance would be greatly appreciated. Thanks.

    (Am also going to try installing CU9 to see if that resolves the issue).

    Friday, July 10, 2015 7:47 PM
  • Hi,

    the problem are replication issues in a large Public Folder structure. It´s best practise to keep the primary mailbox in a separate database. If you have much public folder mailboxes (max 50), then split it in different databases.

    Dirk

    Monday, July 13, 2015 7:02 AM