none
Reason for Login failed for user ‘Domain-name\SRV2$’. in sharepoint

    Question

  • Hi

    the machine-account fails?  towards “sharepoint_config”.  what is the reason

    for example 

    srv1 srv2 srv3 srv4 only two servers displays critical error 

    Login failed for user ‘Domain-name\SRV1$’.

    Login failed for user ‘Domain-name\SRV2$’.

    Error is in sharepoint servers SQL database login for 'SPL_Config' on instance 'SRVSQL1_SQL' failed. Additional error information from SQL Server is included below.



    adil

    Monday, April 24, 2017 8:24 AM

All replies

  • I think the users you used don't have enough db permission.

    顺其自然地勇往直前!—Justin Liu

    Tuesday, April 25, 2017 2:53 AM
  • Hi Adil,

    Grant correct permissions to the database access account :-

    https://technet.microsoft.com/en-us/library/ee513059%28v=office.14%29.aspx

    Also, Please check in service.msc if any service is running as the computer account (which does not have access to the Config database)

    Let me know if this helps. Feel free to get in touch in case you need further help.

    Thanks, Vandana Rathore (MCSE, MCTS, PRINCE2®) |(Please remember to click on “Mark as Answer” if this post helps you)


    Tuesday, April 25, 2017 4:34 AM
  • Vandana, please don't propose your own replies as answers. Let the community or the original poster do that.

    Thanks


    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, April 25, 2017 2:21 PM
    Moderator
  • check if you have recently installed product service running on local system account? That's where the impersonation is happening. 
    Tuesday, April 25, 2017 5:22 PM
  • You may get detailed information in ULS logs.

    Open event viewer , go to general tab of the error, can you see any correlation ID? if so please copy ID and search in ULS logs based on time stamp of the error.

    Please let us know ULS error details with above correlation ID.

    -Ashok Yadala


    Best Regards, A-Yadala Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.


    • Edited by Ashok Yadala Wednesday, April 26, 2017 6:21 PM spell check
    Wednesday, April 26, 2017 6:20 PM
  • Hi @Asfaw  what do u mean by product service running on local system account?

    also search service not crawled some sites in web application and throw below errors in crawl logs

    Count Error message
    192 An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser.

    An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( Error from SharePoint site: WebExceptionStatus: TrustFailure The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel


    adil

    Wednesday, May 3, 2017 7:34 AM
  • Adil,

    Trace on Services.msc console service running on local system account. As an example any backup agent.

    Hope this helps.

    Wednesday, May 3, 2017 2:48 PM