none
Logging in to Non-Domain Network Share from computer on Domain RRS feed

  • Question

  • I've got a machine running Windows 7 logged on the network domain but when I try to map a share to a machine on the network, but not registered on the domain I cannot connect (even though I have a local account on the networked machine).

    When attempting to connect Windows 7 prompts me for my connection credentials and it automatically fills in the domain name. 

    How can I connect to this network share using credentials that are local to that network share?
    Tuesday, January 20, 2009 4:05 PM

Answers

  • When you say local credentials I assume you mean local on the "TestServer", not local on the Windows 7 box. Then you should be able to just type in TestServer\LocalAccount and the password (the domain you see should automatically switch to "TestServer")

    Also; have you tried mapping the drive using the IP address (i.e. \\xx.xx.xx.xx\TestShare)?
    • Marked as answer by Stunnerkline Tuesday, January 20, 2009 9:57 PM
    Tuesday, January 20, 2009 9:07 PM

All replies

  •  Have you tried entering the username prefixed with the machine name, i.e. MYMACHINE\myuser? That should automatically switch the "domain"
    • Proposed as answer by Marcelomza Thursday, May 28, 2009 5:18 PM
    Tuesday, January 20, 2009 4:50 PM
  • As Kjetil suggested,  try using the COMPUTERNAME\USERNAME or WORKGROUP\USERNAME combination in the username field.

    Joe
    Tuesday, January 20, 2009 4:58 PM
    Answerer
  • Thanks for the replys but that does not work.  I tried typing in \\<servername>\<username> as well as <servername>\<username> and in both cases it fails saying that the resource is unavailable and that I might not have permission to access the network resource, yet I can map to that non-domain server share without a problem from an XP machine on the same domain.

    It appears to me that Windows 7 has taken the security leap that once a machine is registered on a domain it can only access other machines on that domain?  That doesn't seem right??
    Tuesday, January 20, 2009 8:00 PM
  • I have both domain and non-domain computers in my network, but I have no problem.

    What OS is the computer with the share running? Are you by any chance trying to connect to a NAS box or Samba server? If so, you may have to change some policy settings.
    Tuesday, January 20, 2009 8:07 PM
  • Thanks for the reply, Kjetil.

    The machine that is not registered on the Domain is running Windows Server 2000.

    Here is more detail on what I'm trying to do:

    If you have a share on a non-Windows 7 machine (let's call the machine "TestServer" and the share "TestShare") that is not registered on the domain and you go to a Windows 7 machine, on the same network and registered to a domain, and try to map a drive letter to that share, what do you put in the credentials box?

    When I attempt to do this the credentials box comes up with a place for Username and a place for Password and below that is says "Domain: XXXX" (where the XXXX's are the domain that the machine I'm trying to map from is registered).

    On the "TestServer" machine there is a local logon account, let's call it "LocalAccount".  On a machine with XP I can simply choose to map the drive and select the 'connect as a diferent user name' and supply the local account credentials and the drive will map.  In this case, if I simply type "LocalAccount" into the Username box on and supply the password the XXXX domain is automatically added to the Username and the logon fails because "TestServer" isn't part of the domain.

    It would seem like there should be an option to not pre-pend the domain name or choose to use local login credentials??

    Tuesday, January 20, 2009 8:52 PM
  • When you say local credentials I assume you mean local on the "TestServer", not local on the Windows 7 box. Then you should be able to just type in TestServer\LocalAccount and the password (the domain you see should automatically switch to "TestServer")

    Also; have you tried mapping the drive using the IP address (i.e. \\xx.xx.xx.xx\TestShare)?
    • Marked as answer by Stunnerkline Tuesday, January 20, 2009 9:57 PM
    Tuesday, January 20, 2009 9:07 PM
  • Yes, local credentials are local to the TestServer.

    When I type in TestServer\LocalAccount the domain listed does switch to TestServer but I still cannot connect.

    If this should work then it must be something else on my end, I just thought there was something I was missing or a new way to do this type of mapping.

    Thanks again for the help.

    Tuesday, January 20, 2009 9:35 PM
  • I retried the process, deleting the current "browsed" connection to the share, and re-mapped the share and selected the option to logon using different credentials.  At this point I typed in TestServer\TestAccount and everything mapped successfully.

    Thanks again.
    Tuesday, January 20, 2009 9:58 PM
  • I'm running Windows 7 in a domain and was having a having a hard time mounting up a samba share on a linux box, since the linux box wasn't a part of the domain and Windows 7 insisted on pre-pending our domain name.  When asked for a user name, instead of connecting as "admin" (which inhereited "domain\"), I connected as "\admin".  It worked like a charm!
    • Proposed as answer by Bobl256565656 Thursday, November 19, 2009 11:59 PM
    Thursday, May 28, 2009 2:29 PM
  • Hello, my problem is: the server does not accept the username or pass win 7, when trying to connect to the domain. You help? Thank you
    Thursday, May 28, 2009 5:23 PM
  • I found that to make login/passwords work in windows 7, it needs the following "fix":

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    more details here:
     http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746
    • Proposed as answer by IT MDC Wednesday, May 4, 2016 9:16 AM
    Thursday, July 2, 2009 9:18 PM
  • I was having the same problem as Stunnerkline -- Windows 7 computer in domain trying to connect to a Windows server not in the domain.  Would not work.  This included connecting to both shares and secure web pages on the server.   Used \user and it worked perfectly.   Have been working around this for a week now and then spent 3 minutes online just now finding the answer.  Thanks cmulkey! 
    Friday, November 20, 2009 12:03 AM
  • I had the same problem and I did try the \\[IP Address]\[Share Name] and it worked.  When it asked for credentials I entered "\[local admin username]" (where local means the server that the share is hosted on) and password.

    The question is why is it not liking the hostname?  I can ping the other machine with the hostname, so I know that DNS can resolve the name to an IP.

    Friday, April 30, 2010 1:06 AM
  • Thanks, almost 7 years later this helped me today ;)
    Wednesday, May 4, 2016 9:17 AM
  • I've got a machine running Windows 7 logged on the network domain but when I try to map a share to a machine on the network, but not registered on the domain I cannot connect (even though I have a local account on the networked machine).

    When attempting to connect Windows 7 prompts me for my connection credentials and it automatically fills in the domain name. 

    How can I connect to this network share using credentials that are local to that network share?

    Monday, December 5, 2016 9:20 AM
  • What is the solution? I am facing the same issue since 6 months and want to really solve it now.
    Tuesday, April 17, 2018 11:03 PM
  • The explanations here aren't clear, but I did get mine to work using this thread though: one computer in our network was mistakenly configured on a domain, and the same issue in windows 7 was occurring, where it tried to replace the domain info with what's on YOUR local PC correct? LocalDomain\LocalUserName. The Domain in question is often just the name of the computer you're on (at least it was in my case). This will not work when you're trying to connect to an outside device, because it wants the SERVER domain that you're connecting TO.

    What worked for me (because we don't use active directory or any kind of domain configuration) was ServerName\ServerUserName where ServerName is the name of the server computer and ServerUserName is just the user on that server that you would normally use to connect the drive by itself. The username is also the account in which the share was created. To find this information, open CMD, ON THE SERVER, type whoami hit enter. use the results ServerName\ServerUserName with the password for that user account and it should work.

    Hope this help.

    Friday, June 22, 2018 7:16 PM
  • I resolved the issue using Kircos' solution with one change.  Use "Send NTLMV2 only."

    Quote:

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    Thursday, October 11, 2018 11:21 PM