locked
Intellitype privileges issue RRS feed

  • Question

  • Hi, I've been using a MS Sidewinder keyboard with the Intellitype software and I got my macro keys assigned and working fine. However if a program is right-clicked and "run as admin" then the macro buttons will not work.

     

    Now I know I can work around this issue by running itype.exe itself "as admin" on startup and it will allow me to use the macro keys in admin-run programs. But this will then disable the keys in non-admin-run programs.

     

    Huh, I hope this makes sense to somebody. :) So, is there a way to have the macro keys working in both scenarios at the same time, i.e. in programs I run normally and also in programs I "run as admin"?

     

    Thanks!

    Saturday, December 10, 2011 8:55 PM

All replies

  • Hi,

    For hardware questions, please ask here: http://www.microsoft.com/hardware/en-us/support

    Thanks for your understanding and cooperation!

    Regards,

    Miya


    Miya Yao

    TechNet Community Support

    Monday, December 12, 2011 3:13 AM
  • Hi,

     

    first of all this is really an application-level question, not a hardware one. It concerns the intellitype software.

     

    Second, the link you gave me lists none of my neighboring countries to call for hardware support. I am in Slovakia.

     

    Can you help any further? Thanks!

    Tuesday, December 13, 2011 7:58 AM
  • Hi globalistas, have you changed your keyboard by now? I know that 10 months passed by but I faced this problem and solved it.

    I just bought a Natural 4000 keyboard; hotkeys and custom mapping did not work when I was on Steam, which I run with administrative privilege.

    To get it working you must configure a new scheduled task according to the replies in this post:

    http://superuser.com/questions/46/elevated-priviliges-for-startup-applications-in-vista/190#190

    It will run with both programs, administrator and normal user.

    Ask me if you have any trouble.

    Saturday, August 11, 2012 6:45 PM