locked
User settings not getting saved for connection group applications -App V 5.0 RRS feed

  • Question

  • Hi,

     We have Application A with user settings keys.The settings are getting saved when user changes the values as standalone publish.

    But once Application becomes part of connection group. Application user settings will not get saved if user updates path. For each launch it pulls up defaults user settings. Is it know behavior for connection group application?

    If Connection group application does not have any user default settings, if user updates user settings, settings are getting saved.

    Regards,

    Manju


    Tuesday, September 22, 2015 8:58 AM

Answers

  • User settings from member packages will not be transferred to a connection group .Similarly, once the Connection Group is disabled, user settings done inside the Connection Group will not be transferred back to the member packages.

    Example: In your case, if you do any changes to app A which stores information in its user settings. Next time when you launch the application those settings will be reflected. But when you add it to a connection group, those changes done earlier in user settings wont reflect now as it wont be propagated inside the connection group.

    Suppose now in this connection group, if you do changes to user settings, it will reflect.But when you remove it from the connection group the settings will be reverted back to earlier one.

    More info - http://app2pack.blogspot.com/2015/09/user-settings-and-connection-group-in.html


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Tuesday, September 22, 2015 11:13 AM

All replies

  • User settings from member packages will not be transferred to a connection group .Similarly, once the Connection Group is disabled, user settings done inside the Connection Group will not be transferred back to the member packages.

    Example: In your case, if you do any changes to app A which stores information in its user settings. Next time when you launch the application those settings will be reflected. But when you add it to a connection group, those changes done earlier in user settings wont reflect now as it wont be propagated inside the connection group.

    Suppose now in this connection group, if you do changes to user settings, it will reflect.But when you remove it from the connection group the settings will be reverted back to earlier one.

    More info - http://app2pack.blogspot.com/2015/09/user-settings-and-connection-group-in.html


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Tuesday, September 22, 2015 11:13 AM
  • ^^ As he say... Under the hood registry/file system changes are written do different places if you create a connectiongroup. In the registry for instance a merge takes place from all packages in the group.
    Tuesday, September 22, 2015 10:00 PM
  • Hi Vignesh,

    Thanks. Scenario is different. user settings of connection groups application is not getting updated\saved. 

    Application is having default user settings and part of connection group. When user launch the application and tries to update default settings preference. It is not getting saved\updated.  for each time launch it is picking up default user settings. This behavior only if application is part of connection group.

    To troubleshoot this issues, we remove application from connection group. Everything works as expected. We are not expecting the user settings to carried from standalone to connection group. Why settings are not getting saved when application is part of connection group?




    Wednesday, September 23, 2015 1:52 PM
  • Hi Tiberivs,

    Yes. This issue observed only on connection group application.  More information as below

    Application is part of connection group. If user perform any changes for existing user settings, the user registry is not getting updated. For each launch it pulls up default settings. 

    But strange thing is, If user set new settings(Not existing one settings and not part of bubble), it get saved under the same hive with new registry.

    This issue observed only on connection group. Not on stand alone application.

    Regards,

    Manju

    Wednesday, September 23, 2015 2:54 PM
  • As Tiberivs said, when application is in a connection group, the settings get saved to a different reg/file location. And I believe in your case, the application checks for a particular file/reg rather than that saved in a connection group location.

    Also try changing the order of the application to highest in the connection group, as the highest settings (residing in same location) will overwrite other settings. (May not be your case, just give a try)


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, September 23, 2015 3:23 PM