none
DPM 2010: Problem creating a replica. DPM failed to communicate with <SERVER> because the computer is unreachable. (ID: 41) RRS feed

  • Question

  • I am in the process of setting up a DPM 2010 server however I am having some issues that are hard to resolve, all of the server in the network are Windows Server 2008 R2 SP1.

    The local system (physical) that DPM is installed on works great, all of the Hyper-V machines are backed up and the Bare Metal stuff all works great, however i having issues with the other systems that are on the network.

    I keep getting this same error over and over again:

    The replica of Backup Using Child Partition Snapshot\TEST_VM on HostServer.contoso.com is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. (ID: 3106)

    DPM failed to communicate with HostServer.contoso.com because the computer is unreachable. (ID: 41)

     

    I have tried many different things:

    ipconfig /flushdns and /registerdns

    Added the Windows Server Backup feature

    Verified there is only 1 dns record

    I am able to ping and remote desktop from the DPM server to the "HostServer", protected system.

    I enabled the "Server Manager Remote Management"

    I verified that the firewall rules exist for DPM:

    I created the PingBeforeConnect DWORD:

    I have tried deleting the protection groups and recreating them.

    I have tried uninstalling the agents and reinstalling as well as resetting the DPM server name on the protected server.

     

    Does anyone have any suggestions? I am gettting desperate!

     


    • Edited by amdderik Monday, November 28, 2011 11:37 PM
    Monday, November 28, 2011 11:36 PM

All replies

  • No one has any ideas on this?

    Tuesday, November 29, 2011 6:20 PM
  • I was having the same issue.  I read your comment about 1 DNS record and that got me to thinking.

    My DPM2010 server has 6 NICs. Each server I am protecting has 2 NICs.  So on the protected servers, I ran 1 patch cable to the main network, and then connected a second patch cable just between the protected server and the DPM 2010 server – no switch or anything in between. I gave the second connection a 192.168.xx.yy address on the protected server and match it to 192.168.xx.1 on the DPM2010.

    When I first set up the protected servers, I connected to the main network (172.16.xx.yy) and took the defaults. Without thinking about it, on the Advanced Tab, and then on the DNS tab, the default is to leave the following checked:

    This is fine for the first NIC on the protected server. But when setting up the second NIC on its own private 192.168.xx.yy network, I forgot in some cases to clear this check. That would register the second NIC in DNS also, and this I think was causing confusion to the DPM Server.

    Once I saw your note, I looked at DNS on the Domain controller, and found 6 DNS entries for my DPM2010 server and 2 each for some of my protected servers – which were the ones giving me the ‘recovery point failure” or “synchronization failure” messages, that in the details, contained the error message that titles this thread. The failing servers more than 1 DNS record.

    I deleted the protected server and DPM server 192.168.xx.yy DNS records (forward and reverse lookup), and clear the check box on all the 192.168.xx.yy network connections on all 6 servers. This seems to have cleared things up.

    I hope this helps in some – thanks for posting your issue, it did help me. Hope this returns the favor.

    Friday, December 23, 2011 5:56 PM
  • Great Thanks for the reply.

    For a temporary fix I have just been using the hosts file to over ride the DNS server.

    Friday, December 23, 2011 6:47 PM