locked
SCCM 2012 SP1 Distriubution Point Issues RRS feed

  • Question

  • Hi

    I have been bashing my head about this issue since the new server has been installed.

    None of my workstations are able to download using BITS from the SCCM server.

    By Build is SCCM 2012 Sp1 CU 3

    Server is Server 2012 R2 running with SQL 2012.

    I have checked BITS is installed and enabled under IIS

    I have tried to remove role and add back in again.

    My IIS now shows no virutal directories for DP

    Seems to not distribute packages

    Severity Type Site code Date / Time System Component Message ID Description
    Error Milestone SCM 4/12/2014 8:54:24 AM SYD-ITM-02.ab.local SMS_DISTRIBUTION_MANAGER 2302 Distribution Manager failed to process package "Configuration Manager Client Package" (package ID = SCM00001).    Possible cause: Distribution manager does not have access to either the package source directory or the distribution point.  Solution: Verify that distribution manager can access the package source directory/distribution point.    Possible cause: The package source directory contains files with long file names and the total length of the path exceeds the maximum length supported by the operating system.  Solution: Reduce the number of folders defined for the package, shorten the filename, or consider bundling the files using a compression utility.    Possible cause: There is not enough disk space available on the site server computer or the distribution point.  Solution: Verify that there is enough free disk space available on the site server computer and on the distribution point.    Possible cause: The package source directory contains files that might be in use by an active process.  Solution: Close any processes that maybe using files in the source directory.  If this failure persists, create an alternate copy of the source directory and update the package source to point to it.

    I have checked all of the above.

    I am ready to rip this thing out and start again, but I have 300 workstations trying to be managed by it.

    Not sure where to go to from here.


    Steven Wells

    Wednesday, December 3, 2014 10:08 PM

All replies

  • Have you reviewed distmgr.log?

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Thursday, December 4, 2014 1:26 AM
  • The first error or warning is this:

    Compiling C:\Program Files\Microsoft Configuration Manager\bin\x64\smsdpprov.mof  $$<SMS_DISTRIBUTION_MANAGER><11-28-2014 08:36:37.988-660><thread=3780 (0xEC4)>

    Failed to compile MOF file. Error code: 3 

    I am also having issues with my clients downloading policies via the MP Virtual Directory too.

    As a work around I have installed another DP on another server, but not MP. So still working on issues with MP


    Steven Wells

    Thursday, December 4, 2014 1:30 AM
  • I have just tried to reinstall DP on main server after re-registering MOF files, 

    This is the error that seems to be the cause

    Cannot set the current Drizzle Role status for the DP.

    SCCM won't create the IIS virutal directories, so everything reports 404 errors.

    I re-installed the MP role and that has fixed my policy download issues.


    Steven Wells

    Thursday, December 4, 2014 2:54 AM
  • I had the same issue,  I resolved it doing the following

    -Removed the DP role from the server

    -deleted the Server from the SCCM Console

    - i then deleted all SCCM packages and files from the Server that was being used as the DP.  ex.   d:\*

    - after a few minutes add the server back in the SCCM console and give it the DP role again.  all files will be re-uploaded back to the DP.

    Try that and see if that works for you.

    Thursday, December 4, 2014 3:26 AM
  • Cannot set the current Drizzle Role status for the DP.


    That's usually caused by BITS (or the lack of). Double check the OS requirements.

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, December 4, 2014 7:29 AM
  • Hi,

    BITS is enabled as I can see the icon in the default web site, and it's set as defaults.


    Steven Wells

    Thursday, December 4, 2014 7:36 AM