locked
Connector - Escalation option in an Incident from enabled to disabled when incident is updated by mail RRS feed

  • Question

  • Hi guys,

    I have the following behavior. I have opened an incident where escalation option is disabled. In one specific time, using Portal i set escalation enabled. The problem comes when an update is coming from email, the escalation option changes to disable. I know, the exchange connect has linked a template for updating when this option is disabled. I used a incident template (I use authorizing tool for removing the escalation property from incident class). But it does not work.

    My question is the following: do you know a way where escalated property keeps his last update value from portal? Maybe extended the Incident class could be an option but maybe you know other ideas.

    Many thanks.

    Thursday, August 4, 2016 10:14 AM

Answers

  • Just export the MP containing the incident Template that is configured in Exchange Connector. Open the XML in an editor and check if the "Escalated" property is set to true/false in the MP.

    If something is configured in the Incident Template it should be found somewhere here in the marked area:

     

    If the "Escalated" property is not configured in the MP it should not change the "Escalated" property in an Incident when the Incident Template is applied by the Exchange Connector on update of an Incident.

    Hope this helps. 


    Andreas Baumgarten | H&D International Group

    • Marked as answer by TonydAlbendea Wednesday, August 10, 2016 7:08 AM
    Tuesday, August 9, 2016 6:43 PM
  • How much Incident Templates does the Management Pack contain?

    Normally each property is only set once for each template.

    I would try this:

    • Make a copy of the xml-file ;-)
    • Search in the XML for the Incident template name (the name should be found in the <Language Pack> section). Copy the GUID in the Line above and search again.
    • The line where the GUID will be found should look like line 33 in my screenshot.
    • Start looking for the "Escalated" property within the next lines until the next "</ObjectTemplate>" tag.
    • Delete the line with the "Escalated" property (properties if found more than once between the two "ObjectTemplate" tags).
    • Save, import the MP (best in a SCSM test environment) and give it a try.

    Hope this helps.


    Andreas Baumgarten | H&D International Group

    • Marked as answer by TonydAlbendea Wednesday, August 10, 2016 9:49 AM
    Wednesday, August 10, 2016 7:18 AM

All replies

  • Hi

    I am not sure I understand completely your situation, but in general terms if a template does not have a value set for a property then it will not change the property when it is applied to the Incident.

    It sounds like the template used with Exchange Connector has the escalation option set to disable - if this was not set at all, then the email template should not change the escalation value. When the Incident is set to escalated in the portal, it would stay in this state when a email update is received.


    Glen

     


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    Thursday, August 4, 2016 12:08 PM
  • Hi,

    your last line describes my problem: "When the Incident is set to escalated in the portal, it would stay in this state when a email update is received" -> in my case when the incident is set to escalated in the portal, when a email update is received, escalated option is removed. The template used for updating leaves escalated empty (not selected).

    this is the history of an incident when you do an update

    Property Changes:
    Property Old Value New Value
    Escalated True False

    Thursday, August 4, 2016 12:28 PM
  • Hi

    On the template for the email updates it would be difficult to see if it is set to Null or set to False as both would show an empty box.

    Do you have a test environment or at least a test Exchange Connector mailbox. If you can create a new email template and not do anything with the escalation checkbox, you will then know that it is set to Null. And see if it is still happening.

    Glen

     


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    Thursday, August 4, 2016 8:24 PM
  • Hi,

    from my test enviroment I have the same Problem but I will check really if the update sets escalation to false.

    Monday, August 8, 2016 6:10 AM
  • Just export the MP containing the incident Template that is configured in Exchange Connector. Open the XML in an editor and check if the "Escalated" property is set to true/false in the MP.

    If something is configured in the Incident Template it should be found somewhere here in the marked area:

     

    If the "Escalated" property is not configured in the MP it should not change the "Escalated" property in an Incident when the Incident Template is applied by the Exchange Connector on update of an Incident.

    Hope this helps. 


    Andreas Baumgarten | H&D International Group

    • Marked as answer by TonydAlbendea Wednesday, August 10, 2016 7:08 AM
    Tuesday, August 9, 2016 6:43 PM
  • Thanks Andreas,

    you are right, in the XML is set to false. Should I Change alone the part in your Image? because I found in the XML template used 3 times the escalation Option set to false, 2 of them in projections.

    Wednesday, August 10, 2016 7:09 AM
  • How much Incident Templates does the Management Pack contain?

    Normally each property is only set once for each template.

    I would try this:

    • Make a copy of the xml-file ;-)
    • Search in the XML for the Incident template name (the name should be found in the <Language Pack> section). Copy the GUID in the Line above and search again.
    • The line where the GUID will be found should look like line 33 in my screenshot.
    • Start looking for the "Escalated" property within the next lines until the next "</ObjectTemplate>" tag.
    • Delete the line with the "Escalated" property (properties if found more than once between the two "ObjectTemplate" tags).
    • Save, import the MP (best in a SCSM test environment) and give it a try.

    Hope this helps.


    Andreas Baumgarten | H&D International Group

    • Marked as answer by TonydAlbendea Wednesday, August 10, 2016 9:49 AM
    Wednesday, August 10, 2016 7:18 AM
  • can I use <null> or should I remove the escalated entries in the MP?
    Wednesday, August 10, 2016 8:42 AM
  • I would recommend to delete the line. Safest way ;-)

    Andreas Baumgarten | H&D International Group

    Wednesday, August 10, 2016 8:44 AM
  • You are right. I did it before but was not working. I Change the first template used in connector to another, and after it I apply the first template modified wihout escalation properties. Now it is working in my test enviroment. Thanks so much for your Support.
    Wednesday, August 10, 2016 9:51 AM