locked
Migration job fails on Distribution-point sharing gathering process RRS feed

  • Question

  • I am in the process of migrating from SCCM 2007 - 2012 and when setting up the source hierarchy the job fails with the following error:

                                                                    ERROR: [Worker]: Microsoft.ConfigurationManagement.SoftwareLibrary.ObjectSerialization.LibraryException: Couldn't find the specified instance SMS_SCI_SysResUse.SiteCode='ROS',FileType=2,NALPath='["Display=\\\\SC-RKGN-01\\"]MSWNET:["SMS_SITE=ROS"]\\\\SC-RKGN-01\\',RoleName='SMS Site System'     at Microsoft.ConfigurationManagement.SoftwareLibrary.ObjectSerialization.ObjectManager.GetInstance(ObjectKey objKey, LibraryContext context)     at Microsoft.ConfigurationManagement.SoftwareLibrary.ObjectSerialization.Library.Get[T](Expression`1 key)     at Microsoft.ConfigurationManagement.MigrationManager.DPSettingsSqls.SyncDistributionPoints(LegacyRepository legacySite, MigrationRepository currentSite, String sourceSiteCode, HashSet`1 version5ActiveDPsFQDN, IDictionary`2 stringResources)     at Microsoft.ConfigurationManagement.MigrationManager.DPSettingsSqls.SyncDistributionPoints(LegacyRepository legacySite, MigrationRepository currentSite)     at Microsoft.ConfigurationManagement.MigrationManager.SyncAgentJob.<SyncDPSettings>d__5f.MoveNext()     at Microsoft.ConfigurationManagement.MigrationManager.ExtensionMethods.<AttachErrorHandler>d__6`1.MoveNext()     at Microsoft.ConfigurationManagement.MigrationManager.ExtensionMethods.<AttachErrorHandler>d__6`1.MoveNext()     at Microsoft.ConfigurationManagement.MigrationManager.SyncAgentJob.<get_ExecutionPlan>d__7.MoveNext()     at Microsoft.ConfigurationManagement.MigrationManager.Job`1.ExecuteNext() SMS_MIGRATION_MANAGER 2013-03-06 2:41:06 PM 5620 (0x15F4)

    The server (sc-rkgn-01) being referenced was decommissioned a couple years ago and has been replaced. I had our DBA search the source site database and found one reference to sc-rkgn-01 as a distribution point for the secondary site ROS. We deleted the record and tried the job again, it failed with the same error.

    We have ran the 'Clean Up MIgration Data' on the SCCM 2012 site and rebooted both machines, however the job always fails at this spot. We have searched both the source and destination server databases and cannot find any reference to sc-rkgn-01.

    I am wondering if there is somewhere else that the source hierarchy wizard stores information as we are at a loss.

    Thanks

    Wednesday, March 6, 2013 9:06 PM

Answers

All replies

  • I also have a similar problem migrating DPs from SCCM 2007. The problem looks like the same so I didn't start a new thread about this. I gathered data without sharing DPs at first. Migrated all the necessary objects and collections. Now I'd like to share the DP's and to upgrade them. But data gathering process fails everytime with an error in migmctrl.log file :

      ERROR: [Worker]: System.Data.SqlClient.SqlException: Violation of PRIMARY KEY constraint 'ContentDPMap_PK'. Cannot insert duplicate key in object 'dbo.ContentDPMap'. The duplicate key value is (IST00140, WAS1B01.xxx.COM, MSWNET:\\WAS1B01.xxx.COM\, TK1, 2). The statement has been terminated. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at Microsoft.ConfigurationManagement.MigrationManager.MigrationRepository.BulkCopyData[T](Snapshot snapshot, LegacyRepository legacyRepository, IntlSqlFormatter formatter, Func`2 watermarkFunc, T lastMaxId, Boolean doNotDrop) at Microsoft.ConfigurationManagement.MigrationManager.MigrationRepository.BulkCopyData[T](Snapshot snapshot, LegacyRepository legacyRepository, IntlSqlFormatter formatter, Func`2 watermarkFunc, T lastMaxId) at Microsoft.ConfigurationManagement.MigrationManager.SyncAgentJob.<SyncDPSettings>d__5f.MoveNext() at Microsoft.ConfigurationManagement.MigrationManager.ExtensionMethods.<AttachErrorHandler>d__6`1.MoveNext()

    I really don't know what causes this, but there seems to be no duplicate records for the machine was1b01 in sccm 2007. Hope I don't have to upgrade 300+ DP's manually! :-|

    Monday, April 8, 2013 11:07 AM
  • Are your DP's within CM07 assigned an FQDN?

    Andy


    My Personal Blog: http://madluka.wordpress.com

    Tuesday, April 9, 2013 3:38 PM
  • deleting that DP solved the problem. Thank you.
    Friday, April 12, 2013 7:37 AM
  • I am having the same issue.  How did you resolve this?  The DP was not listed to delete.


    • Edited by willbar Thursday, July 18, 2013 3:31 AM added info
    Thursday, July 18, 2013 3:30 AM
  • Remove-CMDistributionPoint (http://technet.microsoft.com/en-us/library/jj850060.aspx) could work. Otherwise you would have to call Microsoft support because it is not supported to edit the database manually. http://thomasmarcussen.wordpress.com/2010/05/18/deleting-orphaned-distribution-points-from-sccm-packages/ is *not* supported!

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, July 18, 2013 7:47 AM
  • This would work on a 2007 DP?  Would I run this on the Primary server?

    Thursday, July 18, 2013 1:36 PM
  • This (powershell) will only work on CM12 SP1.

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, July 18, 2013 2:00 PM
  • I called PSS on this one.  The DP that had been deleted was still in WMI.  Deleted it from WMI and Data Gathering ran successful.

    • Proposed as answer by willbar Saturday, July 20, 2013 12:18 AM
    Saturday, July 20, 2013 12:18 AM