locked
missing templates for a new page creation RRS feed

  • Question

  • At my previous place of employment, when I created a new SP site, I would be presented with a list of templates and I could select my layout.  Having changed employers, the SP server was handed to me preinstalled.  Here when I create a new SP site, there is no list of templates; it creates a site with two columns.  I think that somebody has forgotten to install the templates.   Also, when I access Site settings > Look & Feel there is no option "Page layouts and site templates" which various google searches says there should be.

    Q1.  Can I install the missing templates from the SP disk?  (I've had a look but I can't see anything obvious on it.)

    Q2. How do enable the "Page layouts and site templates" option?

    Thanks a million!

    Thursday, June 21, 2012 11:58 AM

Answers

  • Did you activated corresponding Features?

    Check the appropriate "Site Collection Features" are activated on that site.

    (both form "Site Collection Features" - Site Collection Administration  and "Manage Site Features") 

    For Ex: "SharePoint Server Standard Site Collection features", "SharePoint Server Standard Site features", Team Collaboration Lists,..

    • Marked as answer by mlw-kedst Friday, June 22, 2012 1:35 PM
    Thursday, June 21, 2012 12:06 PM
  • As bobyThomas123 suggested, its a feature issue,

    make sure you have the right features enabled, for example to have page layouts and site template you must turn on SharePoint server publishing infrastructure @ site collection features and enable SharePoint server publishing on sites level.

    you CANT install templates off the SP setup disk AFAIK! but if you feel something is missing and shouldnt be, run the configuration wizard psconfig UI, but as i said those templates have relevant feature that must be enabled in order to show up, depends on what you need.

    Good luck


    Aabed Yassine - Systems Engineer If my answer helped you please Vote As Helpful, if my answer solved your problem please Mark As Answer.

    • Proposed as answer by AaYassine Thursday, June 21, 2012 12:23 PM
    • Marked as answer by mlw-kedst Friday, June 22, 2012 1:35 PM
    Thursday, June 21, 2012 12:22 PM

All replies

  • Did you activated corresponding Features?

    Check the appropriate "Site Collection Features" are activated on that site.

    (both form "Site Collection Features" - Site Collection Administration  and "Manage Site Features") 

    For Ex: "SharePoint Server Standard Site Collection features", "SharePoint Server Standard Site features", Team Collaboration Lists,..

    • Marked as answer by mlw-kedst Friday, June 22, 2012 1:35 PM
    Thursday, June 21, 2012 12:06 PM
  • As bobyThomas123 suggested, its a feature issue,

    make sure you have the right features enabled, for example to have page layouts and site template you must turn on SharePoint server publishing infrastructure @ site collection features and enable SharePoint server publishing on sites level.

    you CANT install templates off the SP setup disk AFAIK! but if you feel something is missing and shouldnt be, run the configuration wizard psconfig UI, but as i said those templates have relevant feature that must be enabled in order to show up, depends on what you need.

    Good luck


    Aabed Yassine - Systems Engineer If my answer helped you please Vote As Helpful, if my answer solved your problem please Mark As Answer.

    • Proposed as answer by AaYassine Thursday, June 21, 2012 12:23 PM
    • Marked as answer by mlw-kedst Friday, June 22, 2012 1:35 PM
    Thursday, June 21, 2012 12:22 PM