locked
SFT_MNT / Parse Items Problems RRS feed

  • Question

  • Hi all,

    im running into a very odd appv (4.5) problem.

    Q: is already used as network drive in our environment, so we decided to use the V: Drive instead for softgrid.

    Now I'm actually sequencing Microsoft Visio 2007 and i need to set the templates folder to Q:\Visio\Templates.

    But the sequencer always replaces the "Q:" String to the %SFT_MNT% Variable and this ends up into, logically, V: Drive on the Client Machine.

    And yes, I'm sequencing to the V: Drive too.

    Ive already tryed the following:
    - Adjusted the InstallDrive Registry key on the sequencer VM -> No Success
    - Tryed to adjust the project file (SUBSTITUTION Pattern) and the default.sprj -> No Success


    has anyone a solution?

    any help would be appreciated.

    Thanks in advance,

    Fabio
    Friday, May 29, 2009 9:21 AM

All replies

  • Hello,

    Softgrid had some really funny issues with "hardcoding stuff".
    The SMS-connector required a Content path for example that had to be _named_ Content. Note the capital C.

    Anyways, I suppose this is a registry-key somewhere - no possibility to perform a correction afterwards?
    (as a quick workaround..)

    /Znack
    Friday, May 29, 2009 9:29 AM
  • Hi znack,

    thank you for your fast reply.

    unfortunalety not, the string will be immediality replaced by %SFT_MNT%.

    anyone knows why my "manual" changes to the project file (SUBSTITUTION Pattern's) will be ignored at all?

    I'm really starting to get frustrated! =(
    Friday, May 29, 2009 9:35 AM
  • Unfortunately my machines are packed up for a road trip so I can't check this out.  It has been a while since I sequenced to anything but Q:, but this used to work.  You have me curious.  I will set up a test next week using the latest release 4.5.1 (CU1) and see if I have the same issue.

    My assumption is that the templates folder setting is a registry settting, and that the values look OK in the sequence editor but you have this issue on the client.  You might check the Virtual File System Tab for a mapping to delete.
    Friday, May 29, 2009 2:12 PM
    Moderator
  • Hi Tim,

    Exactly, the registry key is a plain text value (REG_SZ).
    But the sequencer already shows it as "%SFT_MNT%\Visio\Templates".

    If i try to replace that that value with Q:, the sequencer automatically replaces the value.

    Tuesday, June 2, 2009 3:24 PM
  • Hello,

    I just checked the parse-items tab on my sequencer and thought of something.
    There are a couple of values for SFT_MNT and they seem to be case sensitive.

    Have you updated all of them?
    (default; Q:,q:,q:\app.001,Q:\APP.001 etc etc etc)

    /Znack
    Wednesday, June 3, 2009 12:58 PM
  • I tried the following

    - Change the "Install Drive" in HKLM\Software\Microsoft\SoftGrid\4.5\Sequencer\Configuration to V:
    - Open the Sequencer
    - go to the "Exclusion items" tab of the Options and "save as default" this list. This will generate a "default.sprj" in the Sequencer's installation folder. Close the Sequencer
    - open the default.sprj and search&replace Q: by V: Save the file (Save as... UNICODE encoding to be sure)
    - open the Sequencer: Check: BUSTED

    but I did not succeed either :-(

    You could try to install the application to the c: drive (thus everything is "VFS"ed. Then, the difference between the Seqeuncer's Mount Point and the Client's Mount Point should not be an issue (because you can be quite sure thet the application installer did not wirte "Q:\something" in any of its configuration files.
    BUT this way does not follow MSFT's best practices
    Falko
    Thursday, June 4, 2009 4:37 PM
    Moderator
  • You can try one more thing try to change the sft_mnt from the sprj file once the virtual app is saved and then try to publish it. I will also try it on my machine and see what happens.
    GNU developer by choice ....
    • Proposed as answer by znack Tuesday, February 22, 2011 6:22 AM
    • Unproposed as answer by Aaron.ParkerModerator Saturday, November 17, 2012 3:27 PM
    Friday, June 12, 2009 5:58 AM
  • ...or just put the templates inside the package if they don't change much.

    Thursday, June 18, 2009 12:35 AM
    Moderator
  • Now I'm actually sequencing Microsoft Visio 2007 and i need to set the templates folder to Q:\Visio\Templates.

    But the sequencer always replaces the "Q:" String to the %SFT_MNT% Variable and this ends up into, logically, V: Drive on the Client Machine.

    Is this in the virtual registry?

    /Kalle
    Friday, July 10, 2009 7:38 PM
    Moderator