locked
Outlook - MS Office identified potential security risk - Hyperlinks can be harmful - Continue? RRS feed

  • Question

  • I've seen this asked in other forum threads and on other sites without any satisfactory answers.

    I'm running Outlook in Office 365 under Windows 7.

    When I'm in a Task with some links in the text I periodically get the following:

    Microsoft Outlook Security Notice
    Microsoft Office has identified a potential security concern.
    This location may be unsafe.
      rtfimage://
    Hyperlinks can be harmful to your computer and data. To protect your computer, click only those hyperlinks from trusted sources.
    Do you want to continue?

    Then, if I click Yes, it inserts this into the body of my Task item:

    {HYPERLINK "rtfimage://"}

    Which, bizarrely enough, looks like plain text in the body but Windows seems unable to copy-paste into even Notepad.

    And it then pops open this window:

    Open the program you want to use to open this file:
    File: rtfimage:///

    I have searched the body of the Task item for "rtf" and for "image" and nothing shows up, and I don't have any "images" in it.

    This keeps happening. I guess I can keep saying "No" and proceeding but the popup periodically returns on its own, sometimes very often.

    Other threads on this subject that I've seen got no resolution other than perhaps modifying the registry.

    Is there possibly a more straightforward fix for this?

    Thanks!


    Jay

    • Moved by Perry-Pan Tuesday, October 30, 2018 6:36 AM
    Monday, October 29, 2018 9:16 PM

All replies

  • Hi Jay,

    >> Other threads on this subject that I've seen got no resolution other than perhaps modifying the registry.

    Do you mean the registry key “DisableHyperlinkWarning”?

    I’ve researched a lot and the registry key seems to be a direct way to disable the warning. Please try changing the registry to check the results.

    You can refer to the following steps:

    (Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Please refer to this article about how to back up and restore the registry in Windows)

    1. Press Windows Key + R combination, type put “regedit” in Run dialog box and hit Enter to open the Registry Editor.

    2. Navigate to the following location: (If it does not exist, create it.)

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Security

    3. Click Edit > New > DWORD Value. Name it as DisableHyperlinkWarning.

    4. Double click and set the value to 1.

    If you have more concern about this issue, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by JayTech55 Wednesday, October 31, 2018 6:04 PM
    • Unmarked as answer by JayTech55 Saturday, November 3, 2018 6:54 PM
    Tuesday, October 30, 2018 6:36 AM
  • Thanks, Perry.

    I've added it.

    I expect that will do it.



    Jay

    Wednesday, October 31, 2018 12:19 AM
  • You are welcome. Hope it works on your side.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, October 31, 2018 8:09 AM
  • The problem is back. And this time, unless I'm missing something, it didn't even wait to allow me to choose Yes or No to proceed and it just inserted that line:

    {HYPERLINK "rtfimage://"}

    And once it has inserted that, I cannot even select the text to delete it. (It appears as normal text but sure doesn't behave like it.) My only option is to close the Task item and say No to saving changes.

    Any other suggestions?

    Thanks!


    Jay



    • Edited by JayTech55 Saturday, November 3, 2018 7:51 PM
    Saturday, November 3, 2018 6:57 PM