locked
Can't Connect to Internet RRS feed

  • Question

  • Hi
    I am trying to connect a Windows 7 Computer to the internet
    through a adsl router/modem

    The modem connects my xp computer to the internet without any trouble.
    This Win7 computer has actually connected 2-3 times
    most of the time it will not
    The network card is on the motherboard it's a VIA Rhine II Fast Ethernet Adapter
    here's is some info

    Under
    Network
    Home Network
    No Interent Access

    Unidentified network
    Public network
    No Interent Access

    Under Properties
    The ipv4 shows settings - obtain automatically "for all of them"
    the ipv6 saids "In order to configure TCP/IP, you must install and enable a network adapter card" - obviously not seeing the adapter
    even with ipv6 turned off no connection

    For connection status
    IPv4 Connectivity - No Internet Access
    IPv6 Connectivity - No Internet Access

    If i try to "Set up an Internet connection"
    i get this message "connection failed with error 651"

    Have update my Ethernet driver too
    to a vista driver - VIA vista driver

    Oh win7 does see the adsl modem, it on the network area

    May just buy a cheap network card and plug it in!

    ok thanks



    Just turned on the comp to check something else, and this time it connected to internet
    but later when i turn it back on it probably wont be, time will tell
    trying to set up dual boot to see if the network adapter works under xp
    Monday, July 6, 2009 9:01 AM

All replies

  • For what it's worth, here's my one trick pony suggestion for "WinXP PC's connect, Win7 (Vista) doesn't":

    I found out the hard way that Vista and Windows 7 have a TCPIP performance autotuning feature, designed to take advantage of features in the TCPIP standard... that are not always implemented in routers (or weren't until recently).
    When communication about the tuning settings breaks down, your internet connection slows to a crawl, or stops altogether.

    First, try disabling the autotuning.
    1. Open the Command Prompt with administrator privileges. [Start, All Programs, Accessories, right-click Command Prompt, Run as Administrator]
    2. Type the following command and press Enter:  netsh interface tcp set global autotuninglevel=disabled
    3. Exit, and you're done

    If this works, you should try upgrading the firmware in your router (don't trust the router vendor's "Vista compatible" list - if your box is a couple of revisions old, just flash it anyway. But please make sure you have the right firmware for your particular version!)

    Once you've flashed the router firmware, you can turn autotuning back on using the same approach, but type
    netsh interface tcp set global autotuninglevel=normal
    instead.

    An alternative to doing the router firmware might be to borrow a friend's nice new router, and see if that makes a difference.  Or take the offending PC to someone with Vista and a working internet connection.

    Monday, July 6, 2009 7:33 PM
  • thanks
    will check that out
    my modem is a few years old now, i think
    as long as i can turn the autotuning on and off
    since my main comp is the xp one, and it works fine on the net

    unfortunately everyone i know is running xp
    thanks

    edited
    It working now
    but will wait to see if it keeps working
    thanks

    Nope stopped again
    Monday, July 6, 2009 7:44 PM
  • Ok
    Got my dual boot with win7/xp working
    xp has not problem connecting to the internet
    so it's the the network adapter
    it's only windows 7 that has the problem

    most times it will not connect
    occasionally it does,
    i haven't found a pattern to figure out when it does yet

    thanks
    Tuesday, July 7, 2009 10:23 AM
  • I'd suggest a more hardware oriented approach and cut it off at the source.

    Go into your network adapter properties and disable all offloading, flow control, etc.. Allow the software to take control of it - if its demanding it give all of it to it... assuming it has those options.
    Tuesday, July 7, 2009 8:57 PM
  • this is what it has under Adapter Properties/Advanced
    What should i try changing

    Flow Control - Disabled
    Interrupt Moderation - Enabled
    Network Address - Not Present
    Receive Buffers - 160
    Speed & Duplex Settings - Auto Negotiation
    Transmit Buffers - 160
    Wake Up Type - OS Controlled

    thanks

    EDIT
    thanks North7
    I "Disabled" the Interrupt Moderation and it connect straight away
    now i'll just wait and see if the next time i turn the comp. on, if it will connect again or not
    thanks


    EDITED
    Just turned the win7 back on
    and again
    NO CONNECTION
    damn

    OK
    just turn the "Wake Up Type - ALL"
    and i'm "Connected"
    again
    now i'll just wait and see if the next time i turn the comp. on, if it will connect again or not
    thanks


    EDIT
    it wont connect again

    this is ridiculous
    Wednesday, July 8, 2009 7:25 AM
  • ok

    here's the go now
    most of the time when i turn on the win7 comp
    it will NOT connect to the internet

    I have to change one or several of these setting to make it connect

    Flow Control - Disabled
    Interrupt Moderation - Enabled
    Network Address - Not Present
    Receive Buffers - 160
    Speed & Duplex Settings - Auto Negotiation
    Transmit Buffers - 160
    Wake Up Type - OS Controlled

    then
    when the comp goes off, next time it's on it won't connect
    so i have to turn the setting back, to get it to connect again

    obviously i shouldn't have to do this to get a connect to the internet
    it's ridiculous

    obviously the answer lies in the differences in the way win7 connects
    compared to the way xp connects
    since xp connect everytime
    Thursday, July 9, 2009 6:20 AM
  • Well I been playing with Safe Mode in Win7
    And it connects to the internet "Everytime"

    It just wont connect in normal mode, without me play around with the setting


    I can't help but notice no "mod" has replied to this thread

    So i'm assuming that know one has a clue on how to fix it!
    Hence microsoft is unable to fix all the networking problems that everyone is having!

    Not good for future sales
    i'll certainly be sticking with XP unless all networking problems are fixed
    Saturday, July 25, 2009 3:48 AM
  • still no solution to this problem !!!
    Wednesday, September 16, 2009 7:04 PM
  • I just encountered a problem like this and it was due to an old copy of Bonjour services from Apple Inc. being just installed with another piece of software.  I updated the bonjour services to the 2010 version and the computer could see the internet again.

    Where I checked:

    c:/Program Files(or 'Program Files(x86)' for 64 bit editions)/Bonjour

    right click and go to properties

    If the version is pre 2010 update it

    http://support.apple.com/kb/DL999

    Hurray for sloppy code

    Hope this helps

    Friday, August 6, 2010 5:51 PM
  • After I did a Microsoft update, I got a 651 Error on my Dell Microsoft 7 PC using a wireless router. And I tried everything. But this is what worked. (I did the 'command prompt' thing that was suggested by another person and then turned it back to normal -- just thought I'd mention that in case it had any effect.) But I fixed the problem by 1st holding the F2 and FN (at the bottom of the keyboard) several times. Then going to the Control Panel, view network status and tasks (click), change adaptor settings (click), somehow my Broadband Connection was the default (there was a green check mark), disabled that, went to Wireless Network Connection that had a black X and enabled that. Nothing happened for awhile. And then as I was sitting there looking at it, the connection came up on it's own with my router name.
    Sunday, February 20, 2011 11:36 PM