Unable to import pfx/p12 certificate on Windows XP RRS feed

  • Question

  • When trying to import a PFX (.P12) certifcate on a Windows XP PRo, SP3 the following error message occurs:

    "An internal error occurred. The private key that you are importing might require a cryptographic service provider that is not installed on your system."

    This happens with all but one user account, on all computers used to test the fault. All computers are of exactly the same image, delivered via WDS. All test accounts that fail to import the certificate orginate from a copy of the same windows base profile. The single account that does import the certificate is from the same Windows base profile and can complete the operation on the same computers with which the other accounts failed. A copying the windows profile from the account which does work, to one of the accounts which did'nt, results in that account then being able to import the certificate; in other words, it does not appear to be the computer build and is most likely a problem with the user profile.

    I've looked at a number of forums which require the following:

    Setting permissions on the All users "Machinekeys" folders, deleting the Type001 key in the list of providers within the registry, re-registering all of the .dll files used in the process,

    but they have all failed.

    Does anyone know where I can go with this or try anything else?

    Many thanks in advance - Hopefully!


    Saturday, January 22, 2011 10:46 AM

All replies

  • Seems silly but

    have you checked the system date/time?

    The routers date and time? Using a server? has this systems time been reset?

    Checked the clock battery?

    If out of range. Your system might be killing the import. Been with us since the xp sp1/gold days.

    If you find this helpful, please mark as answered. Or post back your results.

    Checked the 

    The certificate will autorun after double click.
    1 - "Welcome to the Certificate Import Wizard" click Next
    2 - File Import - File name: <path>\VlanWireless2007.P12 - Click Next
    3 - Password - Only the "Include all extended properties" is selected -
    Click Next
    4 * A - Certificate Store - "Automatically select the certificate store
    based on the type of cerificate" is selected as requested by the University
    given manual.
    4 * B - But I also have tryed "Place all certificates in the following
    store" and I recieved a error message. The steps where the following.
    * B - Clicked on Browse
    * B Select Certificate Store - I checked "Show Physical Stores" then double
    clicked on "Trusted Root Certification Authotities" and selected "Smart Card"
    hitted "OK". (Will go back on Certificate Store) and clicked Next.
    * B Completing the Certificate Import Wizard - Clicked Finnish
    * B A small window pop open with the following text
    " The import failed because the store was read-only, the store was full, or
    the store did not open correctly."

    Read only set?



    Friday, March 11, 2011 5:22 PM