locked
2007 > 2012: Data Gathering Status Error. RRS feed

  • Question

  • Hey,

    I'm working within a test environment attempting to migrate a test instance of SCCM 2007 to 2012 but falling at the first hurdle. After specifying the active source hierarchy and setting the access accounts to the domain admins account and then hitting "Ok" the Data Gathering Status process begins and then fails. The migmctrl.log file contains the following entry:

    ERROR: Migration Manager: Error occurred when trying to make sql connection to SQLSERVER. Contact product support for help. Error Information - 2146232060, a network-related or instance-specific error occurred while establishing a connection to sql server. The server was not found or was not accessible. Verify that the instance name is correct and that sql server is configured to allow remote connections. (Provider: Named Pipes Provider, error:40 - could not open a connect to sql server) ---> System.Data.Sqlclient.sqlexception:a network-related or instance-specific error occurred while establishing a connection to sql server.

    I'm guessing that this is either an SQL permissions issue or a SQL configurational issue. Unfortunately we have a small team containing no DBA and our granular SQL knowledge is weak at best. Any assistance would be greatly appreciated!

    Kind regards.


    M Tipler

    Monday, December 3, 2012 2:20 PM

Answers

  • Hey Jason,

    Yes - it was an SQL issue - although I have hit another wall with my SCCM migration for which I'll be creating a post shortly.

    Changing the SQL service acccount to a domain account rather than local system account and then setting SPN for the domain account resolved my issue. Any one suffering similar issues please find details within the URL below.

    http://technet.microsoft.com/en-us/library/bb735885.aspx


    M Tipler

    • Marked as answer by Mattyt123321 Wednesday, December 12, 2012 1:50 PM
    Wednesday, December 12, 2012 1:50 PM

All replies

  • Worth mentioning that there are no active firewalls between each node. I've also enabled TCP/IP within SQL configuration manager. Since doing so I'm now getting a different error within migmctrl.log...

    ERROR: Migration Manager. Error occurred when trying to make sql connection to SQLSERVER. Contact product support for help. Error information - 2146232060, login failed. The login is from an untrusted domain and cannot be used with Windows Authentication.


    M Tipler

    Monday, December 3, 2012 2:44 PM
  • does the domain admin account that you specified in the source hierarchy wizard have full privileges in your old SCCM 2007 environment?

    if you are not sure, you can check this also from the SCCM 2007 console

    Monday, December 3, 2012 2:52 PM
  • Hey! Yes the domain admin account has full privs on the 2007 site.


    M Tipler

    Monday, December 3, 2012 3:01 PM
  • Also worth mentioned that

    17806 - SSPI handshare failed with error code 0x8009030c while establishing ac connection with integrated security; the connection has been closed.

    AND

    18452 - Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

    These are being logged upon the 2007 site server containing the target DB's.


    M Tipler

    Monday, December 3, 2012 3:10 PM
  • "The login is from an untrusted domain and cannot be used with Windows authentication"

    So is the new 2012 site server in an untrusted domain?


    Jason | http://blog.configmgrftw.com

    Monday, December 3, 2012 3:13 PM
  • Hey Jason - thanks for your response.

    Nope - it's in the same domain as the 2007 site server.


    M Tipler

    Monday, December 3, 2012 3:18 PM
  • Open SQL Management Studio on the CM12 server and see if you can connect to the CM07 SQL server (using the same credentials as the migration job is using).

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, December 3, 2012 3:53 PM
  • Hi Torsten - Thank you for your response. When attempting to connect through management studio using windows authentication I'm receiving the same "The login is from an untrusted domain" error.

    M Tipler

    Monday, December 3, 2012 3:59 PM
  • When I open management studio upon the 2007 site server and connect using the same credentials it allows me to connect!?! Remote server connections are enabled as well. Completely confused.

    M Tipler

    Monday, December 3, 2012 4:21 PM
  • Even just tried removing the 2010 site server from the domain and re-added it. Made no difference. :(

    M Tipler

    Monday, December 3, 2012 4:40 PM
  • You mean the 2012?

    Have you reviewed the security log on the system hosting the 2007 DB?


    Jason | http://blog.configmgrftw.com

    Monday, December 3, 2012 5:03 PM
  • Hey Jason,

    Yup - I mean 2012. Well spotted.

    Unfortunately the windows security logs on the 2007 site system contain nothing of interest.


    M Tipler

    Monday, December 3, 2012 6:43 PM
  • Hey Jason!

    Thank you once again for your assistance.

    http://www.secretgeek.net/boring_sql_one.asp

    I've checked the above and this isn't the issue.

    http://blog.michelbarneveld.nl/michel/archive/2009/11/11/login-failed-microsoft-sql-server-error-18452.aspx

    I saw this yesterday and attempted solution 2 by modifying the registry upon the 2007 site server - unfortunately this made no difference.

    As for solution 1 (below). I was more than a little unsure about this. I'm not entirely sure what an SQL service class is and where to find this information. So I imagine a pretty poor stab at what my command structure would be is as follows:

    Setspn -A SQLSERVICECLASS?/2007siteserverFQDN:1433 2007hostname\local service

    Solution 1 - Register a SPN for the SQL Service

    Execute the following command to register a SPN

    SetSpn -A MSSQLSvc/sql.mb.local:1433 MB\sql_service

    (Where MSSQLSvc is the service class for SQL Server,  sql.mb.local is my dns entry, 1433 is the port my sql instance is listening on and MB\sql_service is the account sql server is running as)

     

    Very kind regards.


    M Tipler

    Tuesday, December 4, 2012 10:26 AM
  • Not sure exactly what command you ran?

    Did you run

    Setspn -A SQLSERVICECLASS?/2007siteserverFQDN:1433 2007hostname\local service

    or

    SetSpn -A MSSQLSvc/sql.mb.local:1433 MB\sql_service


    Jason | http://blog.configmgrftw.com

    Tuesday, December 4, 2012 4:05 PM
  • Hey Jason,

    I think I may have got to the root of the issue. The VM used for the 2012 site was not sysprepped. Therefore it had the same SID as the 2007 site (as it was deployed from the same base VM). Starting the 2012 site from scratch. Thank you greatly for all of your assistance.  I won't mark this as the answer until I can confirm that this was the cause of the issue.


    M Tipler

    Tuesday, December 4, 2012 4:09 PM
  • Doh! Really! This is 2013.

    Jason | http://blog.configmgrftw.com

    Tuesday, December 4, 2012 4:14 PM
  • Hahaha I know, I know. Our test environment is archaic. We have a VMWARE production environment where a new SID is generated automatically when you deploy a VM from a template.

    Once again - thank you for your assistance. Muchos appreciatos.


    M Tipler

    Tuesday, December 4, 2012 4:26 PM
  • Well - rebuilt the 2012 server having sysprepped. Still getting the Login Failed. The login is from an untrusted domain and cannot be used with Windows Authentication.

    So using SQL management studio from the 2007 box, I can connect to the 2012 box. But when attempting to connect to the 2007 box from 2012 using management studio it fails and I'm still getting the following within the SQL error logs on the 2007 box:

    log 1 - SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed.

    log 2 - Error 18452, Severity:14, State:1.

    log 3 - Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

    This is driving me nuts now.


    M Tipler

    Tuesday, December 11, 2012 12:43 PM
  • At this point, what you are seeing looks to be more of a SQL specific issue and you may get a better answer in a SQL forum.

    Jason | http://blog.configmgrftw.com

    Wednesday, December 12, 2012 4:00 AM
  • Hey Jason,

    Yes - it was an SQL issue - although I have hit another wall with my SCCM migration for which I'll be creating a post shortly.

    Changing the SQL service acccount to a domain account rather than local system account and then setting SPN for the domain account resolved my issue. Any one suffering similar issues please find details within the URL below.

    http://technet.microsoft.com/en-us/library/bb735885.aspx


    M Tipler

    • Marked as answer by Mattyt123321 Wednesday, December 12, 2012 1:50 PM
    Wednesday, December 12, 2012 1:50 PM