locked
External Firewire drive problem. RRS feed

  • Question

  • Hi,

    My W7 Beta system has an firewire card with VIA chipset connected to an external hard drive in an ULTRA enclosure.

    Booting up W7 there is no error message. The drive is shown in "My Computer" but when you go to access the drive W7 says the drive is not formatted (it is formatted). If I "safely remove the hardware" then shut down the drive, then repower the drive, the drive becomes accessible. 

     

    This does not occur with W98, W2K, or Xp.

    Thursday, January 29, 2009 4:10 PM

Answers

  • Hello,

     

    I'd suggest reinstall the USB driver using the Compatibility Wizard. Remove that hardware device in Device Manager, right-click on the driver executable/installer file and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver. In addition, you can use the Windows XP driver for testing.

     

    If the problem still persists, please understand that Windows 7 is a new operating system (only the beta version) and whole driverstore has been reprogrammed; some old driver is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the vendor company to upgrade their device driver. Thanks for your time and understanding!

     

    Good Luck!

    • Marked as answer by Andy Song Wednesday, February 11, 2009 4:02 AM
    Friday, January 30, 2009 10:31 AM