none
Start Exchange Server Powershell as Administrator RRS feed

  • Question

  • Hello,

    Our company just enabled MFA for Exchange. I am currently an admin and trying to obtain messagetrace for users. Before MFA I can do it with ease but now with it open I cannot do it in my current PowerShell. I download the MFA enabled Powershell and connect to IPPSSession but if I try running any cmdlet command, PowerShell doesn't let me because I don't use it as an Admin.

    My dilemma is:

    Windows PowerShell: Can start as Admin / Not compatible with MFA

    Exchange PowerShell: Cannot Start as Admin / Compatible with MFA

    I tried remotesign and force remotesession but to no avail.

    Any ideas?

    Friday, October 13, 2017 4:20 PM

Answers

  • Hi,

    Here's my current Powershell Version

    Name                           Value
    ----                           -----
    PSVersion                      5.1.15063.0
    PSEdition                      Desktop
    PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
    BuildVersion                   10.0.15063.0
    CLRVersion                     4.0.30319.42000
    WSManStackVersion              3.0
    PSRemotingProtocolVersion      2.3

    Hi, it seems temporarily disabling MFA allows both PowerShells to work properly. I'll just stick with my regular PowerShell for now.

    Thanks,

    Thursday, October 19, 2017 1:19 PM

All replies

  • You do not need to run any cmdlets as admin, it works just fine in normal session too. Are you using the latest version? Which cmdlets fail, can you give an example?

    Anyway, to have the MFA-enabled one run as admin, simply right-click on it and select Run as Administrator.

    Friday, October 13, 2017 6:53 PM
  • Hi,

    Here's my current Powershell Version

    Name                           Value
    ----                           -----
    PSVersion                      5.1.15063.0
    PSEdition                      Desktop
    PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
    BuildVersion                   10.0.15063.0
    CLRVersion                     4.0.30319.42000
    WSManStackVersion              3.0
    PSRemotingProtocolVersion      2.3

    Hi, it seems temporarily disabling MFA allows both PowerShells to work properly. I'll just stick with my regular PowerShell for now.

    Thanks,

    Thursday, October 19, 2017 1:19 PM
  • Thanks for your response and sharing.

    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 23, 2017 10:00 AM
    Moderator
  • Right-clicking on the Exchange Online Powershell Module and choosing 'Run As Administrator' results in the module not opening. Running it normally does not fail, however I am unable to Set Remote Policy as the module is not being run as an Admin.  Therefore I am unable to open a PSSession...  Additionally, if I open the file location of the Exchange Online Powershell Module, when I right-click on the App, 'Run as Administrator' is not an option.

    Windows Powershell and Powershell ISE have no issues being run as administrators. 

    Wednesday, June 12, 2019 4:32 PM
  • Usually you don't need to 'run as administrator'. Since all Exchange is a 'remote' session, even on local machines, just launch your favorite editor, pass credentials, then do your tasks. I rarely ever run PS in admin mode, since I pass proper elevated credentials to complete the needed steps.


    NOTICE: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Tuesday, July 2, 2019 2:39 AM