none
cbengine crashes everytime trying to recover data from online cloud RRS feed

  • Question

  • hi,

    we have a dpm server that is backing up fine , however we cannot recover data from he cloud - everytime we try the cbengine crashes.

    Problem signature:

    P1: cbengine.exe
    P2: 2.0.9118.0
    P3: 5ab8ef8e
    P4: OnlineAgent.dll
    P5: 2.0.9118.0
    P6: 5ab8f066
    P7: c0000005
    P8: 0000000000066c0c
    P9: 
    P10: 

    tried updating to the latest azure backup agent, made no difference 

    we can recover from disk - which is ok for a few days , but everything in the cloud is not accessible!

    any pointers ?

    Thanks

    mrP

    Friday, November 9, 2018 12:19 PM

All replies

  • Hello!

    You could try updating the Microsoft Azure Recovery Services agent first to the latest version to see whether it helps.

    You can download it from here: http://aka.ms/azurebackup_agent

    Here’s also a Wiki page that lists the different versions:

    https://social.technet.microsoft.com/wiki/contents/articles/52073.microsoft-azure-recovery-services-azure-backup-agent-list-of-agent-versions.aspx

    Best regards,

    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 9, 2018 12:49 PM
  • leon,

    already on version 2.0.9118.0 which is April 2018 - 

    there is a version 2.0.9145.0 in that list but no download link or kb article for it.

    how do you try that one?

    mrP

    Friday, November 9, 2018 2:54 PM
  • the latest from the download link is 2.0.9118.0 which is the same as from the azure portal.

    mrP

    Friday, November 9, 2018 2:57 PM
  • You can also try to download it from the Azure Portal.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 9, 2018 3:27 PM
  • mmmh, i see that - i installed it with the dpm console closed and the version that's running is the .9118 one, 

    do you have to reboot after installing or shutdown services prior to installing?

    mrP


    • Edited by mrP Friday, November 9, 2018 6:27 PM
    Friday, November 9, 2018 6:27 PM
  • ok, got the latest version installed, run recovery and it failed with the same error ID:104 
    Friday, November 9, 2018 6:55 PM
  • details for logs

    10C8 0F04 11/09 18:49:00.746 41 RecoveryWizard.cs(789) NORMAL Starting recovery wizard...
    10C8 0F04 11/09 18:49:09.588 41 AlternateTarget.cs(260) NORMAL Retrieved 10 production servers from DPM
    10C8 13EC 11/09 18:49:12.101 68 Rorn.cs(476) NORMAL RORN Job: Triggering Job: 6675b2d9-2843-4cd1-afc5-808cc8c02774
    10C8 13EC 11/09 18:49:12.103 16 jobmanagerservicesproxy.cpp(149) NORMAL JobManagerServicesProxy::TriggerJob(). jobDefID=6675b2d9-2843-4cd1-afc5-808cc8c02774
    10C8 1294 11/09 18:49:12.342 68 RornTaskDef.cs(495) NORMAL RORN TaskDef: Task 627fffc8-1963-499c-b04a-0fe0b3da8481 created
    10C8 1294 11/09 18:49:12.343 68 RornTaskDef.cs(480) NORMAL RORN TaskDef: Task 627fffc8-1963-499c-b04a-0fe0b3da8481 started
    10C8 1294 11/09 18:49:17.643 68 RornTaskDef.cs(488) NORMAL RORN TaskDef: Task 627fffc8-1963-499c-b04a-0fe0b3da8481 stopped with error code 0
    10C8 1294 11/09 18:49:18.596 08 configmanagerservicesproxy.cpp(75) NORMAL ConfigurationManagerServicesProxy::DeleteInquiryResultTables(). taskId=627fffc8-1963-499c-b04a-0fe0b3da8481

    good news is that cbengine does not seem to be crashing anymore, but bad news is still can't recover any data from azure!

    mrP

    Friday, November 9, 2018 7:16 PM
  • You mentioned "everything is not accessible" could you elaborate on what you are trying to recover?

    Also what DPM version and build are you running?


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 9, 2018 10:29 PM
  • I cannot recover any of the data stored in azure. I can select backups but the recovery process fails with error I’d 104 Dpm is 2016, build number 1807 Thx
    Friday, November 9, 2018 10:33 PM
  • Could you explain the steps you take when trying to recover? If possible post a screenshot as well.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 9, 2018 10:45 PM
  • i do the usual select a date later than a week- which only show online as an option to recover from , drill down to a folder/file and select a local temp folder on the dpm machine- start the recovery and after 5 seconds error occurs - 

    same process but select a disk recovery point works fine 

    azure shows that i have 40+ backups in the cloud, but i cannot access any of them!

    mrP

    Monday, November 19, 2018 7:21 PM
  • Nothing out of the ordinary indeed, has there been any recent changes in your DPM environment?

    Could you provide a screenshot of the exact error message?


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, November 22, 2018 9:11 AM