After creating new document library, ECB is missing for added documents RRS feed

  • Question

  • I have an existing Sharepoint site. Other (existing) document libraries show the full edit control menu when the view has the "Name (linked to document with edit menu)" column activated. However, now when creating a new document library with the same view settings, the full ECB menu is not available. Instead, the only menu options are "View Properties", "Compliance", "Add to My Links", and "Send To".

    I can't figure out why these newly created document libraries are behaving differently when it comes to that edit menu.

    Any ideas on where I can check?


    • Moved by Mike Walsh FIN Wednesday, May 25, 2011 9:05 AM Not a programming question so why post it to the programming forum? (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Tuesday, May 24, 2011 10:57 PM

All replies

  • Can you check the permissions for the new document library? Compare the permission settings against the existing document library where you can see the complete menu. Also, check if the permission inheritance is broken in any of these document libraries.
    Wednesday, May 25, 2011 6:54 AM
  • Suresh,

    Thanks for the reply. The permissions for the document library are the same as for other libraries where the edit menu is working as expected. As a site administrator, even I can not see the edit menu on these newly created document libraries.

    I also checked the properties\settings for the webpart on both libraries, and they are the same.


    Wednesday, May 25, 2011 7:41 PM
  • I wanted to follow up with you guys regarding the ECB not displaying corretly. I have the same issue. In fact, after upgrading from wss 3.0 to SPF 2010, I have existing doc libraries working perfectly with the full ECB menu items but if I create a new document library the ECB does not display.

    It is affecting doc libraries, announcements, tasks, etc. All of them show 2 choices on the ECB. Download Item and View properties. That's it.

    I did notice that someone had messed with the default content type Document. I have since renamed back but doesn't seem to make a difference. I can add custom ECB items, apply the ECB to other colums but SharePoint will not display the correct ECB menu choices. Any ideas? Permissions are fine.



    Saturday, September 17, 2011 9:05 AM
  • Hi,

    Follow this:

    1. Save your existing document library as template without data.

    2. Use this to create new one.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Sunday, September 18, 2011 11:30 AM