none
Create Project trough enterprise project type with templates does not send notification to team member(email) when published RRS feed

  • Question

  • Hi All,

    I encountered this issue in my client site when implementing project server 2013.

    At First I thought that this issue occurred intermittently , sometimes project creation (create project from PWA- assign resources with team member -save and publish) trigger email notification to the assigned team member and sometimes not. (new task notification)

    I have checked with our infrastructure team and verify that I use the right SMTP server address and port , and cross check with them for their side configuration (exchange) , we did not find anything wrong on both settings.

    and then we found out that the failed notification email comes from project creation using defined project templates in an enterprise project type, even from a project that consist of template schedule , we added new task on that project and assign a team member on that task that resulted with notification sent to the team member, but not with task that comes from templates.

    can someone help us on this issue, or is there any CU on this?

    I appreciate any comments and feedback, Thanks for your attention!

    Regards,

    Nugroho

    EPM implementator

    Friday, December 13, 2013 9:06 AM

Answers

  • Could you please update your serve from Oct 2013 CU along with Project professional 2013 oct CU

    kirtesh

    • Marked as answer by NugrohoAldo Thursday, December 3, 2015 6:31 AM
    Wednesday, December 18, 2013 9:50 AM

All replies

  • Hi,

    Insure your SMTP is working fine. When you create project from EPT make sure that you build your team for that project then assign resource for task if required change the start date and finish date then save and publish the project. 

    Also make sure to configure alerts and reminder and notification for PWA.

    Check for Resource who is not getting notification whether alerts and reminder is configured or not.


    kirtesh

    Friday, December 13, 2013 9:13 AM
  • Dear Kirteshtiw,

    Thanks for your response,

    I did all of that, SMTP working fine as i can always trigger new task notification when assigning team member to task that were not from project templates (create new task on PWA) .

    for configuration, i did check alerts and reminder settings in PWA settings and everything should be correct,

    Thanks again for your attention

     

    Friday, December 13, 2013 9:47 AM
  • When you chnage the start date or finish date and assign a new resource to the existing EPT task then it send notification or not.

    also check the Email address of resource is correct or not whoever is not getting notification.

    If not then 

    delete and recreate the template 


    kirtesh


    • Edited by Kirteshtiw Friday, December 13, 2013 9:58 AM
    Friday, December 13, 2013 9:55 AM
  • Apparently re-create the template did not solve the problem , but i did find some clue and more strange behaviour.

    When I did publish for the first time , no notification sent EXCEPT for new task (not from template)

    I did remove the assignment  from the task created from template and publish the project, no notification ( normal behaviour by design i assume) THEN i reassign to the same task and publish the project resulting : Notification Sent

    Any leads from this? changing the start/finish dates from the task templates did not trigger the notification.

    I purposely use 1 account (1 email address), pilot account to test this behaviour.

     

    Friday, December 13, 2013 10:22 AM
  • I am assuming while creating Template you are just saving it as template not published it.

    When you create a new project from template for some of the task you remove the resources then assign resource to those tasks then save and publish the project.

    Or create a new task under summary task assign resource then save and publish the task you notification sent to the resource means it is working.


    kirtesh

    Friday, December 13, 2013 10:29 AM
  • Kirteshtiw,

    Yes we did create the template from project professional and as far as i know, the only way to create template is just to save it, no option to publish the template.

    "

    When you create a new project from template for some of the task you remove the resources then assign resource to those tasks then save and publish the project. <--there are no resources assigned from the template, when i assign resources (new assignment) this will not trigger notification

    Or create a new task under summary task assign resource then save and publish the task you notification sent to the resource means it is working. <--new task (not from template ) also trigger the notification

    "

    Friday, December 13, 2013 10:39 AM
  • Normally when i create template i put dummy resources and i create only summary task and save the template.

    I create new sub task assign resources then save and publish the project.


    kirtesh

    Friday, December 13, 2013 10:48 AM
  • When you create new task , that falls to category task that are not from template so (in my case) it will trigger the notification.

    Regards.

    Friday, December 13, 2013 10:51 AM
  • Yes it will be new task not from template.

    Then template is behaving as expected.  


    kirtesh

    Friday, December 13, 2013 10:53 AM
  • so that means the template and it's task will not trigger notification except if i assign - reassign the resource?

    I think this is not the right behaviour by design.

     

     
    Friday, December 13, 2013 11:02 AM
  • when you create project from Template and publish it . Notification is not going because project server send notification when any kind of change happen into the project plan. It means if you publish the project first it will not send notification but after that if you will open the project and make some change ( reassign resource or change the dates ) it will send the notification.

    http://office.microsoft.com/en-in/project-server-help/alert-or-remind-me-of-changes-with-e-mail-notifications-HA010102074.aspx


    kirtesh

    Friday, December 13, 2013 11:04 AM
  • Kirteshtiw,

    yes , but i think it should fall to New assignment category , as i use the template with no resource, and then i assign new resource to that task and publish.

    Friday, December 13, 2013 11:11 AM
  • Yes, You are right it will fall to new assignment category. are you having same patching level for Project server and MPP . 

    Also which CU do you have for your project server.


    kirtesh

    Friday, December 13, 2013 11:19 AM
  • Kirteshtiw,

    I'm Running project server 2013 version 15.0.4420.1017 (edited)

    and I never run any CU or hotfix as i couldn't find CU that contain issues fixes for my case ( so far )


    • Edited by NugrohoAldo Friday, December 13, 2013 11:48 AM incorrect version
    Friday, December 13, 2013 11:31 AM
  • Do you have any custom code for email notification ??

    kirtesh

    Friday, December 13, 2013 11:38 AM
  • Nope , no any custom code in our implementation
    Friday, December 13, 2013 11:40 AM
  • Could you please update your serve from Oct 2013 CU along with Project professional 2013 oct CU

    kirtesh

    • Marked as answer by NugrohoAldo Thursday, December 3, 2015 6:31 AM
    Wednesday, December 18, 2013 9:50 AM